Roon Server on QNAP QTS 4.5.1 Situation

Hello everyone,
I was trying to figure out an issue with QNAP’s QTS 4.5.1 in the last days.
The situation with QTS 4.5.1 is, that it is shipped with a version of ffmpeg, that does not support AAC decoding/encoding, which results in the inability to play AAC encoded files or radio streams in Roon.

Today I received a message from QNAP:

Our RD team has told us the way to resolve this issue is to use CAYIN MSP’s ffmpeg. The path for CAYIN’s ffmpeg is below:
CAYIN MSP’s ffmpeg path : /usr/local/cayin/bin/ffmpeg

This would mean a user had to install another Third-Party App before Roon Server is able to play AAC encoded material (which I am not a fan of, as it means there is a dependency of a third party app and Roon Server needs to depend on it.)

Unfortunately I can’t provide ffmpeg in the Roon Server app itself, due to licensing issues with the AAC codec, but I was thinking of a similar approach to ffmpeg on ROCK: A user can manually provide ffmpeg, by putting it in a “Codec”-folder in Roon Server’s storage path.

If you are currently affected by this issue, please send me a PM.


Users not only have to install CAYIN MSP but also need to obtain and activate a license (basic is free). Also the old CodexPack is no longer supported from QTS 4.5.1 onward - CAYIN MSP seems to be the replacement app. It’s used for thumbnail generation and transcoding by the multimedia console.

PS: While QTS naged users for quite a while to install CAYIN MSP, QNAP somehow failed to inform the users about the reason behind it IMHO. So will future devices and new installs have CAYIN MSP preinstalled by default?

There is a temporary solution. It is posted here:

For me it worked (QNAP TS-453A)


Are there any instructions to do this?

The instructions were literally in the post right above yours.

pls take video to explan clearly any instruction to do this, thanks.

hi @shing_hong_chan,
please check your private Messages. :wink:

I am using a Qnap 451 and am having the same problems streaming the BBC Radio AAC HiRes programmes. Can you elaborate on your last but one para where you suggest putting a codec in the Srver storage path? Is it possible to get the NAS to play ball?

I’m getting this too. At first I thought it was an issue with FiP not having their AAC streams active. Then I saw this. Yep. No AAC connectivity. WTF?

It’s a qnap issue if you read the threads on the forum there are some workarounds or fixes. Apparently they didn’t include the right CODECS.

Continuing the discussion from Roon Server on QNAP QTS 4.5.1 Situation:

Hi Cristopher,
I have same problem with my TVS 873 and QTS No aac file streaming and no aac radio stations.Tried to change ffmpeg like P mentioned unfortunately is not working here. Did also a exchange with the ffmpeg from cayin and lost the abilty to stream mp3. Now I am in the initial status “only” a workday later. Looks like we have the problem: who is willing to solve the “licensing issues”. Qnap moved to Cayin…Roon? best Bernd

Is there going to be a permanent fix to this? I guess that question is best directed at @crieke

The workaround works of course, but it doesn’t survive a firmware update. Not the end of the world having to re-do it every time but a more elegant solution would be good.


The latest QNAP firmware upgrade did not lead to the loss of AAC… We were lucky I suppose

It did for me. I’d applied the fix in the previous version, but when I upgraded the fix had regressed and I had to apply it again.

Same for my. After firmware upgrade.
Had to re-apply the fix (by copying the correctly build FFMPEG codex).

I did have to fix again after updating multimedia app

Thanks for this Pascal_Simons, worked for me. :grinning:

I updated my QNAP TS-651 yesterday and faced the same problem - no AACs playing anymore. I also followed the instructions in Pascal_Simons link and it worked for me. :+1: I hope that I will not have to repeat that every time QTS is updated.

OK so I have a new issue after the latest Firmware (or since moving my Roon to my SSD).

If I don’\t restart every day or so, my QNAP grinds to a halt due to Memory 95% overload. QNAP have had a look and said “ah your Roon app is using 5GB” which I have no idea if it was before or not.

Literally the NAS grinds to a halt and the only thing that fixes is a restart (which takes about 20 mins to shut down everything with no memory to process). Something to do with overloaded swap memory whatever that is but never had it before.

Any ideas??