Roon Server on Synology DSM 7 Situation

I don’t see this as an immediate issue for existing users as updating will probably be optional, but for new units the DSM7 might be a requirement and this will no doubt irk some new users of the platform.

We are going to probably see similar issues on MacOS 11 no doubt too - as things get tightened up for apps.

thanks for the warning. I would normally update my Synology NAS as soon as DSM7 would be available but will now wait till your Roon server implementation works.

I saw this after installing DSM 7, my roon server does not work anymore. I cant revert back DSM.

Received notification that DSM7 is now in beta and several improvements were implemented since preview build.

Any update on this? I’d like to upgrade my DS918+ to DSM 7.0 beta asap, but need a way to keep roon core running on it…

… solved the issue myself: upgraded to DSM 7.0 and then restarted Roon core with root privileges, following theserecomendations: Roon Server on Synology DSM 7.0 Preview

It works!! :slight_smile:

1 Like

Restarted by ssh with root works, bur the command needs do be run every time the NAS reboots, is there a way to run this command upon startup automatically, thanks.

I would think a simple shell script in the proper directory should work…it’s been a while since I worked in Linux but I’m sure it is not that much work to get it to run at startup. Unfortunately, I can’t update to DSM 7 yet but will try when I do…

It’s a simple process.

Go to DSM 7 control panel, go to task scheduler and create a new task one as a root user to start the script of roon at the startup.

Insert the command /var/packages/RoonServer/scripts/start-stop-status start

And it will work well, until a new update comes for support for DSM 7, updates could not work for the roon app. Let’s see when it happens.

1 Like

This will be a turbulent ride, the update from today broke completely the dsm7 roon install, any help is welcome.

Update: The same ssh command Works after restarting the NAS.

1 Like

I have a Synology DS1520+ running DSM7 and it is not seeing my Nucleus+ and I had no idea that would happen as I did no prior research (that’s on me) I just assumed all would be well

They do tell you don’t put it on a production setup…

Hello @crieke, thank you for all your help. I was wondering if there are any updates on this. Thank you!

I have made all required changes according to their DSM7 developer guide and it is currently running on my diskstation.
In DSM7, thirdparty apps are not allowed to run as root anymore, due to that, I have to figure out some aspects (mounting external shares for example).
Unfortunately there is no support for local audio playback in DSM 7.


Thank you for your answer @crieke. I’m sorry if I am not understanding you. You said you made required changes and Roon is running on DSM 7 right now. Can you explain how you did that? I would like to update my synology to DSM 7.0 at some point.

It is not something trivial, you can simply change on the previous installer.
I will release the new installation, when I am confident, that it works well and is easy to to set up.


Thank you @crieke! I appreciate you.

Thankyou Crieke!

Looking forward to the new release!

Question: I have expanded RAM on my Synology, 48GB. Are there any RAM changes that happens when we can’t run as root anymore? ulimits or anything in that nature?

this does not mean, that an app is limited to a certain amount of ram in Dsm 7.
But it might happen, that “watching for files in realtime” when adding a new album won’t instantly add this album, when the amount of music files or folders will exceed this limit.
But I am still checking the options here.

1 Like

Hey there, just joining to check if there is currently any known way to install Roon Server on DSM 7 :slight_smile: ?

1 Like