Roon Server on Ubuntu keeps scanning folders

Probably I solved one problem. IP is mentioned in this thread Router does not support wireless multicast

Still scanning :disappointed_relieved:

Did you move the folder it seems to be stuck on out of the watched folder areas and then reboot the server, and see if the scan continues?

it is just like that after 667 waiting for @support to assist, this is not the only thread reporting these kind of issues after 667.

I second this @support

@mavmcl, I saw that you were using Ubuntu 20.04 and linking to an IP addressed external storage. I was experiencing similar problems as you were for my Ubuntu 20.04 setup. I don’t know if my solution has any relevance to your particular problem but since I was posting in one of the separate threads, I just wanted you to be aware of my latest post in case there was anything helpful there:

Thanks @Darryl_Caillouet so to summarize you switched protocols from SMB to NFS, right? and did the presentation yourself instead of handling it from Roon?

I can do so, I started using my Mac as core while they fixed the issue, but that can take months… I will do as you did and switch back to Linux core.

@mavmcl, Your analysis is correct. I manually mounted the remote folder using a different protocol to my Roon core. Then I added that local manual mount as a folder instead of letting Roon handle the remote mounting for me from the Storage->Add Folder interface.

I’m not sure if Samba/SMB/CIFS is the problem but I know that for me, NFS4 worked like a charm.

How did you do that change of protocol?

@fab_aut, Because I do my ripping on a Windows PC, I had setup Samba on the two Ubuntu boxes so it would be easy to drag-and-drop files from File Explorer to these remote drives. When I linked in the remote folder via the Roon interface, I’m assuming that it made the connection with CIFS automatically because it realized that this particular transfer protocol was loaded and available. So the CIFS mounting of the remote shared folder was done at the click of a mouse button by Roon.

In order to change the protocol, I had to manually setup an NFS server on the remote box as an alternative, NFS client software on the Roon Server and manually link the shared folder via the NFS protocol. First I tested it by mounting the remote folder manually from the command line then checked the results in the Roon client. Once I had confirmed that it worked, I added a line to the /etc/fstab file so that Ubuntu would automatically remount the remote folder each time the box was rebooted to make my temporary test a permanent solution.

As you can see, this is not a simple process because it’s all being done from command prompts, involved loading packages from the repository, editing configuration files and a bit of testing. Having run out of other ideas, this was just an attempt by me to find ANY solution that seemed viable. The hope is that as the Roon techs get more information from users, they’ll be able to identify the root cause and come up with a more elegant solution. While my hack worked for me, it might be useless for people who have hardware or appliances that don’t give them level of control they need like I had as an administrator of the box with unlimited control.

Let’s see how it goes after the initial import:

it is behaving… NFS looks to be a way around.
Thanks @Darryl_Caillouet

1 Like

Unfortunately for me is way to difficult. I’m not so skilled! I set up my NUC (only for Roon and Plex server) following some guide, as a little monkey :slight_smile:

Is it possible to ask for a little help from some admin, like @nuwriy or @noris?

what kind of storage device do you use?
Synology or Qnap NAS? if not which one do you use? initially you have to tell the storage to “stream” the share thru NFS so you can do the configuration in the client side (your ubuntu nuc)

Synology DS918+ is the storage device. Nuc with Ubuntu 20.04 is the server. Bluesound & Nad are my streaming devices.

In the Synology side:

in the ubuntu side:

you have to adapt the ubuntu side to your needs. some linux skills may be needed.

Thanks for your kind help, my NAS is already NFS enabled. On the other end, I’m not well-versed in running linux commands, so… I’m gonna wait for a solution from Roon Labs.
In addition, english is not my language, so… I’ll wait.


Hi @mavmcl & @fab_aut,

Thanks for these reports! I have forwarded your setup details + logs over to our QA team for further review, thanks in advance for your patience while we look into this further!

Thank you.