Roon Server on Ubuntu keeps scanning folders

Core Machine (Operating system/System info/Roon build number)
Nuc8i3/Ubuntu 20.04/Roon 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Hi, it seems that my server is going on forever to scan my three folders. It keeps to scan. And scan… and scan. How can I stop this activity?

Have you tried rebooting the server?

Yes. I rebooted the nuc.
This morning I rebooted it again, and the scanning has stopped.
Now, 4:11 PM, it keeps scanning :frowning:
On Linux, is there any way to reboot the server (Roon) without rebooting the device?

Antoher strange thing is that all my devices (NUC included) are running under 192.168… but, (using IP Scanner), I can see ROON under 239.255 etc. And everything is hardwired.
Thanks, have a nice Sunday.

After more than 24 hours my Roon server keeps scanning one folder. Tracks are always the same. So I believe something went wrong after the update. Can someone at Roon investigate? Thanks.

Well, you would just Stop RoonServer and then Start RoonServer.

That is very odd. Roon uses the Ubuntu’s PC IP address. Is that the IP of that PC?

I would remove that folder from the watched area and see if the scan finishes. Roon support will probably ask to see those files anyway for evaluation.

The same thing happens to me on 20.04. Service restarts and reboots don’t resolve it. It’s a specific folder that it gets stuck on, too, so I suspect it’s having issues with specific files in there or something.

same here, @support 667 broke Linux app… now it keeps getting stuck scanning the library, the workaround I have found is to stop Roon service in linux, clean /var/roon/RoonServer Cache and Temp start the service again… it will be ok for a day or so…

Screen Shot 2020-10-24 at 18.26.54

Ubuntu 20.04, no drama before 667.

That is very odd. Roon uses the Ubuntu’s PC IP address. Is that the IP of that PC?

Not at all. Every device is under 192.168… Shoud I be worried? The strange ip is

@support please let me know if you prefer me to start a new thread.
Happening Now, logs from ubuntu core machine:

Please assistance or let me know if I just move the core to Mac.
This is not happening on MacOS core app.

1 Like

noticed something funny in the logs… my ubuntu VM is in UTC timezone… not sure if that could affect 667 and it didn’t in previous one.

gents, check your Linux core date/timezone with: timedatectl
I am kind of skeptical at the moment, but after changing the core VM timezone to the right one I have done 4 manual rescans, it didn’t got stuck yet…

EDIT: It is stuck now… so date/timezone was not the fix…

Really annoying… something to add along with the eternal may 2019 Mac CPU issue, GPU issue… please FIX the product.

Probably I solved one problem. IP is mentioned in this thread Router does not support wireless multicast

Still scanning :disappointed_relieved:

Did you move the folder it seems to be stuck on out of the watched folder areas and then reboot the server, and see if the scan continues?

it is just like that after 667 waiting for @support to assist, this is not the only thread reporting these kind of issues after 667.

I second this @support

@mavmcl, I saw that you were using Ubuntu 20.04 and linking to an IP addressed external storage. I was experiencing similar problems as you were for my Ubuntu 20.04 setup. I don’t know if my solution has any relevance to your particular problem but since I was posting in one of the separate threads, I just wanted you to be aware of my latest post in case there was anything helpful there:

Thanks @Darryl_Caillouet so to summarize you switched protocols from SMB to NFS, right? and did the presentation yourself instead of handling it from Roon?

I can do so, I started using my Mac as core while they fixed the issue, but that can take months… I will do as you did and switch back to Linux core.

@mavmcl, Your analysis is correct. I manually mounted the remote folder using a different protocol to my Roon core. Then I added that local manual mount as a folder instead of letting Roon handle the remote mounting for me from the Storage->Add Folder interface.

I’m not sure if Samba/SMB/CIFS is the problem but I know that for me, NFS4 worked like a charm.

How did you do that change of protocol?