Router does not support wireless multicast

I have a BT Smart Hub 2. It does not support end user configurable multicast.

How can I get chrome cast audio to appear as an end point or a browser to display lyrics?
Thanks In advance.

Any reason you are still on a 2?

It’s a new installation of fibre, so I presume it’s their latest router. Maybe there’s some confusion with another term, bt home hub 6?

That sounds more likely.
BT homehubs work with chromecasts.
Can you see the chromecast in Google home?

Yes and I can cast to it via “cast” but Roon cannot see it.
Roon can also not display lyrics in a browser as I’m guessing that all depends on multicast.

I had this all working on my last router, but now have the issue.

Hi @Mike-D,

What operating system is your Core running?

As mentioned in our Networking Best Practices guide, we suggest staying away from ISP-provided routers and instead replace them with consumer-grade equipment, such as Netgear/ASUS/Linksys.

Often times ISP equipment does not pass multicast properly as you have seen. This could also be a firewall issue though, so I would check to make sure that Roon and RAATServer are configured to be allowed past the firewall.

Hi Norris, it’s windows 10.
I can see inbound/outbound rules for Roon in the windows firewall. My server hasn’t changed, but the router has, but do I need to configure the router firewall with regards to traffic that stays internal with the router supplied network ?

Could you explain what ports I’d make exceptions for?

“This can be resolved by adding exceptions for Roon and RAATServer to the router’s IPv6 firewall settings.”

Hi @Mike-D,

The IPV6 exceptions were more for Technicolor routers, but I am not sure if they apply on your end. You can try disabling IPv6 altogether as a temporary test to see if it helps.

I would also check to see if rebooting the Chromecast helps, or if you are able to connect to the Core via a web browser (not from the same machine as the Core, but another one on the same network):

If there was a major issue with BT routers you would be getting a lot of complaints as most UK based ADSL providers use variants of the same devices. Has the entire network been powered down then back up again, router first?

Here’s my post on the bt forum

It’s not configurable :slight_smile:

Not all ISP give an option to use a different router as the supplied devices are a combined modem router with no way to disable the routing functions. You cant put BT home hubs into modem mode so your a little stuck. Adding in another router will likely cause more network issues as having two on one network is not a good idea.

I’ve had the same router and it worked absolutely fine with Roon without any multicast setting needed and as @Henry_McLeod says the forum would be flooded with BT users from the UK.
So whatever is wrong it’s not the router model. It might not be working properly but that’s a different issue.

Your right, need to keep an open mind.

I had this issue before and that’s what fixed it on my old router.

I just need general troubleshooting help, why can’t I see the chrome cast audio I wonder.

I also have the wired adapter for Chromecast audio, so if I connect it to the router via ethernet, I can then see the device listed on the router, with an IP Address, but roon still does not see it.

I can disable the windows firewall and the router firewall but do not observe a change.

I can use the Iphone as a Roon Remote, so the server is at least accepting some communication.

The server can also communicate with qobuz.

From what I’ve seen in the past the Roon Endpoint should broadcast it’s presence via multicast and then the Roon server will respond to setup the connection.

I think the multicast group for RAAT is

Don’t know how techy you are but you could install Wireshark on a laptop and see if the Chromecast is sending multicast or broadcast traffic.

I don’t think that ROON or endpoints do group joins so switches that support IGMP snooping but see no explicit group join may discard it. I don’t know the BT smart hub but I think they have IGMP snooping enabled by default for the TV and multiroom so this may be causing issues with Roon.

My switch supports IGMP snooping but also has a handy feature where it floods unknown multicast i.e where it hasn’t seen an explicit group join for the multicast.

1 Like

You can still use them in a similar way without issue if you wish (or at least I always have) - just disable the WiFi and plug only the substitute router into it. Setup the substitute router to offer DHCP on a different subnet (e.g. 192.168.2.x) and all works as you’d expect.

i can install wireshark and check

whenever i wireshark the traffic (which is installed on the roon server), there is no traffic being logged from the chromecast audio. even when i cast to it via the qobuz app, i’m still not seeing any traffic to the source\destination ip.

although another detail now, is that even within google chrome i cannot see the chrome cast audio (but I can in the google home app, and in qobuz).

I think that’s to be expected as unicast to/from the Chromecast won’t be captured on a different switch port, I don’t have any Chromecast stuff here so I can’t duplicate it but I would have thought that casting would just tell the Chromecast to get the audio stream directly from the Qobuz content server rather than your app.

I was hoping that by running wireshark on a different switch port than the Chromecast is plugged into and seeing multicast/broadcast means that the switch is flooding it.

By not seeing it I think your smart hub is using IGMP snooping and ignoring the RAAT multicast traffic as it didn’t see a join message.

i did see this, but the source address is the roon server