Roon Server playback stops when closing iPad running Roon Remote

Core Machine (Operating system/System info/Roon build number)

Windows 10 PC 4th generation Celeron processor, USB 3.0 output through Matrix Audio H3 PCIe card running headless and set to sleep never. Library on USB hard drive connected directly to PC USB 3.0

iPad Pro with iOS 13.3

Roon Server - Roon Version 1.7 (build 511) stable (64 bit)
Roon Remote - Roon Version 1.7 (build 511) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Google mesh network WiFi network and Linksys USB dongle on PC

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Chord Qutest, USB connection to PC (Matrix Audio H3 PCIe card)

Description Of Issue

I searched the boards but couldn’t find posts from folks that had a similar problem so here it goes…

Infrequently but regularly when I close my iPad (fold magnetic cover/keyboard over the screen), Roon Server will pause streaming music to my DAC. I haven’t found any consistent pattern but seems to happen if I restart my PC or the first time I use Roon Remote during the day. Can happen rarely but at other random times too. Once I go back into Roon Remote on my iPad and un-pause playback the streaming becomes stable.

My work around is to just un-pause playback on Roon Remote but it’s getting annoying that sometimes when I close my iPad to enjoy the music that I have to go back in to get the music going again.

Hi @Douglas_Gardner,

Does this only happen when Roon is open on the iPad? If you close Roon first and then fold the cover does it ever occur?

What if you lock the screen manually before doing so? Does it still happen then?

I did some tests to answer your questions and here’s the pattern I was able to consistently repeat:

  1. Shutdown Roon Server on my PC and then restart it.
  2. Go into Roon Remote on iPad
  3. Start playing a track from my library
  4. Press lock screen button on iPad
  5. Streaming to my DAC halts after a few seconds

Also tried closing Roon Remote between steps 3 and 4. Had same result with music pausing after a few seconds.

In each case when I go back into Roon Remote I’m able to resume playing where it paused.

So it doesn’t seem to matter if I press the lock button on iPad or close the cover. Also doesn’t seem to matter if I close Roon Remote first (assuming closing Remote means pressing home button)

Thanks, @Douglas_Gardner!

Can you get the same behavior to occur if you start playback to System Output of the Core machine? If so would you kindly reproduce the issue while playing to System Output and make a note of the time that the playback stops as well as the track that you were playing?

Yes, I get the same behavior to occur if I start playback to System Output of the Core machine with PC running without keyboard or mouse. I did get different behavior when I reconnected my keyboard and mouse that may shed some light on what might be going on. Here’s what I did this morning:

Test 1:

Connected monitor to HDMI port on PC and rebooted PC using remote desktop; no keyboard or mouse

Selected Album 10,000 Maniacs, Our Time in Eden, track #2 These Are Days on iPad Roon Remote

At roughly 41 seconds into the track I pressed the lock button on the iPad

After about 6.5 seconds (at 47 seconds into the track) audio from standard out on PC paused

Went back into iPad Roon Remote and repeated but without restarting Roon Server

Audio continued to play after pressing the lock button on the iPad.

Test 2:

Paused the music using Roon Remote

Restarted Roon Server on PC using remote desktop

Roon Remote couldn’t connect to Roon Server on PC

Restarted Room Remote on iPad and still couldn’t connect

Used remote desktop to confirm that Roon Server was still running

Still couldn’t connect to Server from Roon Remote

Attached USB keyboard and mouse to PC and logged onto PC

Restarted Roon Server

Reconnected Roon Remote

Played tack Eden from same album; locked iPad at roughly 20 seconds in; track continued to play and did not pause after locking iPad

Test 3:

Went back into PC using remote desktop and restarted Roon Server

Reconnected Server from Roon Remote (no problems with Remote finding the server this time)

I noticed that the idle screen was showing on the PC monitor

Selected track Eden again from Remote

Paused at roughly 20 seconds into the track and audio paused on System out after roughly 6.5 seconds as first attempt above.

Repeated Test 3 but made sure that the Idle screen was not on PC display. Music continued to play without incident after iPad lock button pressed.

Repeated Test 3 with PC idle screen showing and music paused roughly 6.5 seconds after pressing lock button on iPad.

Could there be something wrong with how I’m launching Server?

Adding to the post above, I did the same experiments except that I used Roon Remote on my iPhone XR in place of Remote on my iPad and when using Remote on my iPhone I don’t have any of the pausing problems that I have with my iPad. This seems to be pointing me to a problem with Remote on my iPad and not to anything on my PC. iPad is iPad Pro 2nd generation A1701.

Hi @Douglas_Gardner,

For the tests above, do you know the time in your local timezone that the issue occurred? If not, can you reproduce once more and provide that time?


I don’t recall the specific time I did the test so I’ve done some new ones today:

iPad Test 1:
At roughly 2:57 PM US Eastern Time. I played Norah Jones, Come Away with Me, flac 352.8khz 24 bit, track #2, Seven Years. Played the track for 20 seconds from Roon Remote and then pressed the lock button on iPad. Roon Server paused playback after another roughly 6.5 seconds. Roon Remote shows that the track paused at 26 seconds into the track.

iPad Test 2:
Restarted Roon Server. Selected track #3, Cold, Cold Heart from Roon Remote on iPad and started play at roughly 3:03 PM US eastern. Locked iPad at roughly 21 seconds into the track. Roon Server paused after 6 seconds or so with Roon Remote showing music paused at 27 seconds into the track.

iPhone Test 1:
Restarted Roon Server. Selected track #1, Don’t Know Why at roughly 3:06 PM US Eastern time. Pressed lock button on iPhone. Playback continues with no pausing.

Thanks, @Douglas_Gardner.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Thanks for setting that up. I ran some tests this morning that will hopefully create some useful logs. Here’s what I did:

9:15 AM US eastern time: Restarted Roon Server on PC
9:21 AM Played Yo-Yo Ma Solo from Tidal, 44.1kHz 16 bit, track 1, Appalachia Waltz using Roon Remote on iPad
25 seconds in I pressed lock button on iPad and after another 6 seconds or so Server stopped playing.
9:25 AM I un-paused by pressing play button on Roon Remote

9:27 AM: Restarted Roon Server
9:28 AM: Played track 2 from same album above
at 16 seconds into the track I pressed lock button on iPad and at 22 seconds the playback paused
9:29 AM: un-paused to continue play.

After these tests I did not restart Server and I’ve been listening normally using Roon Remote on iPad to navigate library.

I was able to create a success scenario where playback continues without issue after locking my iPad. Here are the steps that seem to consistently work:

At roughly 7:07 PM US eastern time…

  1. After rebooting PC I log in using remote desktop on iPad so Roon Server launches.
  2. Exit out of the remote PC session by closing the remote PC connection. Not by minimizing the remote PC session but by selecting the close icon for that PC in the Windows remote PC application on my iPad.
  3. Launch Roon Remote and connect to Server on the PC
  4. Play any track from Roon Remote and playback continues after locking the iPad.

Note that if I restart Roon Server from my iPad using the Windows remote PC app and I fail to exit the remote PC session before using Roon remote on the iPad to play music then music playback will pause after about 6 seconds as outlined in the thread above.

I don’t have any explanation of why this cures the failure mode I’ve been experiencing but I’m glad that there is a prescription that yields a stable experience. Hope that this information helps the team working this issue to get broader and more stable solution in place.

Thanks for the update, @Douglas_Gardner! That is definitely very helpful.

In this case, it seems to point to the remote connection app rather than the Roon remote app. Can you confirm what app you’re using to remote in to the PC that runs RoonServer?

I’m using Microsoft Remote Desktop 10. I think folks commonly know it as Microsoft RDP. I’ve got about two days and counting with trouble-free Roon.

There’s definitely a problem with RDP interfering with Server and Remote regardless of it being a RDP or Roon problem. The interaction between RDP, Roon Server, and Roon Remote seems really important to understand and document for your end users and to optimize by your developers.

I spent a lot of time searching these support topic boards for similar problems and suggested configurations for headless PC Roon Server configurations on Windows 10. I found a lot of problems noted with RDP related to running Roon Player or Roon Core. Nothing matched my scenario and many of the suggested remedies to those problems involved disabling account security features by mucking with, “netplwiz”, to remove password checks on the headless PC.

It would be great if Roon had a bit more authoritative prescription for configuring the account/operational environment on Windows 10 to minimize negative interactions between Core, Server, and Remote. For my case it would have been super helpful if there was a caution somewhere about RDP interfering with Roon Remote sessions if there are any active RDP sessions running on the Roon Server PC. The information on netplwiz in the knowledge base and referenced in the guides for installing Roon software doesn’t talk about RDP problems that can come up if auto log in is not configured or cannot be configured.

For others at Roon and outside that might view this issue, I was able to arrive at a stable configuration by closing the RDP session I used from my iPad to log in and start Roon Server after PC start up. RDP session is closed by exiting the session in the app and not by minimizing or exiting the RDP app. If I failed to do that then music playback would pause on Roon Server the first time I locked the iPad where I was running Roon Remote. This solution wasn’t intuitive to me. With this start up process I keep all of the account security in place and have a stable Roon system.

Many thanks to you and Roon for these resources. Personal thanks to you and the team for being very supportive in working through these issues; both mine and the others I searched. That you have this support board is terrific. Without it I don’t think I would have found a satisfying solution and without folks like yourself I would have felt abandoned by Roon.


Hi @Douglas_Gardner,

Thanks for the follow up here! I wanted to also let you know that I met with the senior technical team to discuss this, including what Roon is seeing when this happens.

In the diagnostics report, Roon sees that the audio device is lost. Essentially, the endpoint we were playing to “disappears” and is not available to Roon which is why the pause occurs. When you open the app back up you can start playback immediately, which means this endpoint loss is a very short time period before it becomes available again.

After some further research, it appears that the RDP app can have some audio-forwarding functionality — meaning if you’re remoted in from a device, the audio from the Windows machine can be forwarded to the device that is remoting in. Our current theory is that, when the device is locked, this audio forwarding is ended which causes a change in the audio on the Core machine and a brief loss of audio in Roon. When you close the connection first, this audio forwarding is ended and so there is no interruption

You may be able to get around this by tinkering with audio settings to prevent this audio forwarding. It’s hard to say for sure if this will resolve things for you, but it’s definitely worth a shot. Ultimately, something about the iPad closing is causing RDP to do something with the audio on the Core machine, causing this brief loss in connection to the endpoint.

I hope this helps! Please let us know if you have any questions.

That information on RDP and audio-forwarding is very helpful. In the RDP app I clicked the configuration setting for RDP connections to my PC and selected, “Don’t Play Sound”, in the audio forwarding section. That has also solved the problem too. I do get a some slight drop outs during the fractional second that I enter into and exit out of an RDP session but with sounds turned off in the RDP session there is no longer a problem with Roon pausing if I leave the RDP session up on my iPad.

So it looks like this case can be solved in a few ways. I’m listing them here for future searchers of similar problem:

  1. Exit the RDP session after the Windows 10 PC is set up and Roon Server is running (PC is set to sleep never) will ensure the Roon remote session isn’t disturbed.
  2. In RDP settings for the connection to the PC make sure that audio forwarding is turned off, “Sound = Don’t Play Sound”.
  3. Set up the PC for auto log in using, “netplwiz”, settings to totally eliminate the need to run an RDP session to launch the PC at start up. If you need to run RDP then note that audio interference may happen unless you do (2) above.

Thanks again for your help. I’ve tested my current configuration for a couple of days and everything is stable. Roon Remote on my iPad and Server are playing together nicely with no unexpected pauses when I close my iPad.


1 Like

Thanks for the followup, @Douglas_Gardner!

I’m glad that things seem to be working for you now. If you ever have any questions or issues please feel free to reach out! Happy listening :headphones:

I had lots of issues with Windows Remote Desktop and switched over to VNC

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.