Roon Server Software Rebooting

Roon Core Machine

Intel NUC 8 Mainstream Kit (NUC8i7BEH) - Core i7, Tall
Crucial 8GB Single DDR4 2400 MT/S (PC4-19200)
Samsung 970 EVO Plus SSD 250GB NVMe M.2 Internal Solid State Drive

Roon Server Software
Version 2.0 (build 1268) earlyaccess

Operating System
Version 1.0 (build 254) production

Networking Gear & Setup Details

GB Ethernet Connection to NUC

Connected Audio Devices

NUC HDMI Connection to OPPO BluRay
Use by wifi Macbook Air M1 MacOS Ventura 13.3.1, IPAD Pro, Android Pixel 5, by ethernet Windows 10.

NAD Master Series M17 V2i by Ethernet and BluOS Wifi
Bowers & Wilkins Formation Wedge by Wifi

Music Library on Hard Drive connected by USB to NUC

Number of Tracks in Library

320,490 tracks. 63,204 are Local. 257,286 on Qobuz.

Description of Issue

Roon Server Software reboots itself 1 or more times a day. Sometimes I am using ROON, playing music and sometimes I am not. Not sure if this is NUC hardware, NUC itself, or software issue but would like help to fix. Log files uploaded under my user name.

Also ROON is slow sometimes at loading pages, searches, discography etc… I know that there are posts about this, especially with large libraries, and ROON is looking at a software fix – but I don’t know if the problems are related.

Thanks for any help you can offer.

You likely don’t have enough memory for a library that size. Go to 16 GB at least.

Yes I may have outgrown the hardware I purchased 4 years ago. I can upgrade the memory to 32 GB. Or should I get the latest Roonlabs recommended NUC system for large libraries?

Before I throw any money at the problem I was hoping for some guidance from ROON. My library has grown considerably since I purchased the NUC, but it is mostly from QOBUZ streaming library additions, the local library has grown a smaller amount. The original SSD drive recommended by Roon failed and I would like to be sure I don’t have another component issue, a database or software issue.

Does anyone at Roon Labs have the log files I submitted?


I have been reorganizing my TAGS so that all contain less than a 1000 items. I had unintentionally tagged tracks instead of albums which drastically increased the number of items in some of my TAGS. The rebooting problem started happening a lot less as I got rid of one extremely large TAG I had, but ROON started crashing. This had not been a problem in the past.

Today I had trouble backing up ROON. It would crash, the server rebooted and the backup failed. I finally made 2 successful backups. I purchased additional memory and installed it today. However, after the memory update the NUC would not complete a reboot, and it would finally power off. I was unable to get a BIOS image on a screen and the unit started making a grinding noise before shutting down. I took the board out and examined the fan, and saw no dust or debris.

I have temporarily moved to a desktop ethernet connected Windows 10 computer to run the Roon core, so I have access to my library.

I am not sure if I should get a NUC12 or a new MAC Mini M2 or M2 pro to replace the failed NUC 8 or a desktop computer. But I don’t think I’ll put anymore time or money into the NUC 8 as I have outgrown the processor and RAM given my library size.

I am still wondering if the log files tell us anything about what was happening. Any thoughts on what to use as a core for a library my size?

I’ve cleaned up the tags and got rid of 30,000 tracks. But I still have some episodes of crashing each day, usually while searching with the core on a Windows PC. I am wondering if the logs I sent over show anything. I’d like to know before I purchase something to replace the NUC that won’t boot up.

Hey @CoralRad,

Ben with the support team here, thanks for taking the time to write in! I was able to take a look at your core diagnostics and wasn’t able to find anything specific to your crashing, unfortunately.

That said, @David_Snyder makes a good point in terms of memory and the size of your library. I would also suggest upgrading the RAM on your core device, especially with RAM being pretty affordable, then seeing if your issue persists.

I’ll be on standby for your reply. :+1:

1 Like

Benjamin, Thanks so much for looking at the log files and getting back to me. I really appreciate it, I know your team gets quite busy.

I installed 32 GB RAM on the NUC but was unable to get it to work, it started making a grinding noise and would shut down, and I was unable to boot to the BIOS page and get a screen image. So I moved the core temporarily to a Window 10 system (Xenon W-2104 CPU 3.2GHz 16 GB RAM 64bit OS), rather than try a fan replacement which I guess is what is making the noise.

Roon is quicker now but I have crashes from time to time, usually when searching. Any thoughts? Could a database problem cause the crashes? The server, of course, isn’t rebooting on its own but Roon loses contact now with the core occasionally and I have to reboot the windows computer about once a day.

I want to replace the old NUC with a better processor and with 16-32 GB RAM. I was thinking about the NUC 12 i7 on the ROON approved list and going fan-less but I see from the community board posts that people are having issues, and seems like it would be better to wait and see if Roon labs works out the HDMI compatibility issues first.

My library has grown a lot since I set up the NUC. I am looking at trying a new Mac mini M2 pro, or a MINISFORUM UM690 Mini PC (AMD Ryzen 9 6900HX Windows 11 Pro DDR5-4800 32GB 512GB PCIe4.0 SSD ? replaced OS with Ubuntu ), but I’d rather use ROCK. So I am working on downsizing the QOBUZ library size while I wait on the NUC 12 issues to be resolved.

I don’t really want to be tinkering, I want to get back to a reliable system which I can set up fairly quickly and forget about. The crashes worry me, as I was not expecting any problem after moving to windows tower. By the way I changed from early access to production when I moved to the Windows PC.

I purchased a fan for the NUC, I’ll see if I can get it up and running later this week.

I replaced the fan in the NUC, it runs quietly now, but I still can’t get the NUC to complete boot up or display the BIOS. I am going to take it in for service repair consult. If I get it running I will give you follow up.

The core is running pretty well on the Windows 10 PC, but I still get a crash now and then, but less frequently than a few days ago. When I have the Roon core running and try to use anything else on the PC I have problems. The computer responds slowly or if I am listening to music I get music drop out. I guess that the 16 GB RAM on the PC is not enough? My library is currently at 270,000 tracks.

That PC probably is underpowered running your large library in Roon on top of Windows 10. Both RAM and CPU may be inadequate. The Xeon server processor is not a good fit. For Roon purposes, it is slower than the previous NUC8i7 laptop class processor.


1 Like

Thanks. The windows setup is only temporary until I get a better dedicated setup for the core. Overall Roon is running better on the Windows than the NUC: Searches are faster and crashes are less frequent. I assume that is due to RAM. If I can get the NUC 8 running again with 32 GB RAM I’ll use that until I get a better replacement.

So the service center tells me that the Crucial RAM card has a short in it and it burned my NUC and their test laptop. Unfortunately I don’t get to test my database on the NUC with improved RAM.

Hey @CoralRad,

I’m so sorry to hear this! Please let me know if I can help with anything else while the device is getting repaired. :+1:

Thanks. I have a UM690 on order, I plan to put Ubuntu server on it then install Roon. This should be a much better processor and it has more RAM than the NUC I was using. I thought about trying to put ROCK on it instead, but I don’t want to have to trouble shoot a failure that could occur with future Roon updates.

I have a new problem in the meantime. I can no longer access my Qobuz library. Roon will not logon. On the qobuz web player I cannot logon. On the Qobuz desktop app, I cannot access my favorites or playlists. I can log onto my account on and see that I have an active account but I cannot stream anything. It is like my account is locked. I tried resetting my password, but this did not change anything. I have years worth of work developing a large number of Qobuz favorite tracks and albums, playlists and edits. My roon database is backed up. I hope I do not lose anything. Have you ever seen this? Are there any precautions I should take? I have been waiting for a response from Qobuz for over 24 hours.

Hey @CoralRad,

To confirm, you are doing this all via your web browser, outside of using Roon? Getting in touch with Qobuz support was the right call to make - did they follow up yet?

If possible, I’d quickly check on another device to see if you experience the same issue. Perhaps another web browser too as it sounds like it could be an issue related to Qobuz servers.

Do you receive an error message?

I’ll be on standby for your reply.

It does not matter what device or method I use I cannot stream Qobuz music, see my Qobuz playlists or favorites including: Roon core (located on Windows), inside Roon app on IPAD or mac, MAC Qobuz desktop app, Chrome or Safari Qobuz webplayer, or android phone.

I can log on to on the web, but not to the web player to stream music on the web, or view favorites or playlists. Roon logon under services settings fails. On Android I get a message that VPN and proxies are not allowed, but I am not using VPN. Mac Qobuz desktop app allows me to see my account is active but I cannot view playlists or favorites or stream music from the discover page. This all first started while I was adding an album from Qobuz from inside Roon 2 days ago.


I did contact Qobuz service online, and was told to logout of all devices including my router for 2 hours. I tried but this did not work. I think my IP address is blocked on Qobuz’s end.

…Later on same day I logged onto my account on a friends laptop outside of my home and was successful. I could see all my album/track favorites and all playlists - which is a relief, I worried they might be gone. However, back at home I still am blocked.

I sent Qobuz my IP address and asked them to check it and unblock me. Not sure what else it could be. I don’t expect to hear back until tomorrow.

I have the new Minisforum UM690 AMD Ryzen 9 6900HX with 32GB DDR5 RAM running and Roon works well, at least as good as when I originally started using Roon on the NUC years ago with a much smaller library.

I struggled with Qobuz service online for 7 days and it was frustrating. They really did not help me very well, but I was able to get a new IP address on my own and am able to stream Qobuz again.

So the issues in this post are resolved.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.