Roon server will not install in ubuntu 20.04

Roon Core Machine

,Ubuntu 20.04, with Jussi’s (HQP) image for dsd1024 playback
i9-11900k cpu, 16gb 3000 mhz ram

Networking Gear & Setup Details

Wifi from main router to above PC, direct USB connect to dac

Connected Audio Devices

USB from music PC to Holo May dac

Number of Tracks in Library

not sure, 20k about

Description of Issue

trying to install roonserver core to ubuntu, previously (core was in windows 11 Pro before). I am following your easy install article for linux and attempting easy install method. I keep getting error “failed to create file” saying some/tmp/tmp file does not exist (screen shot attached)

I have tried terminal with root privileges’ and without, same error every time. Any idea how I can get roon server package installed in ubuntu. Your article does not address this type of error.

If you type ls -alh /tmp what does your system throw out?

It appears that curl, a system utility used to download the installer, can’t write to the tmp directory or sub dir for for some reason.

screen shot, I had to install curl very early as i got a curl not recognized message it had a script to install it.

Sorry, it’s ls -alh /tmp. You’ve shown the contents of your home directory instead. It’s the /tmp directory that curls trying to use that interests me.

BTW you appear to be logged in as root already so sudo shouldn’t be necessary…

Yep, ubuntu rookie, I had tried both as Root and no root log in got same error on both, but yes should not have put sudo in command when I was loged in as root. Here’s /tmp read out

So nothing jumps out there, you’re ok for disk space? Try df - h and then you know the drill :wink:

disk space looks fine. Only a 32 GB ssd but only minimal ubuntu install, HQP and roonserver. so should easily fit on 32gb drive. I’m only using 12-13gb

Looks like a known issue with snap apps:


Nice catch.

I searched and found a post that said snap curl is useless so I uninstalled and did, sudo apt install curl
Now it writes and says I need FFMPEG which I have installed as per the linux roon article, but I also need mount.cifs command. I am not sure how to do that one.

I got it, Roon server should be working on my machine it says, whoo hoo.

1 Like

That’s good news @Quadman. Enjoy :slight_smile: and thanks to @BlackJack

Yes Thank you @killdozer and @BlackJack. Now just hope data base restore goes easy

1 Like

In case anyone else has this issue where curl will not write to a file or directory. Here is the fix I ended up doing. Basically curl from the snap store is worthless so uninstall that one.

sudo snap remove curl

and then use this command to re-install Curl. This fixed my issue

sudo apt install curl

To install the mount.cifs do the following

sudo apt-get install -y cifs-utils

Everything went smoothly after I did this.


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.