Roon services are not available from my ip address

Roon Core Machine

Roon Server on Ubuntu(amd fx 8350, 24gb ram)

Networking Gear & Setup Details

Roon Server connected directly to Mikrotik RB951G

Connected Audio Devices

AudioPro A26 via AirPlay

Number of Tracks in Library

0

Description of Issue

Roon services are not available from my ip address(95.31.6.150). Roon Server logs contain the following errors:

GET to https://qobuz.roonlabs.net/1/featured/albums?offset=0&count=30&userAuthToken=&featuredAlbumsType=Qobuzissims&c=qobuz-us timed out after 60000 ms
POST to https://device-map.roonlabs.net/1/register timed out after 60003 ms
GET to https://metadata.roonlabs.net/1/albums//tracks?c=qobuz-us timed out after 60011 ms

When I turn on the VPN or make a request for another IP, everything works. What is wrong with my IP?

traceroute to metadata.roonlabs.net (35.231.208.158), 30 hops max, 60 byte packets
 1  router.allmazz.me (192.168.1.1)  1.989 ms  3.865 ms  5.815 ms
 2  78.107.181.245 (78.107.181.245)  7.875 ms  7.949 ms  7.998 ms
 3  * * *
 4  85.21.224.83 (85.21.224.83)  48.713 ms  48.878 ms  48.924 ms
 5  72.14.242.54 (72.14.242.54)  45.499 ms  49.521 ms  45.556 ms
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

Your IP resolves to an address in RU

It is not a country that is supported by Qobuz.

That is my guess.

Qobuz works great from an application for Android or a web player.

And roon perfectly works with other russian IP

From behind a VPN. I believe you would need to insert a vpn between roon and qobuz when they authenticate.

Roon only tells you qobuz didn’t authenticate.

I turned on VPN for the authentication period and everything worked, but as soon as I turn it off, search and library stops working.

Qobuz should work, even in countries where you currently not sign up yet.

1 Like

Hi @Kirill_Nikiforov,

I’m sorry you’ve had issues. Perhaps this is a simple fix since we’ve seen it before. Can you restart your router and your Roon core?

I enabled diagnostics on your core and see connectivity working for Tidal and Roon’s account servers. I even see successful Qobuz connectivity. What I AM seeing though is related to a Google Pixel 4 device having connectivity to Roon issues. Is that a part of your music playing failures?

Lots of possibilities but please do reboot the router and core then get back to me!

Wes

Yesterday everything started working, you can turn off diagnostics and close the topic.

1 Like

Glad to hear. Best wishes.

Wes

2 Likes