Roon skipping all tracks, no sound at all

Roon Core Machine

M1 MacBook Air 8GB RAM 256 GB SSD

Networking Gear & Setup Details


Connected Audio Devices

iFi Hip DAC v2

Number of Tracks in Library


Description of Issue

Roon is skipping all the tracks, anything I want to play. I’m only using Tidal library.

Doesn’t matter if it’s my Tidal songs or Roon suggested playlists. It is just skipping to the next song until the playlist ends. No sound at all.

I have had this issue a number of times. Normally I just rebooted my sonore upnpbridge and that fixed it.

Yesterday however that didn’t. I also tried rebooting my NUC and still no luck.

I ended up cycling through the inputs on my Naim NDS And that somehow fixed it.
Could you try this on your streamer?

Skipping tracks tends to be a network issue. Can you please provide more information on your network (router brand/model) and WiFi (same)?

Oh man :sweat_smile:
My setup is much more simple.
It’s just an ifi dac/amp connected to my M1 macbook Air via USB which is running as core.
Everything was fine when I was using my PC that I don’t have anymore.

Have you done basic troubleshooting like rebooting everything from the network outward?

Having the same problem after installing 1.8 Build 988 this morning!!!

Maybe it’s because it’s not connected via Ethernet

I’m having the same problem. It started about 4 days ago in the middle of a listening session and nothing I do can bring it back. Have rebooted all parts of the network and checked to see that all bits are on the same network. Nothing works. Core on MacMini on WiFi to a Lyngdorf 1120, also on WiFi.

J’ai également le même problème après avoir installé la 1.8 Build 988 ce soir !
Habituellement quand cela se produit je relance tout le système et tout revient à la normale.
Mais cette fois cela ne fonctionne pas, j’ai tout arrêté et relancé plusieurs et cela n’a rien résolu !!!

It has started way before the new patch, when I was using PC as my core.
Trying to switch to Mac has caused the above issue that still persist.

Hey @Filip_Giemza,

Thanks for taking the time to write in, and welcome to the community! I’m sorry it was an issue that prompted your initial post, but nonetheless, we’re excited to have you here.

As @Robert_F mentioned, we’ve seen similar issues related to network errors in the past. If possible, can you detail how your core is connected to your router? Are you able to hardwire your core to your router to test? If you haven’t yet, please give your network a hard reboot.

Also, try disconnecting any endpoints and see if you can stream audio from your system output.

Do you have any devices you’re able to use as a Roon remote? It would be good to pull Roon up on another device and test to see if you run into the same issue.

We’ll be monitoring this thread for your reply :+1:

1 Like

Hello Benjamin,
thank you for your reply.
My core is a Macbook Air with M1 chip that is set as a core.
Before I had my core set up on my main PC.
Tried to stream from my speakers but still doesn’t work. Also tried to increase delay in the device settings and that also did not work.
I will try to setup my iPad to see if it works as a remote device…
I’m waiting for my USB-C to Ethernet adapter and will check if the core is going to work while connected via cable, not Wifi.

1 Like

Mine will stream to my other devices, in my case my iFi Zen DAC was listed and it would just keep skipping every track and then the iFi Zen DAC disappeared from Roon completely. I tried uninstalling and reinstalling the USB driver and changing the Zen DAC’s firmware but nothing worked. The same thing happens with my Audioquest Red Dragonfly!

I found the solution and it’s quite embarrassing I did not think about this in the beginning :sweat_smile:
I got the Ethernet adapter and it still refused to work so I looked at the top of my screen and thought to myself “maybe it’s the firewall blocking the connection”.
Lo and behold after I added Roon to ESET firewall exceptions everything started to work.
So yeah that’s it.


We’ve all done similar things.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.