Roon skipping songs streaming from Tidal


For the last month or so (December 2020 until today), I am experiencing this issue of Roon arbitrarily skipping songs from Tidal. This happens both in my PC, as well as an Auralic Aries Mini streamer and another Lumin U1 Mini streamer.

Of note, these same songs/tracks that are skipped in Roon, play just fine in other apps (Tidal, Auralic Lightning DS, and Lumin).

Apparently something similar already a few years ago… Help with a solution would be much appreciated, as it is getting quite frustrating with how often it happens…

Please describe how everything are connected together in your network, and whether you have WiFi or powerline network adapter in your music signal path.

Please state the hardware and OS of your Roon Core.

Please check the format of the music that are skipped: AAC, MQA, etc.

This post is made to the wrong section of the forum, so it has less chance of being seen by @support

Hi Peter,

Thanks (again!) for helping.

My setup is:

  • Roon core running at my Synology DS916+ NAS (Roon version 1.7, Build 710, stable), connected with 2xCAT6 cable (full duplex);
  • Roon clients are:
    1- PC (Windows 10 Pro; Core i7, 2,6Ghz; 8GB Ram) running latest Roon version (Roon version 1.7, Build 710, 64bit, stable), connected with ethernet cable (Cat6)
    2- Lumin U1 Mini, connected with ethernet cable (Cat5)
    3 - Auralic Aries Mini, connected via WiFI-5G

Regarding the Tidal music formats, it did occur both with “regular” FLACs (16/44) and MQAs.

(PS - is there a way I can move the post to the correct section of the forum? - EDITED: I think I did it already, moved to Support)

Please try local music files in Synology, and see if they exhibit the same issue.

No, no issues whatsoever with local files, even high-res like DSD128-256

Please set router DNS to Then reboot the whole network, including Roon Core, Roon endpoints, iPad, etc.

My ISP does not allow changing DNS settings (it os not even an option in the router settings). Any other way around this? :frowning:

If you are using Synology to run Roon Core, set manual DNS in Synology:

Network Center ----> Internet ----> Connection

Scroll down to the bottom of the page:

“Manually Configure DNS server” and just fill in your choices.

 Prefered DNS server:
 Alternative DNS-server:

After doing this, reboot the Synology

Peter, you are amazing, thanks for your patience!

Ok, just changed the Alternative DNS server settings in Synology:

Prefered DNS server: (it was already like this)
Alternative DNS-server: (it was previously

Will test now and see if it solves.


So you have been using manual DNS in the Synology all this time?

Apparently yes…

If you have been using as DNS all this time, the change to alternative DNS server is not likely going to help.

If the Tidal problem occurs again, you may consider migrating the Roon Core from the Synology to Windows 10 Pro for experimentation. See if this makes any improvement.

That is what I was afraid of. My Windows machine is a laptop, many times stays in the office at work and do not bring it home. Not to mention the need to turn on another PC just for running Roon Core :frowning:

Just temporarily.

1 Like

ok will try it!

Hello @Bruno_Costa, I agree that testing the core on Windows temporarily with the same network will help us narrow things down. Please let us know how it goes!

1 Like

Just installed and setup Roon Core in my Windows 10 PC. Same problem after 2 tracks. It took 28 skipped tracks to be able to play another track.

Not sure if it matters, but I am using a 3 months “trial” from Roon for 1€ (black friday or Christmas promotion).

I can’t think of anything else for you to try. I’ll hand this over to @nuwriy for further help

1 Like

Thanks again Peter. Hopefully someone from @support will have further insights. As it is, I am simply unable to use Roon.