Roon skipping tracks with Sonore UPnP Bridge

I was listening to Roon Radio, playing mostly tracks from Qobuz plus some local. Eventually it starts skipping tracks and there is no stopping it, it just keeps on skipping forever. It usually starts in the middle of a track, so not a file format issue.

I can only stop it by restarting the Roon Core.

My setup:

  • Roon Core on Mac mini
  • Sonore UPnP Bridge running on an Audiostore Vortexbox Mite
  • Naim NAC N 272 streamer
  • Roon app on iPad
  • Local media is stored on a Synology NAS

All the above are connected via wired ethernet (apart from iPad).

It is now happening every time I use Roon, it is unusable. I’ve rebooted the bridge and restarted the Core. It occurs with both Qobuz and local tracks.

Please advise how I can resolve this. I’m hoping there are some other users with a similar setup to this who can help.

Hi @wilro15,

Can you describe your current networking setup a bit more? What networking hardware is in use (router, switches, etc.)?

Does this occur for all endpoints? If you play locally to the Mac Mini’s system output do you experience the same behavior?

This is what I have:

  • Netgear Nighthawk R7000 router
  • Synology DS416j NAS (4x 4TB) (connect via ethernet cable)
  • 2012 Mac Mini running Roon Core (Core i5, 8GB, SSD) (connect via ethernet cable)
  • Audiostore/Vortexbox Mite running Sonore UPnP Bridge (connect via ethernet cable)
  • Naim NAC-N 272 (connect via ethernet cable)
  • Cat 5e or 6 cablng
  • No switches

Only using one endpoint currently which is the Naim, via the UPnP bridge.

When the problem occurs I have to kill Roon Core to stop it playing. Restarting the bridge also seems necessary. It first occured when using Roon Radio with Qobuz, but have also experienced it with local tracks too - so I don’t think it is related to where the music comes from.

Hi @wilro15,

Thanks for the update.

For testing purposes, may I ask that you try playing to system output of one of your remote devices? Knowing whether or not this occurs no matter what device you play to or if it’s limited just to the Naim will be a great help in narrowing down where this behavior is stemming from.

Hi @dylan, thanks for the response.

I’ve been trying some things out over the weekend and I think I can recreate the problem. I was playing a track from my local collection and changed some DSP Parametric EQ settings while it was playing. The music stops briefly to apply the EQ change, which is OK of course. I then made a few more changes in quick succession before it could catch up.

This started the skipping problem. Roon would continuously skip to the next track without playing any music. The only way to stop it is to restart the Roon Core.

I believe I need to tag @support? (I’ve seen this happen in other threads, apologies if this is incorrect)

Hi @wilro15,

I’m going to get this report over to the technical team for further investigation. Just to make sure I have all of the appropriate information:

Are these changes that you made also to EQ? Once you reboot everything works okay with those settings changes you made? It just seems to be the act of making quick changes during playback, correct?

Correct. All the changes I made were EQ. To be more specific, I was turning off filters on the Parametric EQ (5 were enabled but I only wanted 1).

Thanks, @wilro15. I’ll pass this along to the team for investigation and I’ll be sure to update you once I’ve received their feedback.

1 Like

I had issues with Roon skipping a lot of Tidal tracks. I solved it by changing the DNS on the Roon core to:

These are public DNS by Google and Cloudflare.

My problems went away after making this change.

Funnily enough I already use Cloudfare for DNS as I read somewhere that it is faster than your ISP’s own DNS.

@dylan This morning I found another way to make it go into endless track skipping.

I was playing Roon Radio. The current track was from Qobuz. When using my iPad, I accidentally selected a track to play when I was trying to scroll. This interrupted Radio and started playing an album. So I quickly clicked “skip back” in the play controls.

Nothing happened for a few seconds while it tried to go back to the Radio track from before. Then it started skipping. So it seems to be related to performing an action too quickly before Roon can catch up - possibly also related to playing from Qobuz.

To fix the issue I had to restart the Roon Core AND my Sonore UPnP Bridge, which at this point disappears from the Roon Zones panel. N.B. The Bridge is still responsive to its web UI, just not visible in Roon.

Hi @wilro15,

We’ve tried to reproduce the behavior that you’ve seen, but so far it has not occurred for us. I was hoping we could gather a little more information here:

  • Are you able to repeat this behavior every time? If you follow the steps listed above does it always occur?
  • If you play to a different endpoint does the same behavior occur?

Yes I can reproduce it, but do you know what? I think it is the Sonore UPnP Bridge causing the issue.

Just now I quickly change the DSP parametric EQ settings and it started skipping tracks. The CPU usage on the Roon Core was higher than usual, almost maxing out 1 of 4 cores.

However I did not restart the Roon Core. Instead I restarted the Sonore UPnP Bridge. The skipping stopped, naturally, as the endpoint went offline briefly. When the Bridge came back up, all was good.

So it looks like a Bridge problem, would you agree?

Hi @wilro15,

Based on the above it definitely sounds like this behavior may be tied to the Bridge device. I’m going to confirm with the team.

In the meantime, can you give these same steps a try with a different endpoint? Does the same behavior occur?

Not the same kit but when my system got into skipping tracks it was almost always a DAC problem and a reboot of the DAC sorted it out. So I would also suspect the bridge too.

Hi @dylan

Thanks for looking into this.

This is what I do to reproduce:

  1. Play some music
  2. Go into DSP settings and enable Parametric EQ if not already on
  3. Quickly enable and disable frequency bands - you need to do it quicker than Roon can catch up

This causes it to start skipping tracks and it never recovers. The Bridge device disappears from the Roon endpoints. Restarting the Bridge app on device resolves the issue.

It can also occur if I just click Next Track or Previous Track too quickly.

Hi @wilro15,

I had a chat with the team about this. They investigated and confirmed that things are working properly on our end. They’ve recommended that you reach out to Sonore regarding this behavior.

Thanks Dylan, I did just that. Unfortunately they don’t have the issue either. My specific setup seems to be quite unique.

So, I am in the process of switching from the Bridge to a Raspberry Pi based approach.

Thanks for your help.