Roon skips and stutters on MacOS

Core Machine (Operating system/System info/Roon build number)

MacOS 10.15.6 / Roon 1.7 Build 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

DragonFly Cobalt on MacBook Pro 16"

Description Of Issue

I’ve noticed this problem for a while now, even with the previous Roon builds, but it seems to be getting worse.
Roon skips and stutters a lot while playing music. Seems to happen more often with Roon in the background, while I’m working on something else (like writing this), but it does happen also with Roon in the foreground and nothing else going.
At first I thought it was a Tidal thing, but it does happen on local files stored on the computer’s drive.
Usually, rebooting the Mac seems to help, but after a while, the skips and stutters comes back.
I have Exclusive Mode on, Integer Mode on, Maximum Buffer Size on and Power-of-2 Buffers on as well. Everything else is default for the Dragonfly.
Any ideas?


Is the Mac the core or remote or both?

Sorry, both.

Can you try and connect with an ethernet cable, even temporarily, as this will probably be the first thing that support asks you to try.

I can, but the music is stored locally on the Mac’s drive, same Mac and drive that Roon is on. There’s no network usage involved.

Even so, you would be surprised how much chatter roon might be doing on the network.the other way is to disable all networking so it thinks it’s offline and try that way.

I have disabled Wi-Fi, played for a few minutes. No skips. Enabled Wi-Fi again, and I’ve been playing for a few more minutes, and no skips either.
I don’t know WTF is going on… Same track skipped at least 10, more like 20 times…

There is a Mac bug that is causing some machines to go haywire eating resources, the temporary workaround whilst they fix the bug is to toggle the WiFi so I wonder if your underlying issue is the resource munching.
If it happens again look at resources on the machine.

The Wi-Fi off/on seems to have done the trick. Don’t know how much of that is a MacOS bug vs a Roon bug. Seems the latter to me…

As far as resources, when it skipped, the Mac was at 5-7% usage. Now, it’s around 12-13% but doesn’t skip.

HI @Alexandre_Siufy,

If resource usage was under 100%, then this is not the same issue that we are aware of.

Does the issue only occur on the Dragonfly or does it occur on other zones as well? For example if you try to start playback to your “System Output” zone, does that work as expected while just the Dragonfly is affected?

I don’t use other devices, but I can try… The Mac’s built-in sound is not really good, but I’ll suffer through it :slight_smile:


This seems to be one of those terrible bugs to troubleshoot, the intermittent ones.
Since I’ve last posted, I’ve been playing music through the Dragonfly and directly on the Mac with zero issues, with Roon both in the foreground as well as the background.
Coincidence or not, disabling the Wi-Fi and enabling it again fixed it, like rebooting does as well.

1 Like

All you can do is keep playing the music :wink:

What does the system activity look like when you play and do the fans turn on on the MBP?

Hi @Alexandre_Siufy,

Glad to hear that there’s been an improvement in behavior here!
If you encounter further issues, please just let us know and we can take another look, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.