Roon skips songs without playing them

Roon Core Machine

Roon ROCK installed on Intel NUC 10i5, 4GB RAM, 64GB SSD

Networking Gear & Setup Details

TP-link Archer C80 + switch TP-link SG-108E, NUC is connected by Ethernet cable to the switch

Connected Audio Devices

Dutch & Dutch 8c as Roon Endpoint, connected by ethernet to the same switch as NUC

Number of Tracks in Library

Tidal as the primary source, not more than 6000 tracks in the library.

Description of Issue

After playing music for some short time, suddenly it stops playing and starts skipping tracks without actually playing them. When I restart the remote (kill the app on iPhone, or restart the app on Macbook pro), the music starts to play again without issues. All SW updated to the latest versions and also D&D 8c has the latest version installed. It’s really annoing, could you please help me? Attached the signal path if it helps…

Thank you

Have you done basic troubleshooting like rebooting everything from the network outward?

In theory, once you start playing music, the controller apps should not have any effect on the server until you do something through the app that changes what the server is doing or adds or delete tracks from the queue. So, start playing an album or tow via Tidal in Roon and then kill the app on the iPhone and quit the app on the MacBook.

Does the music play properly until all the albums are done playing?

Same problem here. I‘m also using a pair of D&D 8c with 2 iPad‘s and a android phone as remote.
One of the iPad‘s is a iPad Air 4. Generation the other iPad is a iPad (6. generation so it‘s quite old)
Killing the app on the iPad 6. generation always solves the problem.
Rebooting everything doesn‘t help.

As Andreas wrote, I also tried rebooting and it didn’t help. I don’t know if it’s the issue of Roon Core or D&D speakers (endpoint). But I agree that it’s strange that restarting of the remote app helps. After that it plays without issue for hours.

Log out of Tidal (Tidal service in Roon) and log back in again. Often solves this kind of problem.

I’m using Qobuz. Will try log out and log back in to Qobuz.

Thank you for the advice, I’ll try that.

I have logged out of Tidal and logged back and it doesn’t help.

I have just realized, that when the songs skipping occurs, quitting the remote app on Macbook pro solves the issue and the music starts playing even without reopening the remote app again.

Same behavior as mine. I just close the app, then the music continues without problems.

The problem still exists, even after rebooting the router, core and 8c’s.
Today I tried to shut down all non-iPad remotes first; in my case on Windows 11 and Android. After that, for the first time with this error, I killed the app on iPad Air 4th generation. After that, the problem disappeared instantly.
In the past, I always stopped the app on the older iPad. Seems to me that the age of the iPad hardware has no relevance.
In the Dutch&Dutch app the following message appeared each time the tracks were skipped:

This is my setup:

Roon Core Machine

Roon installed on a Debian 11 LXC container. Host: latest proxmox

Networking Gear & Setup Details

Router: virtualized opnsense
Switch: Cisco CBS250-24P-4X
Access Point: Zyxel WAC6103D-I

10GBE Link with 3 different subnets between proxmox and Cisco CBS250-24P-4X
Roon Core and all Roon devices in the same subnet
IPv6 in use

Connected Audio Devices

Dutch & Dutch 8c as Roon Endpoint, connected by ethernet to the Cisco CBS250-24P-4X
Raspberry Pi 4 Model B Rev 1.4 with RoPieee, connected by ethernet to the Cisco CBS250-24P-4X
Raspberry Pi 4 Model B Rev 1.4 with HifiberryOS, connected by ethernet to the Cisco CBS250-24P-4X
ELAC Discovery Z3, connected by Wifi
Bluesound Puls Mini, connected by Wifi

Number of Tracks in Library


I have also checked the D&D Ascend app when the issue appeared again. It mirrors the Roon, skipping the tracks, but for a second error message appeared, which is different than yours, see picture. I don’t know if it is somehow related to the D&D endpoint, or where the problem is.

Is there a way to get at least some hints from official Roon support, where could be the problem? Should we maybe contact D&D support?

I have bought lifetime subscription few weeks ago and other than that I’m quite happy with Roon, but this is quite unpleasant issue.

Hey @Peter_Martiniak,

Thank you for getting in touch, and welcome to Community! We’re happy to have you but sorry to see that it was an issue that prompted your first post. My apologies for the delayed response and for your wait. We’d be happy to help figure this out!

Hello as well @Andreas_Baumann, your system setup is more complicated than Peter’s Roon OS ROCK. For now, we’ll keep your report here, but may have to move it to its own thread.

Can each of you please try to recreate the track skipping behavior them make note of your local time when skipping begins? Then recreate the workarounds you’ve discovered that allow the music to continue playing without skipping. Note the time when you initiate the workaround. We’ll pull logs to see if we’re able to determine what’s happening.

We apologize for the inconvenience you’ve experienced. I’ll be watching for your responses.

In my case, the problem occurred tonight at about 22:03. At 22:10 I closed Roon on the iPad, after which the problem with tracks skipping no longer existed. I then had to switch the 8c to the AES input and then restart playback on Roon.
How shall I send the logs?

Thank you @Andreas_Baumann, we really appreciate it. I just pulled logs from our side. We’ll be back in touch once we have more details to share.

Hey @Peter_Martiniak & @Andreas_Baumann,

Please reach out to Dutch & Dutch Support here for their help with the issue you’re experiencing. We apologize for the inconvenience and hope they’re able to provide a quick resolution.

Thank you, I have already contacted D&D support, hopefully they can help. I will report back in case of any news.

1 Like

Well… if they’re as fast as they were with the Roon integration, I’ll probably have new speakers before then.