Roon Skips to Next Track Midway Through Tracks On My Hard Drive

Roon Core Machine

Roon is located on my SonicTransporter i5 and it is running version 1.8. The Sonic Transporter is running version 2.8 of its operating system

Networking Gear & Setup Details

Orbiter router running into an EtherRegen ethernet switch

Connected Audio Devices

The SonicTransporter is connected to an OpticalRendu which in turn is connected to an ifi Pro iDSD DAC.

Number of Tracks in Library

100,207 tracks

Description of Issue

When the system plays a track that is located on my hard drive (but not on Tidal or Qobuz), it will randomly skip to the next track at some point before finishing the previous track It will pause for a second or two and then skip to the beginning of the next track, and do it again When it pauses, it shows the following message:

“An audio file is loading slowly. This may indicate a performance or hardware problem.”

From that description, I can’t tell if the problem is in the hard drive, corrupt music files, my SonicTransporter, Roon software, or something else I dont understand. Help, someone who is more technically proficient than I am.


I think here we don’t get much further without good technical guidance from the team or a few really very knowledgeable helpers in the community. Surely there is a small queue until a Roon staff member can take care of it.

Depending on the level of computer literacy, some in the community also try to understand your LOG data themselves and look for errors, warnings, etc. in the logs for first better clues.

1 Like

Thanks for responding. Do you know of anyone in the community that might be a good technical person to look at my log data or anything else that might jumpstart figuring out the source of this problem? Thanks, Uwe. And of course, Roon staff will eventually respond as well.

I have a question for someone. When I copied my music hard drive (which was starting to fail) from one hard drive to another (both hard drives were powered—had their own power supplies), I used a non-powered USB-C hub connected to my 2018 MacBook Pro. I’m wondering if I should have used a hub that was powered, one with its own power supply. I ask that question because both hard drives were ejected by the computer erroneously—I didn’t initiate the ejection. It happened several times. I’m wondering if this indicates that I needed to use a powered hub for the copying to be successful. And, could it also mean that the files got corrupted due to the hard drives being ejected mistakenly several times.? Anybody have any thoughts or suggestions?


I am experiencing the same issue since yesterday

I expect someone from Staff may take care of your problem and both (yours and mine) get solved quickly

BTW no changes at all from day previous yesterday to yesterday. No new music added, no change of HD, no new stuff (players) added… simply skipping files :frowning:

It seems to be a common problem. I have an audiophile friend who lives in Tacoma so it’s not an isolated issue. Do you have any thoughts (no matter how outrageous) about what’s causing this? I’ll work with anything, even “aliens have decided they don’t like Roon and they’re just messing with us.” Well, ok, I won’t go for that explanation.

1 Like

This is a massively common problem. I have it as well. Is there any option I can change to make roon less sensitive to loading tracks? I would significantly rather have my track pause for a second and finish playing than just have an infinite skip loop when my internet is vaguely slow. better yet, I dont give a single care about my memory usage, is there any way to just buffer the entire song before it ever plays? This issue is so annoying its literally making me not use roon for my listening recently

1 Like

My educated guess (out from Alien’s scope, as far as I know about them) is related to have music on a NAS and the NAS under PLC connectivity, which means 10/100 but Roon is comfortably installed onto a i3 machine with 8Gb RAM and a beautiful 10/100/1000 net connection.

You gave me an idea. I have changed the setup on my S2 to make a bigger buffer before start playing. See what happens…

1 Like

I set my buffer at 500ms and didnt notice any difference at all

Did that make any difference? Problem solved?

Joe, what is your best guess theory as to what the problem is?

As a first step I’d suggest simplifying your network, i.e. remove the EtherRegen and OpticalRendu and just use Cat 5 or Cat 6 ethernet cables. At this stage - i.e. before support weigh in - I think it makes sense to eliminate some of the possible causes. By swapping out the EtherRegen and OpticalRendu we can rule out (or make a move towards ruling out) your network as a possible cause of this problem.

From reading these threads for a few years the cause of ‘files loading slowly’ is nearly always network related. Roon requires a robust network to operate properly and, even when other programs are working well, Roon may stumble if your network isn’t solid.

Thanks for your reply Dave. I’m happy to try your suggestion, but I have a preliminary problem. The network doesn’t recognize the music hard drive now, so I can’t do anything until that problem is fixed. It’s weird. My server (SonicTransporter i5) clearly recognizes the hard drive attached to it, but the network does not. Without that step, I can’t get Roon to notice and scan the contents of the hard drive. Any thoughts about how to fix that problem?

I don’t know much about the SonicTransporters, but why do you need to identify the hard drive over the network? If the ST is running Roon, isn’t the hard drive locally attached? On my Mac, I can add local folders and network shares. What are you seeing in the Storage tab in settings?

This is what I’m seeing. If there’s a way to navigate to the music hard drive, I haven’t been able to figure it out

What happens if you click the ‘+ Add folder’ button? Are you able to navigate to the drive and re-add it?

I did that and it initially created a new version of the old folder with close to 80,000 tracks. When I tried to play something on the hard drive, it reacted with a message that essentially said it cant play the track because it’s loading too slowly. Then I noticed that the 80,00 track number started to decrease on its own and its down to zero tracks now. Not sure how to identify the exact name of the folder the music is in and get it to rescan those files

In which case, unless anyone else has any good ideas, I think you’ll need to wait for @support to take a look and see if they can work this out for you.