Roon skips tracks from TIDAL

For me it doesn’t skip, but way too often it doesn’t play at all. Sometimes it might play but after selecting a different track it goes into infinite “loading” and never starts to play that day, next day it might decide to play again. This is only in ROON, when it try the same tracks through tidal itself it works.
No WiFi, my Roon server is on M1 MacMini with ethernet wired. For me it started sometimes in late December 2021. First I attributed it to some MQA trickery, I tried to disable/enable all different setting combination, but wasn’t able to find a reliable settings to prevent this from happening

I’ve replied in the thread pertinent to my own problem, no response yet from Ashley.

When switching from NUC Rock to Mac Pro core I have no issues playing Tidal files. Has been working fine for a couple of days now.

So the problem is with the Roon Rock Core. I’m hoping Ashley will be able to help diagnose the Rock problems.

There is a consensus developing that this began in December 2021. Possibly a non fatal bug during installation. It’s cost me hours playing around with my network but when I switched machines for the core it works fine.

Can you please try to skip Tidal playback 3-7 times and let me know if it works. Sometimes when I get it to work in the morning and it seems like it is working, I try to skip and then it is back to the same not working at all.

Just skipping 7 tidal tracks and gone back to playing. No problems still.

It’s been flawless since moving the core.

Thank you taking this risk. I cannot really move my core, but I can try to flash some caches and re-install it this upcoming weekend.
It seem that ROON support should be all over it, but they are AWOL. I end up using Apple Music for my streaming needs more and more and Roon only for my own library.

Yes, it’s a really frustrating problem. I had got used to putting Roon on and letting it run. Now it’s more like getting up to turn the record over!

WIth it running smoothly on my Mac it’s been a much more relaxed day.

I guess I’ll have to rebuild my NUC too. At least I’ve closed down my network investigations for now. That was very time consuming.

Started my morning by dumping all the ROON caches in my core. Restarted, started playing Tidal, it played 2 tracks, no skipping, just as it should. On the third one it stopped 1/3 into the track, refusing to play any more Tidal and I’m back to be “Tidal Free”.
With all the perturbations over the last 20+ years with Apple’s iTunes/Music, it always played from my computer to my endpoints, but ROON was a nice dream. Still hope they are trying…

Hey @tudupka,

I wonder if you’ve had a chance to try the solution that Brian has announced a few days ago (reboot your Core twice in a row)?

If that doesn’t work, we’d really like to continue troubleshooting the skipping specifically for your case. Would you please share the details below?

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

Core: MacMini M1 16Gb of RAM, 1TB internal HD, 5Tb external HD with all of my music files.
Networking: Fios → Ubiquiti - EdgeRouter™ Lite → J9561A - HP V1410-24G Switch → MacMini, no WIFI
Device 1: RPI3 connected with ethernet to the same switch J9561A, running RoPieeeXL outputing coaxial signal via Allo Digione hat.
Device 2: USB dac out of MacMini
some other but even Device 2, local to Core exhibiting this behaviour
Library: 112,677 tracks

The above hasn’t change much for about a year. Local files play to any device as before, only Tidal playback is affected.

Continuation of issue:
Rebooted it 4 times in a row, doesn’t seem to make any difference.
After these 4 reboots - first try to play a Tidal album, first track seems to play, when I try to advance to the next track, it is bouncing blue bar in Roon…

trying to get the next track…starts playing it after about 1-2 min, but goes into skipping after 10-20 seconds, until it is stuck again. I try to play a different album, nothing happens for another 1-2 minutes, then it starts playing, doesn’t seem to skip.
This 1-2 minutes before something plays, might be related to what I read in some other thread that Roon is trying to get a full track before it starts playing, it seems that it takes forever, in two minutes I could download a full album, so even that explanation is not quite working. It is also not guaranteed that it would start, sometimes it will, quite ofter it will not, it will go into bouncing back and forth blue light bar, I let it do it for 20+ min, after which I quit ROON and switch to AM.

1 Like

2 posts were merged into an existing topic: Massive TIDAL playback problems

Hey @tudupka,

I appreciate you taking the time to describe in detail both the setup and the way you’re experiencing the skipping.

Would you please attempt to play a track from TIDAL in Roon, but to system output? You may need to enable it first in Settings → Audio.

Does any skipping occur?

System output exhibits the same skipping and erratic behavior.
I know we are trying to illuminate all the external to ROON IO, but it seems to be that the team would need to take a look at their commits and see where they have made changes to the Tidal playback back in December, or prior to the release. Because it use to work just fine for everybody, but now plenty of us experiencing this. You can look at all of our different systems, but something caused that change it is not us.

Hey @tudupka,

Thanks for testing that as well.

Would you please:

  • play to system output for a few minutes (allowing time for the issue to occur)
  • share with us the local date and time
  • upload the entire (zipped) logs folder to our drive

We’d love to take a closer look and see what is happening on your end.

I didn’t have to do anything, but today, everything works as it use to. I tried, System, local DAC, remote endpoint, just like it was two month ago. I even tried to play Tidal to local and remote at the same time, different albums, tried to skip, etc. It is amazing when it works!

I noticed that this thread is resolved too: Playback from TIDAL skips
Since I had to do nothing, it would be interesting to know if this is resolved for others as well and WHAT WAS THE PROBLEM.

1 Like

…and back again. This morning is back to skipping and back to hanging. It has been 30 min, skipped 4 tracks, finally waited for another track to start playing for 1-2 min, it started playing, then skipped, now waiting for another track to load… … skipped the whole track without even playing, next track started playing right away but skipped a few seconds in and so was the next one. Well at this point I cannot torture myself any longer and will listen to AM.
What could it be :thinking:?

I wish everything would have concluded with the post before the last one — it sounded divine :angel:

I am so sorry things went back to how they were before. Would you please:

  • play to system output for a few minutes (allowing time for the issue to occur)
  • share with us the local date and time
  • upload the entire (zipped) logs folder to our drive

We’d love to take a look and see what is happening, to make relevant suggestions :nerd_face:

The update that we had last week(Build 898) seems to address my woes. No more hanging or skipping.
Thank you!!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.