Roon skips tracks on slowdown

@Bob_Hendricks
Thanks I might have to try changing the streaming to “standard”. Are we talking about a noticeable drop in sound quality?
I’m also going to consider a change from powerline adapter/extender to mesh network adapter/extender, but I’m dubious to the actual difference i’d encounter . @dylan

Hey @Anthony_Gilby,

First, I definitely recommend checking out our networking guide. We have some great information there that will be sure to help!

Before making any purchases, I’d recommend performing a test with a simplified network as mentioned above (connecting to the router directly via Ethernet). This way we can for sure track down the root cause of the behavior you’re experiencing. If it’s determined that the powerline adapter may be playing into the behavior you’re experiencing then a mesh network may be a suitable replacement, but I just want to make sure we know the root cause for sure before suggesting any purchases.

Thanks!
Dylan

To my ears, the Tidal Standard stream sounds good enough through my Oppo 105D USB DAC. Better than Apple Music through Oppo 105D via HDMI. The Tidal HiFi stream was definitely better when it worked which was not often, but I am happy enough with the Standard stream to proceed with the move to Roon/Tidal. I will switch to Tidal HiFi immediately if we ever get decent Internet service out here in the sticks. I switched to a mesh WiFi network recently because I noticed some WiFi issues with my Linksys WRT1900 (devices dropping, signal loss, etc). I’m now using Netgear Orbi with the Roon Core connected via Ethernet to one of the Orbi satellite units.

I’m still experiencing this track skipping issue and its still as frustrating as it was.

Can Roon help??? It’s the only thing stopping me from purchasing currently

@Support :no_mouth:

Hey @Anthony_Gilby1,

Were you able to test out things out with a simplified network, as mentioned above (connecting the Core to the router directly via Ethernet)? If so, is there any change in behavior here?

Thanks!

Hi, to be honest not really. This isn’t really possible for me. Unless I buy a separate server I guess. I did connect via the passthrough power sockets and that still had the same problems. I don’t ever get this issue with Tidal desktop app though, so wondered why Roon behaves this way (I’d be happy with slowdown pausing the track (during buffering), just wish it didn’t skip to the next track).

Are we saying that in order for me to make full use of Roon I’m going to have to fork out lots of money on a proper Roon server? I guess I’ll stick with just Tidal for now in that case.

Hey @Anthony_Gilby,

While I totally understand that this may not be a permanent solution for you, temporarily moving the Core machine and testing should allow us to further understand what you’re experiencing and help us determine a solution. In the past we have traced similar behavior to the use of powerline adapters, and so it testing with those removed will allow us to confirm if that’s the case here or if there are perhaps other issues at play. The troubles you’re experiencing definitely seem to be networking related, so simplifying the network and testing is a great first step to finding out exactly what about the network is causing your issues.

If you have any questions or anything here please let me know!

Thanks,
Dylan

I don’t currently have a subscription for Roon as my trial has just come to an end. I don’t think I can justify a yearly subscription at this time given the issues I’m experiencing. Tidal is fine for now though, despite the potential of Roon. thanks

Hey @Anthony_Gilby,

I’ve just sent you a PM.

Thanks!

Hi Dylan,

I’ve tried connecting the MacBook running the core directly to my router and I’m still getting the same problem in that it skips tracks due to ‘slow tidal’. It did feel a bit more stable being directly connected at first, but it didn’t last long and the errors came thick and fast after that. Is it my internet speed in general? I think I get somewhere between 12-15mb/s.

Any other solutions?

@support

Anthony

Hi @Anthony_Gilby,

It may be general network speed issues that you’re experiencing here. This could be from the speeds provided by the ISP (what ISP are you using?) or from the router. In general, we typically recommend against Apple networking hardware as we have seen these devices cause similar issues in the past.

In the past we have seen Google DNS help with similar reports. Can you try using Google DNS and let us know if you notice a change?

I also tried removing the Apple hardware out of the chain, and directly connecting to my IP router. I still had the same issue.

What is Google DNS?

Hi @Anthony_Gilby,

You can read more details about Google DNS on their website. In short, this is an alternative to the standard DNS servers that your ISP uses and we have seen this improve TIDAL performance in the past. TIDAL also recommends the use of Google DNS to improve performance.

12-15 mb/s is plenty. I have a download speed of 400 mb/s and the same has and does happen to me at any given time. Like many others here the Tidal Desktop app always plays just fine. I have tried many different tweaks like Static IP, DNS settings, no wireless etc. and if it decides that it wants to slowdown it will.

It usually happens to me when there is other network activity going on. Scheduled backups of other devices, others streaming from Netflix, Amazon or XBox. If I am listening to Roon on my PC while surfing the internet, then sites like Youtube videos or videos on other sites are very slow to load if they load at all and so if there are other users in my house trying to surf with streaming, then this is when I have problems with Tidal in Roon and or at the same time the others are have trouble loading their content.

If I try to use Tidal thru Roon when they are streaming, then I get the slow network issue. If Tidal is streaming ok thru Roon prior to anyone else on the network, everything is ok for me with regard with Tidal. However they have issues with slow navigation and getting the video up and going if I am using Tidal thru Roon prior to any other network activity.

Once Roon is closed out, then all network streaming activity goes back to normal. I have found that Roon demands a certain amount of data for transmission and it seems that it is prioritized over other traffic.

With each minor update release of Roon it seems to be a little bit more reliable in part because the Roon team is aware of this issue because it keeps coming up here on the forum.

I hope that this helps even though I have no answer for you.

–MD

1 Like

I’ve done that (google DNS) and I’m still getting the issues. Anything else?

I’ve noticed that the issue seems to happen more when I decide to skip a track manually (when playing an album/playlist), Roon then decides that Tidal is slow and skips the NEXT track completely.

If I then go back and click on play the ALBUM again from the start or press play to the left of a track, it seems to work most of the time. The issue appears to happen a lot of the time when I press >I

Its not all the time though. Sometimes it just skips when it feels like it

Hi Mike,

I appreciate your response. And at least it’s not me.

Hopefully Roon will eventually work out how to fix this problem then! I don’t even think I’m doing much online at the same time as Roon to be fair.

It’s weird that Tidal itself doesn’t have these problems, just Roon trying to play Tidal.

Ant

Hi @Anthony_Gilby,

In general, Roon is more aggressive with it’s buffering than the standard TIDAL app, which may be why you’re able to play TIDAL directly fine, but not within Roon. This is something we are investigating making changes to, but currently Roon requires a little bit more from your network.

One thing I’d like to recommend is using a VPN and seeing if there are any changes here for you. I’ve seen this help with a similar report and may be worth giving a go here.

A post was split to a new topic: Qobuz tracks skipping

A post was split to a new topic: Issue with skipping tracks