Roon skips tracks on slowdown

Incredibly frustrating issue. Using Tidal with Roon. If internet slows and Tidal needs to buffer, Roon will just skip to next track (as if that would ever be the desired result here!).
Getting very impatient with Roon now, Tidal app doesn’t do this and is considerably cheaper.

Also, not sure why I was instructed to post here rather than have the Roon staff member just deal with it in the first instance.



Roon staff conduct all user support via the forum, rather than via email or messaging.
Your report / support request will be logged and assigned to a member of Roon support staff shortly.

In the meantime can you describe your Roon setup, including network devices and ISP connection.

Hey @Anthony_Gilby — Thanks for sharing your report with us!

I apologize for the difficulties you are having here, and I appreciate your feedback about our support process. We sometimes hear from people wondering about phone support, email support, or other more traditional methods, and we almost always win them over by resolving problems here every day. I can tell you that we stand behind our products and our support 100%.

Every support thread on this site is tracked by someone on our staff, and they frequently loop in senior staff or developers for feedback. Nearly everyone in our company spends time on this site.

So we can have a better idea of what’s going on here, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Additionally, may I ask that you please verify the following:

  • Does this behavior occur when playing to all endpoints? If you play to System Output of the Core machine does the skipping behavior still happen?
  • How often would you say you see this behavior? When it occurs do you see an error message?
  • Has this behavior always occurred with Roon? If not, can you remember when it first started happening? Was there any change in your setup around that time?


Blimey you want a lot of info!

Roon 1.5 (build 334)
MacBook Pro (15 inch, late 2016)
2.6 GHz intel core i7
MacOS High Sierra v. 10.13.6

Tidal Hifi, only really stream tracks from Tidal but occasionally play FLACs on NAS drive (but issue is only with Tidal it seems).

Router is an Apple Timecapsule

End point mainly used is an SOtM sMS-200 Neo however ALL endpoints including core have the same problem.

It used to happen infrequently, now it’s every hour and happens most tracks until I give up and do something else. Normally works if I come back to it hours later.

Error is “Tidal: Tidal media is loading slowly. This may indicate a networking or convectively problem”. Then it just skips to the next track. Again, I ask WHY would I want it to skip to the next track??

1 Like

Thanks for the details, @Anthony_Gilby!

May I also ask that you provide some additional information about your network? What kind of speed do you have from your ISP? How is your Core machine connected to the network (Ethernet vs WiFi)?

I’d like to recommend clearing your TIDAL cache. Please give this a try and let me know if there is any improvement!

  1. Shutdown your Roon Core
  2. Find and open your Roon database
  3. Navigate to /Library/Roon/Cache
  4. Move the contents of the /Cache folder elsewhere, like your desktop
  5. Try restarting Roon and syncing Tidal


I get between 5mbps and 15mbps. Core is over WiFi.

I tried the cache thing but the instructions are useless. It says for MAC go to “finder” and select GO at the top. That is not an option!


I’m officially ending my interest in Roon now as this is utterly unacceptable from a premium service. Back to Tidal app for me as I can listen to a whole album in that without it skipping the entire middle section of it

Hi @Anthony_Gilby ---- Thank you again for the continued feedback. The insight has been very appreciated and again, sorry to hear of the troubles.

I wanted to hop in here real fast because you mentioned that the instructions provided by Dylan were “useless”:

“I tried the cache thing but the instructions are useless. It says for MAC go to “finder” and select GO at the top. That is not an option!”

I checked the provided link to make sure all the information was present in our knowledge base article on how to locate the Roon database and as you can see the article mentions the following:

Are you unable to locate your Roon DB on the mentioned MacBook Pro using the above instructions?


Thanks but you’ve just reiterated the instructions of Dylan. As I mentioned the instructions appear to be incomplete. It says go to finder and hit GO at the top. What does this mean exactly as this isn’t an option on my Mac. There is no “GO”

Hi @Anthony_Gilby ---- Thank you for the clarification.

Here is a screenshot from one of the Mac devices I have at my desk:


As you can see “GO” is present at the top of my screen. Based on your most recent it sounds like you may have hidden the “menu bar” in your OSX settings. May I kindly ask you to please make the following adjustment to your system preferences and then confirm if you are able to see “GO”.

  • Open “system preferences”
  • Select “general” then uncheck the box of “automatically hide and show the menu bar”


Thank you. I’ve cleared the cache and I’m still getting the error

It’s not even just Tidal now. When playing something else (Flac from NAS drive) it’s saying “Roon: Audio file is loading slowly. This may indicate a performance or hardware problem” and skips to the next track

Hey @Anthony_Gilby,

Thanks for giving that a try, and for the additional details here. I’d like to recommend a test that should give us some great data and allow us to further pinpoint this behavior’s cause.

Recommended Test

In order to further pinpoint the cause of the issue, I’d like to propose this test.

I’d like to try using some of the media that is giving this error (from the NAS) directly on the Core machine. Please see the following steps:

  1. Move an album or two from the NAS to the internal storage of the Core machine.
  2. Add the location you store this at as a watched folder in Roon.
  3. Try playing this media in Roon from this storage location.

When doing this test do you notice the same behavior?


1 Like

Ok, now I think about it my previous test was not from a NAS but from the hard drive of the Core computer as I’ve just checked the watches folders. Roon is not currently looking at my NAS so any non-Tidal tracks are on the Core computer. Sorry about that.

The “skipping” issue is not occurring at the moment, but it definitely was affected Core store tracks earlier.


Thank you for clarifying, @Anthony_Gilby.

When this behavior occurred when playing local content, was there anything different you about your interactions with Roon? What endpoint were you playing to? How was this endpoint connected to the Core machine?

We’d also like to know a little more about your network:

  • Are there any other networking devices besides the Timecapsule? Any switches or anything like that?
  • You mentioned that this didn’t used to be as frequent. Around when this started happening more often, were there any changes to your setup? Were there any newly added applications that utilize the network (Antivirus, VoIP, etc.).
  • How are you endpoints connected to the Core or the Network?


So, as far I’m aware I’m not doing anything different from when I first started using Roon.

I’m using the same end point. It’s the SOtM sMS-200. This is connected to the router via a range extender to pass internet to my listening room that also allows for me to plug Ethernet cables into (the range extender). The Ethernet cable is then plugged into the SOtM unit. I then use Roon on iPhone/tablet to control the music and send it through the SOtM (to external DAC).

Although this setup probably isn’t ideal it appears to allow me to play files from my NAS without Roon ok, so I don’t think this is the issue.

Wondering whether my internet is just too poor for Roon to work.

If the core and endpoints are using wirless then I would put my money on that being the issue. I assume your Nas is hardwired into the router or is that wireless as well?

Thank you for the details, @Anthony_Gilby!

Based on the information you’ve provided, it seems likely that networking difficulties are at play here. I’d like to recommend the following:

  1. If possible, lets try connecting the Core machine to the network via Ethernet. We almost always recommend an Ethernet connection for the Core machine, and knowing if the behavior is any different will certainly help us narrow down the cause further.

  2. Another test I’d like to recommend is trying to connect the DAC directly to the router as opposed to the range extender. We’ve seen issues with some range extenders in the past and we typically recommend against them when possible. Knowing if this is playing into things would be a great data point.

  3. Can you verify how the NAS is connecting to the network? I know it’s not currently in use with Roon, but this would be a great help to further diagnose this issue.

  4. Can you verify how large your collection is on the MacBook Pro that is being watched by Roon?

We also have some a networking guide that I recommend checking out — there’s a lot of great info there that should be helpful!


I had the same problem with Tidal tracks skipping on Roon but not on Tidal. I’m pretty sure it was due to my crappy DSL internet connection. I was able to fix this by changing my Tidal subscription to ‘Premium” with ‘Standard’ streaming quality (250kbps I believe). I’m thinking the Tidal app performed better because I had ‘Optimized Playback’ turned on which changes streaming quality based upon current network conditions. I didn’t see a similar setting for ToR (Tidal over Roon). Downgrading Tidal during a trial subscription was a bit complicated so I just deleted my Tidal account and created a new one at the Premium level.
I have to agree with OP that the choice to skip tracks upon network congestion is a very frustrating user experience. I don’t think other music services behave this way. If I hadn’t implemented the solution outlined above this frustrating behavior would have been a dealbreaker fo me to move to Roon with Tidal. Work is needed here to improve the user experience. Everybody has bad network sometimes. Some of us unfortunates have bad network most of the time…

1 Like

Thanks for your response. I’ll answer in turn.

  1. I’ll have to try this another day as unfortunately I don’t have the necessary adapter to allow me to connect the MacBook to the router. Maybe i might be able to use another laptop actually… either way I’ll not be able to do this until a bit later on (it’s also hard to gauge whether this will prove anything as the issue I’m experiencing is sporadic in nature anyway).

  2. Assume by DAC you mean the SOtM that feeds the DAC. The DAC doesn’t have ability to be plugged directly into a router. For this test should the core computer also be plugged into the router?

  3. NAS is directly connected to router.

  4. Very small library. Must be less than 250 tracks as I haven’t really started ripping my collection properly yet. When you have Tidal available it gets pushed down the priority list so things to do.

I’ll check out the networking guide too