Roon-SonicTransport-Synology NAS

I installed my SonicTransporter i5 & ultraRendu today. I had no problem with setup to my DAC and using my Qobuz account.
My issue is that Roon picked the Sonic Transporter as my storage. I don’t know how to change this. I tried to add storage but I have no idea what the network address is for the Synology DS1019+.

Any suggestions?


Do you know how to get into the GUI of the NAS? The IP address is there under Network.

Thanks John, I have heard the term GUI but no idea what it is. What network setting would that be how would I find it.

Not having a laptop connected is all new to me. Not the I knew much about laptops either.


Not going to be much help to you. GUI = Graphical User Interface. There is a helper program you can download from the Synology web site called Synology Assistant. With it you can discover the NAS on your network and it will also show the IP address. Good luck.

Thanks that is a starting point.


Also can you ‘discover’ your NAS on your network in Windows?
If so, right click for properties and you should get the IP address the NAS has been assigned.
However you will likely have to access the Control Panel for the NAS, if you want to select a static IP address for the NAS and open up filesharing & permissions on the directories/shares you have your music stored in.
I presume you are wanting to use the SonicTransporter to run Roon Core, the content to be on the NAS and the UltraRendu the Roon endpoint?
Alternatively, depending on the size of the disk in the ST and your library, copy all files over to the ST and use the NAS as backup for your library. Both scenarios work, however you should maintain a backup of your library somewhere, as HDDs can fail.

I went into the NAS and found the IP Address. I tried that in the Network Path and it was rejected.
I took the name of the NAS I found there and tried that and it was rejected.

I am not using the ST for my library. I am running raid 5 on the Synology and have a separate hard drive with back up off site.

It just seems off that the ST doesn’t see the NAS connected to the same network switch.

In Roon I show no storage device.


Ok in Roon, go into Settings, then Storage

Select ‘Add Folder’

Then ‘Add Network Share’

You then need to add in the network details of your NAS, including the directory you wish to connect to that contains your music files.

You will see that use hostnames of my NAS units ‘dingo3’ being the main RAID1 volume, ‘dingo2’ being a supplemental (and part backup) RAID1 and not connected to Roon, unless they fail, is dingo4, as a complete backup in RAID1, and dingo1 as a legacy JBOD NAS.

My main folder is called ‘Media\Music’, but I have two other storage locations for MQA & DSD duplicates & formats not supported by my legacy UPnP server, which also still scans the NAS volumes.

Once you have added your network location of your folders Roon will start to scan them.
Also you will need to check the ‘Automatic Rescan Interval’ as NAS units don’t always let Roon know that changes have been made.

Does that help?

This is what I get with either of the pathways that are located where you said they would be.

This is what I have for options.

When I log into the Synology with the laptop i used before SonicTransporter
The first is the IP Address of the Synology
The second is the name of the Synology

Your network share name is incorrect. It should be \\IP address (your actual IP address)\the name of your network share. There is an example right under where you put original-ks.cfg.

This is the address as you suggested I think.
Still doesn’t like it.

Thanks John

You need to add a share name most likely will be \music after the IP address…it’s per the example…you were pointed to above

1 Like

What’s the directory structure on your NAS?
Which folders are set as ‘Shares’?
This will need to be where the Roon Core connects.


Do you have any friends with computer or networking experience? You really could use a hand. The Network Share Location you specified is not complete. Right now you have \\ but you need to add a \ after the 47 with the share name. Some guys are suggesting \music but it might not be that. It could be \share or \Share or something else. You really need to know the path to get where you need to go.

1 Like

Synology has a default music share if you have installed any of the music related apps

1 Like

Synology’s default music folder is “music,” try this in Roon:


If you haven’t already, you must also configure the Sonictransporter to connect to the Synology. Although your music is stored on the NAS, the Sonictransporter indexes the music files. To do that, go to the Sonic interface (enter the IP address of the Sonictransporter in your browser), go to settings, drive mounter, the smb tab, and enter the same Synology share address in the SMB share name field: \\music. Also enter the user name and password for your Synology. At the bottom of this page, the mount point should already be filled by default as \storage\nas. Once that’s done, restart the SonicTransporter.

Hi @Brad_Rockwood.

In the post above

Should have two backslashes to start. \\\music

If you use a host name rather than IP address, sometimes adding a .local postfix to the Synology host name helps. So e.g. \\MySynology.local\MyMusicShare for a ‘host’ device called MySynology and a ‘share’ called MyMusicShare.

Key thing though as mentioned by some above with examples is to first determine your Synology network address (name or IP address) as the ‘host’, and the correct ‘share’ on it for your music. Enter these for the Network Share Location under ‘Add Network Share’ according to the template and examples given.

If the guidance here makes no sense to you, maybe ask a friend with some networking knowledge to read your post and the responses and set things up for you?

Thanks. Very strange, it has two backslashes when I edit it, but they don’t show for some reason.

Backslashes and some other special characters need to be escaped, I always forget myself, including in my earlier response before editing it :grinning:. 4 consecutives backslashes will do to render 2, there is probably a more elegant way.