Roon still works but not on PC it's installed on

Roon Core Machine

The Roon Core is a Windows 10 PC
No Model Custom , 64-bit operating system, x64-based processor
ntel(R) Core™ i5-3570 CPU @ 3.40GHz 3.40 GHz
16.0 GB (15.9 GB usable)#

Networking Gear & Setup Details

Ethernet, no vpn

Connected Audio Devices

Number of Tracks in Library

about 6000 albums

Description of Issue

Roon works on Sonos, and on Linn Select in other rooms but not on the core pc it is installed on.
For years it has shown up in my list, but now just Sonos and Linn.
On my phone it lists Linn, Sonos And The phone!
How can I make it work, like it always has, on my Pc too .
Many thanks, hope it’s easy to fix.

If I understand you correctly, you’re saying that the PC’s audio devices no longer show up in Roon’s Settings > Audio screen?

If so, then this may be a Firewall exception issue. Windows Updates occasionally have a habit of wiping out application settings in the Firewall. Check that there is an exception rule for RAATServer.exe in place for both the public and private networks in the Firewall.

1 Like

Hi Michael,

In addition to Geoff’s excellent suggestion, also, check to make sure your network is Private and not Public.


I tried switching off the firewall to see if it worked. And rebooted the PC after so that Roon restarted, but still it just lists the Linn Select and Sonos, but not the Pc , so can’t play Roon music on PC.
I also tried renaming RATT folder too old and rebooting to force it to make a new Ratt and it still did nothing, (I had read something about that).

Is there anything else I could try?
It has been working on the PC since I first got roon, and it just stopped a couple of days ago I think.
There has been no changes to the pc.

An errant Windows update that is not a changed Firewall exception, perhaps?

Was there an update just prior to your troubles? If yes, fall off the update as an experiment.

Only update this year I uninstalled but still cant play on PC its installed on, (Not in list)

Hi @Michael_Hurry,

Did you happen to verify whether or not the PC was set to Private vs Public network? This impacts device discovery and could be an issue.


1 Like

It’s set to private network.
Whatever is wrong it’s not just a straight forward fix it seems :disappointed:

@Michael_Hurry that just makes things more fun right?

Let’s try a clean install of Roon on the PC.

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Please let me know if you get stuck doing these steps or run into any questions as you proceed!


I have did as instructed, (with fear vibrating through my core (Not roons one), and it is working.
But now I cant get to roon from Phone or Ipad.
I suspect that maybe if I uninstall from phone and ipad then reinstall the apps would it work? Or is there some other wizardry that would rectify my new troubles.

PS I have uninstalled the roon android app and reinstalled and it seems to be working fine. (Thank the lords), so I hope this hasnt been too easy for you to fix and spoiled your fun lol

I have lost all my tags and favourites so should i restore the back up?
I DID THE BACKUP and now it dosnt see PC again but my tags and bookmarks are back.
Also it doesn’t see phone anymore though it did before :disappointed:

So how should I proceed?

Hi @Michael_Hurry,

It seems like there’s something in your database that is causing this. Can you give me the approximate time (and was it today?) that you restored the backup? I would like to look at this with my team.

Normally, I’d expect the RAATServer rename to help us here. Would you mind trying that again too?


It was today, I think around 4pm.
Just before I posted saying I thought it was fixed.
I renamed the ratt file again.

Since then I put back the old ratt file to see if it made phone work, but it didn’t.
If I reinstall roon it works on PC but loses tags , bookmarks, and some playlists.
Restore backup and then loses tags etc.
Eager to get it working again.
If I could restore an older backup would that work?
I looked for older backups but I only saw them when did new install.
Help :disappointed::disappointed:

I found out how to get to older backups so I am using one from the same build December 14th or something. to see if that works and will report.This restored backup is at 3am UK time.

Same result no PC showing up :frowning:
Tried another backup after the 3am one. Same :frowning:
Fresh reinstall brings it all back and that would be good, except no tags, bookmarks, and some playlists missing. So if there is a way to do fresh install and get tags etc back that would be fine.

So not now showing on phone or PC.

Windows 10 had a mandatory update yesterday.

After that my Roon will not function correctly, so I would also like to try a fresh install.

Hi @Michael_Hurry,

Can I have you confirm that things work whenever you fresh install but don’t restore your backup? It’s possible your backup is corrupted. If this is the case, I absolutely recommend trying an older backup if that’s what it takes to get you back up and running.


I have tried older backups, doing the Ratt. Old and new.
The backup recovers,tags,playlists etc perfectly well but!

If I do a clean install that allows it to work on Computer (core), and Linn Select and Sonos and phone.BUT no tags and bookmarks and some playlists.

So backup then restores tags,bookmarks,playlist but then only plays on Linn Select, and Sonos.

If forced I would keep the tags etc, and sacrifice playing on computer, and phone.

So the backups work, but limit where roon plays,and I would miss that.

Is there no way to get the tags,bookmarks back( using backup) but also playable, like it always has been, on comp, and phone too?

Also I tried reverting windows back to before latest updates and still same!

Something happened that stops its core being visible to it,and also the phone.

When I first asked about this the phone worked fine (android).
The iPad still works.
So it can’t just be the backups?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.