Roon stopped identifying SOtM network device...again


(Charles Wells) #21

Ah, thanks for the clarification. Regardless, change the DNS server didn’t fix the problem.


(Noris) #23

Hello @Charles_Wells,

I would definitely start off by eliminating the power-line adapters from the equation, as we have seen issues with these types of devices in the past and your 125ft cable should take care of this aspect. I would also check your Netgear router settings to make sure that multicast is enabled and that you are not performing any multicast filtering.

Also in the past, we have seen some routers require IGMP Snooping/Proxing settings to properly discover endpoints, and while your specific router model is not on the current list we have in our Networking Best Practices Doc, it is possible that it could require these settings.

Do let us know how it goes when the new cable arrives and if you have a chance to toggle those IGMP settings it would be interesting to know if they make a difference.

Thanks,
Noris


(Charles Wells) #24

Thank you for your reply. I’ll follow-up after I test the system without PoE.


(Charles Wells) #25

Well, the results of the recent tests were, to me, surprising and disappointing.

First I booted everything for (another) baseline test: as has happened several times recently, Roon Control identified the sms200ultra, but it wouldn’t play music (tracks “played” in less than a second, without sound).

Then I looked in the settings of my Netgear AC1750 (model R6400) router. I couldn’t find anything that referenced “multicast”; the only thing I could find related to IGMP was under WAN setup: “Disable IGMP proxying.” It was checked, so I unchecked it and applied the change (screenshot below). Then I rebooted everything. The result was the same: Roon recognized the sms200, but wouldn’t play music.

Then I disconnected the PoE adapters, and connected the sms200 directly to the router with my new 150 foot ethernet cable. Rebooted everything. This time, Roon didn’t identify the sms200. This surprised me…I thought PoE was going to be the culprit. I rebooted everything: same result. Rebooted everything a third time, and for no obvious reason, this time Roon identified the sms200 again – but it still wouldn’t play music.


#26

Your problem reeks of something wrong in the network.

I have two suggestions, only one network related.

The first is quick, but probably won’t make a difference. Stop using DHCP in the 200ultra and set a static IP from the 200ultra’s menu. Make sure to use the same IP that you reserved in your router software for the 200ultra. Try it just for yuks. Easy to do and undo if it doesn’t make a difference.

The second suggestion is to re-flash the ultra200’s OS. In my sms-200, the OS got corrupted twice and it resulted in some weird shit. This will take longer and you’ll have to get in touch with May P. at SOtM. I don’t think you can use the same OS as for the SMS-200. I think the 200ultra uses a different image.

I’d say give May my regards, but she doesn’t know me by my avatar name.


(Charles Wells) #27

Slim, before I respond to your latest message (thank you!) I want to send an update about something I just did.

On a whim, I disconnected the SOtM tX-USBultra that sits between my streamer (sms200ultra) and Kii control. NOTE: I’ve tried this before without success. But to my surprise, it worked: the system played music. It wasn’t perfect though: there were intermittent “clicks,” every 2 seconds or so I’d guess. Sounded almost like the little clicks/pops you’d hear playing a record. I’ve never heard these before in my system. These clicks weren’t permanent, though. I tried a different track, and they went away. Then went back to the original track, and still no clicks.

I reconnected the tX-USBultra, and music still played! Again, there were intermittent clicks. I let the track play for 30 seconds or so, then tried a different track - no clicks. Went back to the original track - no clicks.

Now I’m truly stumped. I can’t figure out what’s going on…I can’t isolate the problem!


#28

Aha, I didn’t remember you saying you had a tX-USBultra in the chain. Seems a little over-processed to use both, but I guess that’s neither here nor there. tX-USBultra is for connecting directly to a USB port on a machine. At least, that’s how I always understood it. I doesn’t seem like it should technically make a difference, even though experientially it did.

Dunno. Maybe, if you haven’t already, run that particular chain setup by SOtM support.

At least there’s good news. It doesn’t look like WiFi was the problem since Ethernet was no better.


(Charles Wells) #29

The tx-USBultra is designed to be used with the sms200ultra. In fact SOtM sells them together with a power supply that powers both units – which is the setup I have.

I turned the Kii control off for a few minutes, then turned it back on. Again, music played, with clicks on the first track (alac ripped from CD). Pausing the track didn’t stop the clicks, but as before, switching to a different track, then back to the original track, did stop them.

Again, this is with the the sms200ultra connected directly by ethernet cable to my router, and with the tx-USBultra in the system. So in the course of one evening, the same hardware configuration has behaved four different ways:

  1. Roon doesn’t identify sms200ultra
  2. Roon does identify sms200ultra, but won’t play music
  3. Music plays, but with clicks
  4. Music plays normally

#30

Dunno what else except for one other thing I just remembered.

For awhile I had my SMS-200 feeding an iFi Micro iDAC2. Everything was as it should.

Then I bought an iFi Pro iDSD and fed it with the SMS-200. The first track that I played after first turning everything on for the day always had a loud popping/clicking. Every track played after that was alright.

I’m wondering with all the turning on/off/on if you aren’t accidentally recreating the first of the day equipment turn on. Doesn’t solve anything, but it may be just a red herring in your original problem.

Never did get to the bottom of that. Later, I sold the SMS-200, used a Windows mini-PC as my endpoint and the popping/clicking no longer occurred. It would appear as if the SMS-200 was the guilty party in my case.

Sorry, short of re-flashing the 200ultra OS (and that probably won’t make a difference), I have no more suggestions.


(Fredrik) #31

I run a very similar system with sMS-200ultra Neo and tX-USBultra connected to my TAD dac via USB. I run a NUC with Roon ROCK and I have a Netgear GS108 that sits between router, NUC and sMS-200ultra.
I have zero problems with this setup so I dont really know what might cause you’re problem. Have you the possibility to try with another usb dac?


#32

I can’t find this particular ‘package’ anywhere. For my own edification where did you buy, as a ‘package’?

Are you using an sPS-500 with a y cable or an mPS-15va2 for the common power supply?

Also, I notice in the website for the Kii control they go out of their way to specify what streamers the control has been tested with. They never mention SOtM. Can you take the Kii control out of the chain, as a test?. I am unfamiliar with the Kii control/Kii Three speaker setup, as to whether this is possible.

@Fredrik_Andersson - how are you powering your units?


#33

I’m having trouble following all this action. Are you currently able to play music through your system? If so, is this true both using ethernet cable and PoE to the 200Ultra? Perhaps the problem was connection to your dac after all.

If you are still getting clicks, try raising the buffer in Eunhasu RoonReady a lot, say 1.5 just as a test.


(Fredrik) #34

I use two Paul Hynes SR 4 to power my SOtM products and the old 200W HD Plex PSU (4 rails) to power all the other network equipment.


(Daniel Beyer) #35

Hi Charles,

If you have already tried it please disregard, but, I would suggest getting rid of a lot in your chain for testing purposes. Blackjack mentioned it up thread, but taking your audio chain down to the simplest first and then add things back into it, is, imho, the best way to troubleshoot inconsistent errors like you are experiencing.

I would start by removing the SOtM, tX-USBultra (and their power supply) from the chain and

  1. Try a different USB input to the Kii Control, maybe a laptop running RoonBridge
  2. Also, try a different input like Toslink or SPDIF to the Kii Control

(Fredrik) #36

It is not me having problems with SOtM my system works flawless I just happens to use the same products but not a Kii speakers I run a TAD D1000mk2 CD/DAC.


(Noris) #37

Hi @Charles_Wells,

You mentioned this:

This is very interesting behavior to note. Just to confirm here, if you remove the sms200 from the equation, and use just the Kii Control DAC on your NUC directly, does everything perform as expected?

If you then try adding the SOtM tX-USBultra to the mix, do things still remain stable or do you start experiencing issues?

I just want to separate exactly where things start going wrong, and I believe a process of elimination here would help in narrowing down the possible causes.

Thanks,
Noris


(Charles Wells) #38

Hi everyone,
A lot of messages came in yesterday while I was at work – I appreciate all of them. I understand that the basic process is to eliminate variables to try to isolate the problem. I started with the PoE adapters, but that didn’t solve the problem obviously. I’ll continue by connecting the NUC directly to the Kii control, but will probably be this weekend before I have a chance to test that. Will report back – again, thanks everyone for your suggestions.