Roon stopped identifying SOtM network device...again


(Charles Wells) #1

Unfortunately, I’m having a recurring problem that’s worsened. Haven’t been able to play music for several weeks now.

Back in October, Roon periodically was not identifying the Sotm network streamer I use in my listening room (SMS-200ultra), although it always identified the cheap Muzo I use to play background music. Eventually an alpha version software update from Sotm seemed to fix the problem. But it recurred periodically and unpredictably. Now, it’s become the rule rather than the exception. Even if I power everything up sequentially from a cold boot, most of the time, Roon does not list the Sotm as a playback device, though I know it is “online” because I can see it on my network and even access it (via web browser / ip address).

My setup:
Control is running on an iPad, recent model.
Core running on NUC. OS Version 1.0 (build 174) stable, server Version 1.6 (build 401) stable, 64 bit. NUC connected to Netgear AC1750 router via ethernet. (Router firmware up to date.) Router connected to SMS-200ultra network player by a TP-link powerline network adapter (AV2000, model TL-PA9020P). The SMS-200ultra connects to a tx-usbultra, which connects to the Kii control of my Kii Three speakers.


If someone has some insightful explanation as to why this is happening, that would be great obviously. But assuming that’s not the case, one major reason I’m posting is to ask if people think it would be worth trying an alternative to the power line adapters. To reiterate, my powerlines are working, technically–I can access the Sotm device on my network. But when I last posted about this problem, in October, some replies mentioned that powerline adapters could cause problems. I don’t know an easy to way to just take them out of the system because my cable outlet (and therefore router) is downstairs, and my listening room is upstairs. (It’d be easy enough to carry the router / NUC upstairs, but it then wouldn’t be connected to the internet obviously.) I’m willing to try an alternative to power lines , if people think that’s likely to help. But if I do, can anyone recommend a product or products that have been used successfully with Roon? Might I expected better luck using a wifi extender like the TP Link AC2600? Netgear Orbi, or Eero? Something else?

I remember reading a Computer Audiophile article a year or two ago in which he reported great success extending his network using both powerline and wifi range extenders…so I don’t know why I’m having so much trouble. I’m stumped here and would appreciate any input.

Thank you,


#2

Only if they are the root cause of your problem.

You should definitely locate the source of your problem first by following this guide and especially:

Simplify then Rebuild

This is one of the most powerful troubleshooting tools available. With enough care and determination, you can figure about why just about any piece of technology in your life is broken.This can be labor intensive, and it’s surely not fun to drag gear around the house just to troubleshoot a problem, but the effectiveness of this approach makes it worth it. When done carefully, this almost always generates invaluable information about exactly where things are going wrong, which often helps us make progress on tricky issues.

Repeat these steps until you identify the root cause of the problem:

  1. If you’re still having the problem, simplify until the problem goes away
  2. If you’re not having the problem, add elements back into the system one at a time until the problem re-appears.

Assuming that you are able to make the problem disappear and re-appear, you will eventually figure out the cause.

For example, if you’re experiencing dropouts, you might try connecting your audio device and Roon Core directly to your router (bypassing WiFi, any switches, Ethernet over Power, etc.). Assuming this resolves the issue, you would then start re-adding the removed elements one by one until you find the element that triggers the problem.

  • WiFi Extender: If your WiFi signal is that good in the upper floor, that you can place the extender there, you most likely don’t need one. Use a WiFi bridge instead.
    Because of the reinforced concrete construction of my lower floor, the only working solution was to place a second access point (which has to be wired) on the upper floor. I’m using a pair of cisco WAP371 which is ready for this kind of setup (built-in clustering support).
  • Orbi | Eero: Would not only replace your EoP but also your Netgear AC1750 router. I honestly don’t know if they are able to supply your upper floor with a good quality WiFi.

(Henry) #3

I know it isn’t easy to do, but can you eliminate the network adaptors? I use those with no ill effects but they are very dependent on distance and wiring quality/age. You can try this by moving the SOtM device down or the Core up with a switch.


#4

In addition to the networking advice you have already received, you might try to see if your sms200ultra is losing its connection to your dac. I have found that this is the most common reason why my sms200ultra becomes lost to Roon. This can be checked in Eunhasu.

By the way, with the most recent versions of Eunhasu firmware, this no longer happens in my system.


(Charles Wells) #5

Thanks to all of you for your replies.

I’ll start with ronfint’s suggestion, because that was the easiest to test. I just checked, right now: The sms200ultra is visible as a network device, and it seems to recognizing the Kii dac (see printout below). It says I have the latest software version. And yet, the sms200ultra is not listed as a playback device in Roon control. So, I think I can eliminate the sms200ultra losing connection to the dac as the primary problem for now.

So, moving on to the network, specifically the PoE. If I move the sms200ultra downstairs, it seems to me that I’ll also need to move the Kii control and the Kii speakers, since otherwise I’d be changing two variables. Not impossible, but not fun either (the Kiis are cumbersome carry). So I’m wondering: what I ordered a 125 ft ethernet cable and just ran it through the house, connecting the sms200ultra directly to my downstairs router? I wouldn’t want to leave it permanently, but as a test. I wouldn’t have to move equipment, and as a bonus, I’d have the cable in the future if similar problems ever recurred. It looks like I could buy one for < $25.

Does that seem like a good idea? Is there any problem with using a 125 foot cat6 cable?

sms200ultra dacinfo:

**** List of PLAYBACK Hardware Devices ****
card 0: Control [Kii Control], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 005: ID 20b1:0401 XMOS Ltd
Bus 004 Device 004: ID 20b1:30a2 XMOS Ltd
Bus 004 Device 003: ID 0424:2512 Standard Microsystems Corp. USB 2.0 Hub
Bus 004 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
0 [Control ]: USB-Audio - Kii Control
Kii Audio Kii Control at usb-1c1c000.usb-1.3.1, high speed
Kii Audio Kii Control at usb-1c1c000.usb-1.3.1, high speed : USB Audio

Playback:
Status: Stop
Interface 1
Altset 2
Format: S16_LE
Channels: 2
Endpoint: 1 OUT (ASYNC)
Rates:
Data packet interval: 125 us


#6

Is for some reason, the IP of the SMS-200ultra being changed, automagically?

Do you use ‘address reservation’ for the 200’s IP?


(Henry) #7

That cable is perfect for eliminating the power line solution.


(Charles Wells) #8

Slim,

I’ve never used address reservation for anything, but I thought it couldn’t hurt to try. But there’s a twist in the story now:

I powered everything on, and for some reason, this time Roon Control did identify the Sotm. Compared to the many times it’s failed to do so in the past few weeks, nothing had changed (and certainly nothing had changed since the failures earlier today, or yesterday). BUT, it wouldn’t play music. When I tapped a song and then “play now,” the “Playing 1 track” message appeared for about 6 seconds, then disappeared. But the track never actually played. There was no sound, and the gray bar at the bottom displayed “Nothing Playing” the whole time (first screenshot). Then I tried “Play from here,” and the entire album flashed by: each track “played” in less than a second, and again, no music actually played (second screenshot). This has happened to me before, more than once, in the past. Those times, the problem just went away eventually, perhaps due to software updates I assumed.

Then, I reserved IP addresses to my NUC/ROCK and sms200ultra using the Netgear software. I’ve never done that before, but it seemed pretty straightforward (screenshot attached).

Then I rebooted everything. The router showed that ROCK and sms200ultra had been reserved the appropriate IP addresses. I opened the Roon control and tried to play music: the same thing happened. The sms200ultra was recognized, but tracks “played” very rapidly, without actually playing music.

I did a search, and found that several people have reported a similar problem. But I didn’t see an obvious applicable fix. For example, this thread: Tracks "play" in 1-2 seconds? didn’t seem to come to any resolution.

Now I’m really at a loss…

DHCP|690x343


(Charles Wells) #9


(Charles Wells) #10

Thanks so much for confirming that the cable would be a good test tool. Do you think it’s still the most appropriate next step, given the new twist that Roon recognized the sms200, but wouldn’t play music?


#11

The only times I’ve seen this was when my DAC wasn’t connected or turned on, etc. Maybe a re-boot of everything you could possibly re-boot?

Did you talk to SOtM support? I’ve found them to be very responsive.

I used to have an SMS-200, without any problems. No matter what the problem resolution turns out to be, you probably should leave ‘address reservation’ on, for general principles.


(Henry) #12

If you are able to eliminate the power line plugs you can stop worrying about them. If the problem is them you should be able to come up with a fix.


#13

I hope that I’m not wasting your time, but in Eunhasu, System Setup > System config, this is the response that I had when the link speed was set to 100BASE-T. When I changed to 1000BASE-T, all was well.


(Charles Wells) #14

Slim:

I messaged SOtM about two weeks ago. At that time May responded:

Our server got some issues lately, and during the weekend, we’ve worked to solve the maintenance issues and seems all is fine.
We will take the 4.59 version back to the server and you are able to download the latest image file or update the 4.59 version through the update page again.
Sorry to cause you the concern and the situation.
Thanks.
Best regards, May

I’ve currently got version V0.4.59 installed, which is identified as the latest version. I haven’t messaged her since then.

I did reboot everything again just now, with the same outcome: Roon again identified the SOtM (no idea why that’s changed) but still wouldn’t play music. I don’t think rebooting is the solution because over the last month+ I’ve powered everything on and off many times without success.

Henry:

I’ll order that ethernet cable so I can test a direct connection, without PoE.

Ronfint:

I checked the eunhasu software, and it’s already set to 1000BASE-T. I did notice however that the IP addressed I reserved was different from the Gateway and DNS server (screenshot below) – not sure if that matters.


(Fernando Pereira) #15

IP address, gateway, and mask seem reasonable, in typical LAN configurations the gateway is the lowest address in the address range defined by the mask (in your LAN’s case, 192.168.1.1 to 192.168.1.255). However, I’m not sure about your DNS server address. Try to replace it by a well-known DNS server like 8.8.8.8 (Google public DNS) or 1.1.1.1 (Cloudflare public DNS), and see what happens.


#16

Hmm, I guess the 200 identifies your DAC correctly?

I know you’ve re-booted things several times, but have you done so since address reservation?

Also, I vaguely remember that on the SMS-200 that I had, there was something about specifing Fixed Volume or not. Don’t exactly remember which.


#17

Just as a test, would it be possible to set up a temporary Roon core on a laptop with a very small local library and connect it to your 200 ultra with an ethernet cable? If that doesn’t play, it might indicate that your problems are elsewhere.


(Charles Wells) #18

Fernando:
I changed the DNS server in my router settings and applied the changes. Then I powered everything off, including the router and sms200ultra. The weird thing is that while the router shows the updated DNS server, in the sms200ultra settings, the server hasn’t changed (still 192.168.1.1, the router’s IP address). Is there some trick to this? Should I have made the change somewhere other than the router settings? Screenshots below.

Slim:
Yes, the sms200 seems to be recognizing the Kii dac:

  • List of PLAYBACK Hardware Devices *
    card 0: Control [Kii Control], device 0: USB Audio [USB Audio]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 005: ID 20b1:0401 XMOS Ltd
    Bus 002 Device 004: ID 20b1:30a2 XMOS Ltd
    Bus 002 Device 003: ID 0424:2512 Standard Microsystems Corp. USB 2.0 Hub
    Bus 002 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    0 [Control ]: USB-Audio - Kii Control
    Kii Audio Kii Control at usb-1c1c000.usb-1.3.1, high speed
    Kii Audio Kii Control at usb-1c1c000.usb-1.3.1, high speed : USB Audio

Playback:
Status: Stop
Interface 1
Altset 1
Format: S32_LE
Channels: 2
Endpoint: 1 OUT (ASYNC)
Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000, 705600, 768000
Data packet interval: 125 us

Ronfint:
I don’t see why I couldn’t try that. But since I’ve already ordered a 150 ft ethernet cable to test a direct connection between the sms200 and router (eliminating PoE), and it will arrive Tuesday, I’ll probably try that first.


#19

That’s not weird, it’s expected. The router uses the configured name servers to resolve the names of internet hosts and acts as a ‘DNS proxy’ for intranet hosts. You should be fine this way.

sms200 (192.168.1.10) asks router (192.168.1.1) asks Google (8.8.8.8)


(Fernando Pereira) #20

Doh, you are correct. @Charles_Wells is telling DHCP on his router to do the work of assigning a fixed IP (and also providing DNS forwarding), I was remembering back to when I first set up my home network where I specified the full network configuration for each endpoint on the endpoint itself. My current network also gets everything via DHCP from the router, had forgotten.