Roon stopped playing to paired HomePods [Ticket In]

This time it was 7:56 pm, the song was Natural Selection by UNKLE.

I’m on HomePod firmware version 15.0. I didn’t see any kind of additional build number, and the app says everything is up to date.

Thanks, @Richard_Williams2, I’ve sent this to our QA team.

Hi @Richard_Williams2,

I spoke with the team about this. In our testing we were able to successfully group two standard HomePods, but what we think might be happening here is related to differences between HomePods and HomePod Minis.

Do you have both HomePods and HomePod Minis? If you group just HomePods does it work? Similarly, does group just HomePod Minis work? Could you try doing this and let us know the times and track names for these tests? We’ve left the additional AirPlay logging enabled so we can take a look at the logs for both of these attempts.

Thanks!

OK. I do indeed have both HomePods and HomePod Minis. I tried all combinations. I was able to group the two HomePod Minis together and play successfully. I was able to group each of the two HomePods (A & B) separately with one of the Minis, and they played successfully. But I was again not able to group the two HomePods (A & B) together. Music does not play - Roon automatically pauses a fraction of a second after you hit Play.

The song used this time was “Beautiful” by Moby. I tried at 11:58 am (on the Minis), tried the different combinations at 11:58-59, and then I think the HomePod grouping that didn’t work at 12:00 pm.

Not that this helps, but in my Home setup (Apple), the two HomePods are paired. (I do this to allow them to work together in stereo.) The two Minis are not. I did not try unpairing my HomePods in Apple to see if that would allow me to play them when grouped together in Roon.

Thanks for the updates, @Richard_Williams2. We’ve been looking into this as well and it appears that this has to do with HomeKit grouping. If you ungroup them from HomeKit and then group them in Roon it should work. We are investigating why this stopped working. We believe it has to do with the audioOS update and not our update and are looking into options. We’ll keep everyone updated when we have more info!

Thank you - I do use them grouped outside of Roon and don’t want to have to group and ungroup them constantly, so please keep me posted.

I’d read somewhere once that if you group them in Roon without grouping them in HomeKit, you have to manually tweak the DSP settings to get the stereo effect. After some testing, this appears to be true - pairing them in Roon doesn’t pair them in stereo. Before the update, Roon was able to pass through the stereo pairing from HomeKit. Thank you for investigating.

I am experiencing the same issue. All devices on the network perform as expected. After the most recent update to Roon, only my pair of HomePods (configured as a stereo pair) will not play (from Roon). They will act appropriately using every other service. (HomeKit, Spotify (direct), Airplay from each device, Qobuz App, etc). Roon will locate each device and play separately, but the moment I group them, the playback stops and shows the play triangle again.

Removing from Homekit and adding back to Roon WILL play both speakers, but not as a stereo pair. They play as separate ZONES.

iMac running 10.15.7 (the latest update my core will allow)
All HomePods are current (15.0)
Roon 1.8 (build 756)
All iPhones and iPads are also running 15.0

I think the topic was pinned here:
https://community.roonlabs.com/t/audioos-15-and-homepod-groups-roon-investigating/172922

And that’s the thread that will be updated as they investigate.

1 Like

I now have the same issue with grouped stereo pair Homepods. I’ve been playing them in stereo for a year and, it appears that with the latest build, they stopped being able to play in that manner. They will now only play individually.

I now have the same issue too …

After a month and a half, there has been no solution to this problem and it has rendered Roon unusable in my household because we use both Roon and Apple Music (for different collections) and cannot switch grouping back and forth and change procedural EQ settings every time someone wants to stream music.

All the threads on this topic (about 4 of them) have been closed without resolution and there hasn’t been any kind of update from the Roon side since the initial problem was diagnosed. My concern is that the workaround that some are using to play Roon to their stereo-paired HomePods has somehow de-prioritized this issue in the dev queue. But like many others, I am paying for a service that doesn’t work the way that it used to, and that is becoming problematic.

I would really welcome an update on this problem or reassurance that it is still under investigation. Appreciated!

2 Likes

Agreed. Just picked up to HomePods and would love to know what’s up.

I am afflicted as well. I hope there is a resolution soon!

Me too probleem !!

Hey everyone :wave:

Thank you for sharing that an issue discussed earlier in the year seems to still manifest itself. Our QA team has let us know that the have a ticket in for what’s been reported. We will follow up either to ask for more helpful information or with an update.

Please, stay tuned :relieved:

2 Likes

Same here. Would love to know an ETA on a fix.

FYI - lates update (iOS / … 15.4) fixed this issue for me; Roon is once again able to play to my HomePod stereo pair

setup: stereo pair of original HomePods acting as default speaker for my aTV 4k
Roon setup: HomePods grouped together (zone), with Procedural EQ + Mute Channels filter enabled

I am the originator of this thread, and Roon stopped working for me (as documented above) in September of 2021. I was unable to use Roon as I wanted for six months.

But Roon can now play to my paired (original) HomePods. I do not use the Procedural EQ workaround and everything is working properly, as it was, before the ticket. My HomePods are paired in the Mac/iOS ecosystem and also grouped into the same Roon zone.

Whether this is the update to build 918, or the iOS update to 15.4, I can’t say for certain, because I updated them at the same time, but I am happy to get a resolution!

1 Like

according to Owntone issue #1291 we have iOS 15.4 to “blame” for restored functionality

Funnily enough it was broken in an Apple update and fixed in one as well.

1 Like