Using Roon to stream to HomePod?

Hi Ali, I have just started a Roon trial and have 3 Homepods. I love the look and the sound but Roon is not so keen on them. What is the MM1 you mention in your post?

Hi Bill…

I was referencing the Bowers & Wilkins MM-1.

Thank you Ali.

1 Like

I’ve been following this thread for a while, but finally managed to get my stereo home pod pair to work with Roon, I think. Perhaps someone can mention if they think there is any problem with what I have done, but it seems to sound good. So I enabled each home pod individually in Roon, named them left and right. I then used the group zones button at the top right of the window which lists all your devices, and connected the two as a group. Once this is done you can go into DSP, and use “Procedural EQ” to mute the relevant channel, so right for left, and left for right. Because they are grouped together, the volume controls are linked so they go up and down together. The group appears as a single device under Zones, so you can select it. Seems very good to me so far!

1 Like

thx @Jeremy_Honeybun!

I would love to try that as well. can you perhaps give some more details on the “Procedural EQ” part? i am still confused regarding that. do i do that for the grouped pair or per speaker? and how exactly are the steps preformed?

best

Z

1 Like

So, in the zone selection strip on the right hand side you will start off with the home pods visible individually - you have to “enable” both in the audio section of settings first. Having selected one of the Home pods, then click on Group Zones at top right. That should enable you to select both Left and right with ticks. You see my Apple TV there too, but I left that unticked. Then save. This create the group pair for the Home Pods. Now when you click on the group you get the DSP button at the top, click on this - more pics to follow.
In the DSP window, select Procedural EQ, enable Mute Channels and then mute the relevant channel for each Home Pod - You can select each in the group by clicking on “Left Pod” as shown. Now they should play stereo. I suspect you need a good wifi signal to avoid any sync issues. I use Devolo Magic Wifi plugs and there is one between the pods which also connects the TV, and Sky Multiroom box. I think it sounds great! Hope that helps and let me know if you run into any problems.

1 Like

3 Likes

Awesome @Jeremy_Honeybun!

that works flawlessly! thx for taking the time to explain it

best

Z

That’s seriously clever. Thanks for sharing.

Excellent! Now I can make work my 2 sets of HomePods and Homepods Mini with Roon!

Thanks for the detailed explanation

Regards from Peru!!

New to Roon and really want to use it to its fullest potential. Love the thought of Homepod Minis in a few rooms, away from my main system.
At the moment, I 'm running from an iMac to a Linn Majik DSM 3.
Questions:-

  • Do I require a Nucleus to enable multi-zones?

  • In a multi-zone set-up, would I be able to stream simultaneously to my Linn and any Homepods I have?

  • If yes, would there be any lag between the zones?

  • Would having a HDD instead of an SSD in the nucleus (if required) be to its detriment?

TIA

In answer.

No, multiroom zones are available on all platforms

No, only same protocols can be grouped into zone. If Linn also support airplay then you can use that protocol to group with homepods but not the full linnn streaming which will get you highres and better sq.

Lag can often happen with non RAAT devices due to inbuilt DSP and stuff Roon does not know about. There is a delay for endpoints to combat this as much as possible.

Use an SSD for the database and core or Roons performance is severely affected. HDD is fine for music storage but is creates more heat and is physically noisy.

Hi, im new to Roon and testing it. So far im happy with my set-up. Bit if i want to ad airplay products it askes for a code. With my apple tv it’s no problem. But were can i find the code to connect homepod mini’s?

I have to disappoint you but this does not work. It only works when one uses the speakers separately but as soon as you link them into a zone the L/R separation is no longer there. Try it with a proper stereo-testing soundfile.
This is clearly a Roon Problem. If one links the two homepods in the Apple Homepod app the two pods are clearly separated as left and right. As soon as one links them together in a group it goes wrong. Visible in Roon as a group but NOT working.

It used to work perfectly, as per my instructions above, but then something changed in one of the Roon updates so it no longer works, and I’ve not been able to get an answer as to why. It’s a shame

@RJ_V There are a couple of other topics which may be helpful.

This link details a change which can be made to Apple Home settings which appears to have helped historically but last time I tried @Jeremy_Honeybun 's solution this didn’t help - I could play left or right but when grouped Roon just won’t play to the group.

This link refers to the fact that this is a known issue and currently in support (as mentioned by @beka - however I have seen this mentioned as with support before somewhere but can’t currently find it.

Hope this helps with your understanding if not your frustration… and hopefully the `Roon team will find a fix for airplay 1 used for HomePods soon.

Thank you for your reply. Do not worry, I am not frustrated, only somewhat impatient since this problem is around some time.

@Marcus_Russell Thanks a lot! I’ll give it a go. I also see I have a Homepod software update to do, even though it was set to automatic.

Hi All

In case you are following this thread waiting for a solution I understand from this thread that this is now resolved by an Apple iOS update to 15.4

So the workaround method posted by @Craig_Colthorp now works again