Roon Stopped Recognizing NTFS HDD after OS Monterey upgrade [Ticket In]

Hi Noris,

Any progress on the issue ? I’m still looking forward to using my NTFS HDD.

Thanks and Cheers

I was about to follow up as well. I’ve been using the exFAT copy without issues but this was a costly workaround. Looking for a real solution.

Hi @Richard_Cheng ,

I wanted to touch base with some good news, which is that our technical team has been able to reproduce this behavior and we’ve opened up a bug report with our developers.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved.

Thanks again for the report!

Hi Noris,

Thanks a lot for your response and your team’s work on it.


1 Like


Is there any update? I had the same issue for a month. It is painful to switch to other means to listen to music.

Hello @Shih_Sheng_Yang ,

There is no update to share at this time. We have a ticket regarding this behavior and plan to fix it, but I cannot comment on a timeline of when the fix will be public. Thank you in advance for your patience here!

Hello All,

While we have a ticket in progress regarding this, found a temporary workaround on how to restore access. There is an NTFS driver for Mac called Tuxera, that once installed, should allow you to regain access to your NTFS drives in Roon:

While this isn’t an ideal solution, it can be helpful while we work on this issue.

Still not fixed I gather ?

I’ve downloaded the Tuxera driver, gave it all permissions but still can’t get Roon to see the USB drive. This is very annoying.

Hi All,

For those impacted by this issue, can you please confirm if the NTFS drive is visible and accessible through Mac Finder before installing the Tuxera driver?

It sounds like this is the case, but we just want to confirm that this is through Finder, and not some other way of accessing the drive, thanks!


My Mac mini can see the drive and read the files. Roon can’t. I attach a screenshot.

I’ve not been able to install the Tuxera driver as I use a headless mini and have no access to a screen/keyboard in my current location. The driver requires to be installed at boot up, before I can remote control the mini from another laptop.

Just to be clear, I use the headless in another location. I backup all files from my NAS on an external drive and use that for the remote location. I never had an issue with the old mini (old OS), but my brand new mini has the latest OS and Roon can’t see the external disk.

1 Like

This is been open since beg November, about 4 months now. We’ve had quite a few updates/fixes since. I know Roon does not give ETAs for anything, but could we at least get a confirmation that it’s being worked on?

Thank you.

Yes, this is actively being worked on, the ticket is in progress.

Thank you very much for the info.


Am writing to bring this back up to attention. This has still not been resolved.

Thank you for any help.

Hello @Cemil ,

Thanks for the reminder on this. I checked with the team and there is still a ticket in the queue regarding this issue, it has not reached the top of the priority list yet. While we work on this, using the Tuxera NTFS driver as a workaround is possible.

Roon Core Machine

Macbook Pro M1, 16GB RAM
Roon Version 1.8 (Build 988), Serial Number: BDF0271E-3674-4FB6-AF24-24BCC4BAF1B1

Connected Audio Devices

External DAC connected. Uses Amanero Combo384.

Number of Tracks in Library

on Windows was 3 TB of library.
on mac actuell only 900 tracks

Description of Issue

my new macbook pro M1 cant add my external hard disk as folder.
hard disk (seagate backup) is full useable on the macbook. (driver Host-Controller: AppleT6000USBXHCI)
Macintosh HD works fine.
On Windows no Problem. All of the 3 TB Musik was imported to roon.

Thanks for any help

Hi @Jorn_Bressem ,

How is the drive formatted, is it using MacOS Journaled, exFAT, NTFS, etc?

it is NTFS formatted.


Is there any progress on this? I was very disappointed to see that the fix was not included in Roon 2.0

Hi @Cemil ,

I just checked and it looks like work on the ticket was put on pause until Roon 2.0 was released. Now that 2.0 is out, I’ve sent the team a ping on getting this issue back in the development queue again. Thanks for the reminder on this!