Roon stopped updating from NAS since 1.4

Hi Support

I am running my core on linux using Vortexbox os and all my music is stored on my Qnap TS-453 Pro up until the last update its been automatically updating my library when I add any files, but now its stopped doing so. I now have to force a rescan. Tidal material gets added ok when it syncs to the Tidal just not my own stuff. Any ideas?

Core is connected direct to the router as is the nas.


1 Like

Hi @CrystalGipsy ----- Thank you for the report and sharing your feedback with us.

Moving forward, very little has been changed in this “area” of the code and we’ve found that many NAS devices have issues properly communicating changes to the device they are in contact with. This behavior appears to be more pronounced with OSX based cores, but we have had reports of this occurring on other operating systems, as well.

Basically, when the OS is aware of a change on the network drive, it lets us know and we update your library immediately, but we don’t always get that notification in as timely a manner as we would like. However, in certain situations the OS can be unaware of changes, particularly if they are made directly to the network drive. If the OS fails to notice the changes, Roon isn’t notified, and the changes don’t show up in your library until a rescan is triggered.

Unfortunately, we’ve found that most NAS’s just silently report a subset of events, or none at all. We did some research and found that just about every piece of software that attempts to do “real time watching” on NAS’s eventually runs into this limitation, and supplements it with a periodic scan of the storage folder. Plex does it, JRiver does it, so do others, and so does Roon. Brian discussed some of that here.

As I am sure you are aware, the “rescan period” is configurable, so you can have Roon scan more or less often depending on your situation. Have you tried making adjustments to this feature yet?


How do I change the frequency of the rescan period.

1 Like

thanks @RBM

1 Like

Hmmm, That box only appears when adding a brand new folder, it does not appear when I edit the existing storage location. That means i would loose my current library and have to completely rescan or restore it.

Are you sure? I made the screenshot when editing a network share that was already present and active…

100% no scroll bar to reveal it either.

add a fresh one as if by magic.

Your first one looks like storage local to your Core, the second one is a network share. I believe auto rescan intervals are only available for the latter.

It’s not actually on the core, it’s the Nas mounted by the filesystem not Roon. That explains why it does not show up then if it’s purely for network mounts via Roon. As I said this always worked until the latest update so it’s odd it doesn’t now and nothing changed.

You aren’t getting that option since current folder was added as a ‘local’ watched folder. You can try adding same folder as a network watched folder (Roon will be handling communication with the NAS).

1. Make sure you have a backup, if you don’t - do it!!!
2. Add folder on your NAS as a network share in Roon
3. Change file path of the current watched folder to the one you have in recently added network share.

Since Roon makes a ‘fingerprint’ of each media file in its database, your edits will stay intact.



I’ll backup, and try that,

I setup my NUC with Ubuntu (Ubuntu 16.04.4 LTS (Xenial Xerus)) yesterday and installed Roon Sever according to the article in the Knowledge Base. The audio files are stored on a share on my QNAP TS-431 NAS. In my test environment I had Roon Server running on Windows and the music files were stored in a local folder. I did all migration steps according to the Knowledge Base. Everything worked smoothly.

The automatic update feature in my test environment was working like a charm. After the migration the automatic update doesn’t work anymore. I also have to force rescans and probably will lower the scan frequency as soon as the rest of my library is imported.

In case somebody has an idea how to get this issue solved please share your findings (as far as I understood the previous postings and the other thread which was linked above, we’ll probably have to live with it due to technical limitations on the NAS side)

I have to partially recall my post from a few days ago… the automatic update works most of the times. The update in Roon starts a few seconds (up to half a minute) after the transfer of the files has been finished.