Roon stopped working after upgrading

Roon Core Machine


Networking Gear & Setup Details

Connected Audio Devices

USB Dac and iPhone

Number of Tracks in Library

Description of Issue

installed the latest update for Arc support
Now I can’t stream any music to any devices , iPhone or usb dac
Running Roon on QNAP NAS
reinstalled Roon without success
Library shows all of the files but nothing plays
Where in the log files should I look

Is your QNAP Core running Roon 2.0? If so, are all of your Remotes also running 2.0? What is shown in the Settings → Audio tab, can you share a screenshot?

Server and remote are 2.0 versions

Even playing the radio doesn’t work The stream never gets initiated

A few more questions before tagging support. First, is there a firewall or application security setting on the QNAP NAS that needs to have exceptions made for Roon and RAATServer? Second, can you please provide more detailed information on your:

  • QNAP NAS (model number, OS version)

  • DAC model

  • Network details (router model, what is connected using an Ethernet cable and what, besides the iPhone, uses WiFi, any other Roon Remote devices, endpoints, and network devices in your network)


NMAP of NAS open ports 22,80,111,139,443,445,2049,6881,8080,8081,9200,30000

Audio devices Schiit Unison Modius USB Audio x2

Doesn’t even stream to my iPhone :thinking:

What about your network devices and configuration? Does your NAS work with other devices outside of the Roon application?

Everything works fine with connecting to NAS for everything else
Are there NAS ROON log files that can indicate where the problem is?

I am going to tag @support for assistance Robert. They should be able to look into this with you.

Hi @Robert_Watson2,

I decided to pop in and look at this real fast.

Here’s what I see in the logging

10/17 12:28:23 Warn: [streammediafile] error reading stream: Unable to read data from the transport connection: Software caused connection abort.
10/17 12:28:23 Warn: [zoneplayer] Remote Load Failure While Opening Sound: icy:// Icy: timed out while starting stream
10/17 12:28:23 Info: [zone 1] [zoneplayer]     Open Result (Playing):Result[Status=MediaTooSlow]
10/17 12:28:23 Trace: [zone 1] [Inactive] [LOADING @ 0:00] SomaFM: Black Rock FM
10/17 12:28:23 Warn: [zoneplayer] couldn't play URL channel:// other error
10/17 12:28:23 Warn: [zone zone 1] Track Stopped Due to Error
10/17 17:21:13 Trace: [zone 1] [zoneplayer/raat] Got 'lost' response
10/17 17:21:13 Trace: [zone 1] [zoneplayer/raat] Endpoint Schiit Unison Modius State Changed: Buffering => Idle
10/17 17:21:13 Trace: [zone 1] [zoneplayer/raat] lost endpoint. stopping stream
10/17 17:21:13 Trace: [raatserver] [Schiit Unison Modius] lost client connection. Retrying
10/17 17:21:13 Info: [raatserver] [Schiit Unison Modius] connecting (attempt 1)
10/17 17:21:13 Info: [transport] destroyed zone zone 1 was playing? True
10/17 17:21:13 Trace: [zone zone 1] Suspend
10/17 17:21:13 Info: [zone zone 1] OnPlayFeedback Stopped
10/17 17:21:13 Info: [zone zone 1] Canceling Pending Sleep
10/17 17:21:13 Warn: [raat_ll/client] [Schiit Unison Modius] failed to connect Connection refused
10/17 17:21:13 Info: [zone zone 1] Canceling Pending Sleep
10/17 17:21:13 Trace: [raatserver] [Schiit Unison Modius] client connection failed. Retrying in 500ms
10/17 17:21:13 Info: sleep 40ms after flush
10/17 17:21:13 Info: [audio/env] [zoneplayer] All streams were disposed
10/17 17:21:13 Info: [audio/env] [zoneplayer -> stream] All streams were disposed

It looks like general connectivity issues. Perhaps your network and network devices have Roon’s connections in a bad state. If that’s the case, powering down modem/router, Roon devices, and Roon core and then bringing things back up in the same order could resolve this.

Please let me know if not. In testing, please note the date/time/track played if the issues are still present and report back here.


Restarting everything didn’t solve anything


Could you supply this information please, it is needed by the Roon time in order cross check against the log files.


Just tried playing…

Could it be a file access/privilege issue?

Hi @Robert_Watson2,

It could be. One way to check is to remove the storage locations and add them back. Utilizing “guest” and no password would be one way to check. I did just try to access your core diagnostics information and it’s failing to go through although this could be due to sleep settings.

Try the storage location suggestion above and let me know. Should my diagnostics request go through I’ll be able to look at your timestamp and track example provided and see what happened in that specific instance too.


The power was off yesterday when you tried but back on now
Unfortunately, ROON still refuses to stream music
I reloaded the music library and it still doesn’t work

Hi @Robert_Watson2,

It looks like when you added your library, Roon went through audio analysis for your files and had errors in doing so. Over 5,000 errors in fact.

One thing I noted in my looking at diagnostics is that there seem to be two different IP schemes in play and this may very well be relevant. The core is a 192.168.1.x scheme and mobile instances are 192.168.30.x. This indicates a potential problem when trying to use mobile devices to begin play on a server that’s not on the same scheme.

One thing that is notably absent from your support template is the networking gear and setup details. Can you please tell me about your modem and router setup? Are you using mesh?


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.