Roon stops playing at random times

Core Machine (Sonictransporter I5 Latest Roon Build)

Network Details (Ethernet QNAP TS219P NAS>Asus RC68U)

Audio Devices (Sonore UltraRendu > Sonore UltraDigital >DAC LKS MH-DA004 > Anthem D2V Preamp)

Description Of Issue

New Roon user, having issues with connectivity. Roon stops playing randomly, typically at the start of a track. I select “shuffle” my whole library to see how low it will play, approximately 7500 FLAC tracks. I’ve tried to mitigate some of the common issues using multiple endpoints to see if one in particular was the issue. First a Windows 10 laptop, both wired and wifi. The laptop is setup that it never sleeps. Tried direct output to the laptop instead of the Rendu, same issue. Also an Ipad. Same thing happens, tracks just stop playing. Could be after 10 tracks, 35 tracks etc. etc. I am not always present when this happens so I cannot say if it’s lost connection to the core or not. I do not have to reconnect to the particular zone that was playing when it does stop playing. 99% of this trial and error has been with the Rendu as the output zone. This trial and error study has been over the last five days. When it stops playing, the zone is still present with next track loaded, ready to play. I click “play”, it plays the track that is there.

I’ve also tried it both with Tidal on/off in Roon. The longest I’ve got it to run was overnight, approximately 8 hours. When I look at the played songs in the que, I do see some tracks have been skipped, sometimes multiple in a row, sometimes one. When I try to then play the skipped tracks after the fact, they play just fine.

The Windows PC, Sonictransporter, NAS & Rendu are all connected directly to the router via ethernet. Tried switching ethernet cables on all devices (except for the cable from the modem to the router, if that matters). Tried rebooting all devices, Rendu, Transporter, Roon & router on multiple occasions as well. Tried also connecting them through a switch, same issue. Tried a different switch, same issue. Turned on Multicast on my router. Tried turning off upsampling. Both Sonictransporters have the latest 2.8 firmware loaded.

I was using JRiver previously on my network and did not have any playback issues, although I can’t say I tried playing anything overnight. Since Roon/Tidal come with a higher pricepoint from an investment standpoint, I wanted to see how stable the platform was before I commit to it fully. This issue happens multiple times, daily. Last time this issue arose was overnight; feel free to login to my account to do some diagnostics.

Here is a link to yesterday’s Diagnostics:

https://drive.google.com/file/d/1DfY06COloAlhnw9JHkGgKHKXjaQa9BRn/view?usp=sharing

I do like what Roon has to offer, hopefully I can get this sorted out. Thanks in advance for the support

1 Like

Hi @fmzip,

It would be interesting to know if the same behavior occurs if playing to a device connected to the Sonictransporter via USB. Even if not a permanent solution, knowing how this works will be helpful for us to know where we should focus our investigation.

If I were to try this, do I simply disable the link to my NAS and mount the USB instead. Not sure how to unmount it after the fact…

Will my library and playlist then become corrupt with missing tracks? I do have all my music backed up on a portable USB drive. Couldn’t the same be accomplished by eliminating the link to the NAS and try using just Tidal instead? I will try both and report back

I disabled the SMB link to the QNAP NAS in Sonictransporter and loaded some tracks on USB drive, enabled Tidal and clicked “play”…

I have been able to run for 12 hours straight, not a single skipped track either. That is a first as well! On a side note, I am able to play tracks from my NAS through JRiver without skipping a beat. Seems as though Roon/Sonictransporter not liking my NAS for some reason? How do we we go about resolving this?

The way I have the NAS set up is through SonicTransporter’s drive mount instructions under SMB interface:

The path I’ve entered is:
(\ \192.168.0.255.local\music) - no spaces between the first two slash marks, for some reason the forum doesn’t allow two slash marks in a row -

What am I missing here? Thanks for the support

1 Like

Hi @fmzip,

Happy New Year and thanks for your patience here while your case reached our queue again.

Can you please confirm if the same behavior occurs when using your Windows PC as the Roon Core?

  • Create a Backup of your current database
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

What version of SMB are you using on the QNAP NAS, are you using SMBv3?

Hi Noris,

I will try what you suggested.

Unfortunately my Qnap TS219 does not allow me to select the SMB version. I am assuming it’s version 2 from what I’ve investigated. Could that be the problem that using anything other than v3 can cause the issue?

1 Like

Hi @fmzip,

SMBv2 should work, but you will want to make sure you don’t have SMBv2 with large MTU enabled, please see our NAS Troubleshooting guide for more info:

This guide from QNAP may also help: