Roon stops playing mid track [solved]

I have an issue whereby Roon occasionally stops playing mid track. I stop the track, then hit play again, and it looks like it’s playing but nothing is coming from the speakers. The only way to get it going again is to reset Roon Server.

Can someone check out my logs to see what the issue is here?

I have a dedicated i5 NUC 16gb RAM running Windows 10 Pro to Meridian MS600 end point.


I have the same problem, using a NUC with Win10 to a different endpoint. I am getting so sick of it that I am running out of patience. I have a hard-wired system (no WiFi in the network) and I have swapped cables, swapped hubs and re-loaded Roon from scratch, but nothing makes a difference. Usually, I can’t get beyond a couple of tracks. The same NAS serves my Sonos system without a glitch, so I am convinced that this is internal to Roon. I had intentions to upgrade to lifetime membership, but if this is not fixed soon, then the whole lot will be thrown out and replaced with a decent HW streamer. I know that there are others with the same problem - this needs action NOW!

Hey @Boru80 @zappyroon – Sorry for the trouble here.

Can you both tell me a little more about your setup, network, media, and output, as described here. In particular @zappyroon I would be interested to know if there’s a Remote zone involved here.

Also, @Boru80 – can you confirm what version of Meridian firmware you’re running?

Let me know the details and then @vova and I can look into gathering some logs from you guys to get a sense of what’s happening here. Thanks!

Hi Mike
I’m running Roonserver which is stored on a SSD on the NUC. All my music is stored on a HDD on the NUC (so no network between Roon + music files).

The NUC is hard wired to a different room from my MS600 as I don’t like any fan/disk noise in my living room.

I’m running Roon Version 1.1 (build 57) on my ipad.
Version 1.1 (build 65) Roon Server.

My MS600 is running Software version 1.2 build 163 and Hardware version 2.5.


Hi Mike

Sorry if my frustration made my earlier post sound a little unfriendly - I so want this to work for me and be a long-term solution, but having invested in a NUC plus Roon, and needing to buy a new iPad to use it the way I want, it is driving me nuts.

The basics:

NUC 5i5RYK with 128GB SSD and 16GB RAM, with Windows 10 64 bit OS running Roon Build 65

Router: Apple Airport Extreme v7.7.3, with 80 Megabit fibre DSL connection

NAS: Synology DS212 running DSM 5.2-5592

The NAS is usually connected to the router via a Gigabit switch and I use a powerline extender to bring the network downstairs to the NUC, where there is another Gigabit switch that hooks up the network, the NUC and the output, which is to a Devialet 400 running AIR over ethernet cable (that’s a whole different story of pain, by the way, but for another time). However, in order to eliminate the powerline extender as a possible culprit, I did move the NAS downstairs for a while and plug it directly into the switch there - it made no difference whatsoever, so now it is back upstairs. Output is Wasapi, exclusive, event-driven.(I tried changing settings there - no difference)

I also have a MacBook Air, and that runs another Build 65 as a remote and is my preferred method of control until I get a new iPad. That is connected via WiFi, and functionally it is perfect, but when the playback fails, that either shows that it has lost connection with the core, or just that the music has stopped. Usually, pressing play will start it again. However, the NUC is also connected to a display (my TV) and has a mouse, so as part of the troubleshooting, I tried using just the core, with no remote. Same problem - sometimes, the music just stops.

My music was in a watched network folder, but since I had made no library edits, and after re-installing Roon with no improvement, I am in the midst of an experiment:

I completely whacked Roon, including all files and database, from the NUC, and then reinstalled from scratch. I decided to copy my HD content to the SSD on the NUC, into an organized folder. As I type this, that copying is still taking place, but Roon has happily been playing the music, and the library is gradually updating.

Obviously this is not a full solution, since I have a library of almost 1Tb (mostly ALAC 16/44.1)

So, now I don’t know whether I have fixed something by whacking the database, or whether having the files on the local SSD has solved the issue. A little later today, I will go back and set up the library to include the stuff on the NAS, like it was before, and see how it goes.

Unfortunately, it means I have no log files that reflect the problem at the moment, since they all got binned when I deleted everything earlier. However, I have no reason to believe that there is any anomaly or fault with my network or NUC hardware that was causing the problem. I guess I shall just have to be patient and see what happens. After setting up the system originally (September) I had several days when it worked perfectly, then all of a sudden this problem started, and never went away again. (I have disabled Windows update, so nothing is changing on the NUC, and it is not used for any other application)

I would love to have your thoughts and suggestions, but I remain convinced that this is some kind of internal communications issue. I don’t mind doing a modest bit of troubleshooting with you, but I work with computers all day, and this is supposed to be relaxation !

Just tell me what I need to do next !



Update: So while I was copying my HiRes music to the SSD in the NUC, I started playing the music - it was flawless. When the library had finished sorting itself out, I added my NAS drive as a watched folder, exactly as before, and started adding selections to the playlist. Music continues to play, without interruption, regardless of the format or the folder I am using. That has now been some 8 hours, during which the whole library has also rebuilt itself (around 20,000 tracks).

Seems pretty clear to me that the database in the previous installation had somehow got busted.

What happened once can happen again - what safeguards are there to protect the database from such problems? Anyone who has invested time in editing the standard metadata will not be interested in having to rebuild the library every few days . . .

Input, please.


Hey @zappyroon – sorry for the trouble in here. Anecdotally, it definitely sounds like something on the first install was off, and your troubleshooting steps are sound – I would’ve tried to work around the powerline extender as well.

Since our launch in May, we have seen a few issues with database corruption (now resolved) which is the reason we encourage members to make regular backups.

We don’t have any known corruption issues at the moment, and all the past issues that were resolved manifested as collection issues – problems with edits, problems loading the library, albums being split, etc. As far as I know, we have not seen any database issues manifest themselves in the way that you’re describing. That’s not to say it’s impossible, just that what you’re describing sounds more like a network or hardware issue than an issue with the install. For the moment, this sounds inconclusive (and frustrating)…

I don’t have much more to add here now – without any logs from the troublesome install it will be very hard to get a sense of what happened here. Let’s keep an eye on things, and if the issue recurs, I’ll be happy to take a deeper look into it. Does that work for you @zappyroon?

Actually, one thing to check on the Synology – if you go into DSM Control Panel > File Services > Windows File Service > Advanced Settings – can you confirm what you have set for “Max Protocol” – I would recommend SMB 2 or SMB 3.

Sorry again for the trouble guys.@Boru80 – I’ve sent you a separate PM regarding the Meridian zone.

Hey @Mike

Thank you for the input. I can’t ask for more at this stage.

In fact, since the rebuild I started 3 days ago, the system has been playing non-stop, and has stayed rock-solid even when I have been tinkering with the Windows sub-system. The network setup is identical to how it was when I had the problems, so I have to assume that it was something broken in the previous install. (That would have been whatever version was current in mid-August, followed by, I think, 2 updates) The wretched Devialet Air driver has bombed a couple of times, but Roon hasn’t missed a beat.

On that basis, I have put my faith in you for the long haul, and after seeing the comments from @danny today regarding what might happen if something changes with Roon in the future, I have committed to Lifetime membership, and have already received the confirmation, along with a refund for the unused portion of my first year’s subscription.

Now I’m looking forward to all the goodies that you have in store, and if Roonspeakers eventually gets to support Devialet, then I shall be well satisfied.

Thanks - keep it coming!



Hi @Mike

Well, after around 5 days of near-continuous use, the problem has arisen once again. However, there may be a clue - read on:

My NUC is plugged into the TV, and has a mouse but no keyboard. I usually operate Roon via remote on a MacBook Air, and that runs perfectly, but occasionally I need to tinker with the NUC (for example, to reload the wretched Devialet AIR driver). Because it is cumbersome to operate via the TV, I use Microsoft Remote Desktop from the MacBook. Usually, that works fine, but yesterday when I logged on remotely, the RDP crashed, Roon stopped playing, and the NUC froze, necessitating a restart.

Since that moment, the playback stops mid-track without warning, just like before. (I should add that the RDP freeze had happened occasionally before my rebuild, as well)

It therefore seems to me that the RDP has corrupted something on the Roon side that does not get fixed by rebooting. I am going to remove everything and install from scratch once again, and see if that works this time, but before I do that, do you want any files from the broken system to investigate ?

I can always choose not to use the RDP if that is really the cause of the problem, but I don’t see why it should be. However, I could really use some guidance now - tell me what you need.

Many thanks


This isn’t something we’ve heard before, but I’m going to follow up to get some logs and we’ll have a look. Stand by.

Hi guys,

Was there any solution to this? I’m having similar problems. I wasn’t having it until the latest update to Roon came. It’s getting really frustrating - as I can’t really see why this is happening.
I haven’t changed anything else.
Running a regular PC, with a regular harddrive on it, USB via Dragonfly to my DAC. I’ve reinstalled Roon, my DAC driver all of it - but it keeps coming back.

Any ideas on what might help solve this?

Hey @Changeling - sorry for the trouble here.

Are there remotes involved? Any networking at all (meaning, media is streamed from a NAS or Tidal), or is everything happening on one computer?

Any other audio applications open?

Is the Dragonfly your DAC?

Sorry, here’s more details @mike

PC (no NAS, just SSD) with Roon + Tidal (500mbit/s u/d RJ45-LAN) -> Audioquest Jitterbug -> USB cable -> Linnenberg VIVACE DAC -> Sennheiser HDVA 600 Headphone Amp -> Headphones.

No other audio apps open. I toggle between jRiver and Roon since I still want to do wireless streaming via iPhone/iPad to my Chord Hugo DAC/AMP but I never run the apps at the same time (jRiver won’t work when Roon is running anyway, and using jRiver as an audiozone doesn’t seem to work either)

All audio is hence happening on the same computer.

No remotes.

I’ve just done a clean install of Roon + DAC driver from Linnenberg. It seems to work, but so far haven’t tried that many albums. I did a backup of the whole Roon-folder before uninstalling/installing. Do I just replace all of it with the backed up folder? Worried that the issue will come back if I do, but would be nice to get all playlists back…

EDIT: So I restored the backup, and the problem came back. Sigh. So I’m now stuck with a fresh, and working, install but without all the work put in the last couple of weeks.
Hope there is a way that I can make this work. I’ll keep the old Roon-folder…

EDIT2: I’ve managed to get it working again. It seems to be something with the USB-driver for the DAC. I’ve downloaded a newer version of the ASIO driver and set it up as a new Audio Zone. Purple star indicates bit-perfect.

I’m going to mark this fixed, but let us know if you’ve had any other issues here @Changeling!

1 Like


1 Like