Roon stops playing unexpectly

I am using latest Roon build on my QNAP TS451

Installed RoonServer: 1.4 (build 298) stable
QPKG-Version: 2017-10-03

connected to my Rotel A12

since it is not support DSD I use conversion to PCM, 192kHz and 24bit

after playing random number of songs (no matter if it is DSD or FLAC) it stops playing
helps turning off Rotel as DAC and turning on again

I tried applying other settings but with no luck - any thoughts?

Hi @Dariusz_Rybak ----- Thank you for the report and sharing your feedback with us. Both are appreciated!

Moving forward, I would like to point out that the mentioned NAS (QNAP TS451) is falling under our recommended spec for hosting RoonSever, as according to the device’s spec sheet it is making use of an Intel® Celeron® 2.41GHz dual-core processor. Based on the symptoms you are describing, it sounds like you could be feeling the affects of some performance issues with device.

During your troubleshooting of this behavior have you tried hosting your core (temporarily) on another device with a stronger processor to verify how the A12 performs?


Hi Eric, thanks for reply. I thought so that there might be performance issue, but here are my other thoughts :

  • my Nas is equipped with 8gb ram
  • Roon runs on dedicated SSD
  • Roon shows it can process audio (dsd) between 4-8x
  • cpu usage is approximately 30 percent
  • audio drops rather during playback, pause/play bring it back
    -sometimes playback drops and not playing anymore - Dac reboot helps.

Roon issue I have occurs only on Rotel A12 , all worked well on my old Musical Fidelity DAC M1

Any thoughts?

Hi @Dariusz_Rybak ----- Thank you for the follow up and the insight!

Moving forward, if you are able to reliable reproduce this behavior I would like to enable diagnostics on your account as this action will automatically provide us with a diagnostics report containing a set of Roon logs the next time the application is active on your core device. However, before I enable this feature may I very kindly ask you to please provide the following:

  • A screenshot of your signal path when you are using the A12.

  • Please reproduce the issue and note the following:

    • The time when the error occurred.
    • The track that was playing at the time of failure.

Once I have the requested information above I will go ahead and enable the mentioned diagnostics on your account. Looking forward to your feedback!


Hi Eric, thanks for helping me out

Error occurred today 13:56 CET while playing Michael Jackson - Pretty Young Thing (signal path in 2nd pic)
Song were paused then I had to resume by pressing play.

Other two screenshots are other examples of playing to A12

typical Flac path
path when error occurred


Thanks for touching base with me @Dariusz_Rybak and providing the requested feedback. Very appreciated!

Now that I have the requested time frames I have went ahead and enabled the mentioned diagnostics on your account. Once the report has reached our servers I will be sure to follow up so you know we have it and swiftly pass over to our techs for analysis.


PS: A friendly reminder that the next time the application is active on your core device the report should hit our servers.

Hi @Dariusz_Rybak ---- I wanted to reach out because I have been periodically checking our servers for the mentioned diagnostics report and it looks like we haven’t received it yet. I can see the request was made but it’s still in a pending state.

In light of the above I have re-enabled diagnostics on your account in order to try and “re-fresh” the request, however I want to make sure that our techs get a chance to look into this for you in a timely manor. So in the interest of expediting this process, may I very kindly ask you to please use the instructions found here and send us over a set of your RoonServer logs.


Hi Eric,

The logs can be downloaded here:!Apxveh8pNa7sg7MwcIz3JZ7goHJD9Q


Hi @Dariusz_Rybak ----- Thank you for touching base with me! I just checked the upload and it looks like you have sent over your “RAATServer” logs. Could you please supply us with your “RoonServer” logs.

"…may I very kindly ask you to please use the instructions found here and send us over a set of your RoonServer logs. "


Hi Eric, hope now it is ok!Apxveh8pNa7sg7MwcIz3JZ7goHJD9Q

Thanks @Dariusz_Rybak, this is exactly what I was looking for :clap::+1:

Continuing forward, I am going to attaching the provided logs to your ticket and then it will be sent over to our tech team for evaluation/analysis. Once the ticket has been passed back I will be sure to share the team’s thoughts/findings with you asap.

Your patience while our tech team conducts their investigation is very appreciated!


Hi @Dariusz_Rybak ---- Thank you for your patience here while our tech team has been analyzing the provided logs. Very appreciated!

Continuing forward, our techs have noted that they are seeing traces in the log that seem to suggest the OS is losing connection to the A12. The team has noted that this can occur when a bad USB cable is in play or if there is potentially a “bad power” situation in regard to the USB interface.

When you notice playback has stopped what state is the DAC in? Anything present on the display panel? Is it possible going to sleep?


Hi Eric, sorry for the late reply.

I did some test with better USB cable but unfortunately I had same results (you can see how Roon behaves on the video:!Apxveh8pNa7sg7NFf6jVGbcTHpO-Vg )

There is no any message on the A12 but to fix the issue as seen on video it works to power off/power on A12

I will perform last test, to play from Roon on my Mac with DAC connected to it via USB - I will share the results


Hi Eric, I had no issues playing music via Roon over Mac, the issue only occurs on QNAP, no matter what file types are being played

Hi @Dariusz_Rybak ----- Thank you for the update and sharing the results of the mentioned test, very appreciated!

I just want to make sure we are on the same page in regard to the error being experienced with the A12. The provided video example appears to show Roon cycling through the song queue without playing any tracks, is that indeed the behavior being experienced? The reason for my asking is that the behavior being displayed in the video can come about when Roon is unable to start the audio device.

Being as this behavior is not being experienced when the A12 is mounted to the MAC I have to think that it is functioning as expected. During your troubleshooting have you tried all the USB ports on the NAS?


Hi Eric,

Given video shows issue when A12 connected to NAS (to any available USB). Helps turning A12 off and on to restore playback.

While running on Mac I cannot reproduce such issue considering A12 is connected directly to Mac

Thank you for clarifying that for me @Dariusz_Rybak, I was aware that during your troubleshooting you had tested with another USB cable but wasn’t sure if you had tried a different port on the NAS. Just wanted to make sure we had ruled out the possibility of a malfunctioning port on the unit.

Additionally, I know you had mentioned that this is occurring on the NAS despite the file type being played. Does this include with the DSP engine on and off? The reason I ask is because the “signal path” screen shot above (“path when error occurred”) shows the DSP engine as active.


I will try to replicate it on my setup with my Rotel. But I guess it has a different DAC as it is not the same model.
I know, you already said it stops randomly, but can you give a rough timeframe how long it normally takes until it occurs (between x and y minutes)?

Are there any other services running on your QNAP as well?

1 Like

Hi @Eric, thanks for the hint - I had just disabled DSP on QNAP and since 3 hours it plays. I will monitor it for the rest of the day.

@Crieke Thanks for helping out, the issue occurs after few hours of playing music, 2-4 hours mostly. I have no any other CPU consuming tasks or services.

What runs:

Container Station (one 2GB machine for Ubiquity Controller, with barely 1% CPU utilization
Roon server - uses ~ 20% CPU

Overall RAM utilization 28-30% (8GB installed)

1 Like

ok. I let Roon play all night on my stereo, while I was in bed. It is still playing right now. I guess, it does not occur here… :frowning: (signalpath)

I had issues with my Rotel a while back, too. The PreAmp was clicking randomly (like when switching sample rates) and then it was silent (Roon still indicated to play). After a while it was clicking again and audio was playing again. Apparently this was in my case due to a grounding issue. But your description does not sound like it, as Roon also stops playing on your side…