Roon stops randomly playing songs after a song is finished

Roon Server Machine

Win 10, 16 GB RAM, i7-5500u, minipc

Networking Gear & Setup Details

Fritzbox 5490, Everything connected wired, use of 2 switches(also switched off/on),

Connected Audio Devices

Streaming; Bluesound Node 130(use only Roon for it)
Receiver Marantz Cinema 50
Speakers; Fronts; Focal Aria 926, Center Focal CC900, rears; JBL SVS 178

Number of Tracks in Library

2652

Description of Issue

It seems like roon pauses out of nowhere, always after a song ends, sometimes after a few songs and then again after more than 10-20 songs. At first I thought it was due to Qobuz, which seems a bit less stable than Tidal, which I have rarely encountered any problems with but don’t want to use anymore, qobuz sounds better i think.
The mini PC is the core and I always leave it on, I have already turned off sleep mode, etc. in Windows, restarted the mini PC several times, restarted the router, Marantz and Bluesound. I don’t see many options in the bluesound that I can adjust, but I do notice that when Roon pauses, I open the bluesound app, press play, and Roon starts playing songs again more quickly. I already disabled auto. roon updates. Bluesound node is connected to the Marantz via a coaxial cable. Roon, Marantz and Bluesound have all been updated, Windows is up to date, Cache Qobuz and Roon have been emptied.

I only use the mini PC as a core for the roon, so no other processes are running. I can’t really figure out what the problem is.

my internet speed is via fiber 1gb and speed tests show excellent speed on the mini pc.

I’ve probably forgotten something that wasn’t mentioned above, what else can I do about this?

I have already looked at several other topics, but often the problem seems slightly different.

1 Like

Fellow user here, wondering if that happens with local and/or/only streaming content, and if it happens between tracks of an album, or when switching between tracks of different albums, since the problem may be connected to changes in bit depth and/or sample rate not handled gracefully by your setup.

You might try to use Muse‘s sample rate conversion for a test, selecting to resample everything to the same resolution of, let‘s say 192kHz/24bit, and see if the problem persists.

Thanks for your comment.

First of all, a correction to the title, I typed ‘stops’, but it is more like pausing, if I wait for 30 seconds to a minute/a minute and a half, everything continues afterwards. It also happens sometimes when I pause the song halfway through.

it happens with both local and streaming content, everything is at least 44/16 bit, I mainly use playlists, but often also entire albums. I haven’t noticed it yet when playing an entire album as far as I know, I can still test that. By the way, I forgot to mention in my first message; roon also often takes a long time to load when I am in artist pages, for example. I just had the music play and the correct song was displayed in the bluesound app, but in roon everything was stuck at the previous song. What could that be? I wasn’t fast enough to see if anything was visible in processes in the task manager on the mini PC, everything seems normal there. I checked both songs for source and both were 44.1/16. Regarding Muse, is it better to choose 44.1 or 192 for conversion? And should I choose compatibility only or custom?

The more you explain the less I think it’s what I thought it is, but go ahead anyway and select max PCM rate which needs the least clicks - it’s supposed to keep a steady endpoint output sample rate regardless of all the tracks rates to not cause the DAC to misbehave on changes.

I wouldn’t know where all that lagging is coming from…

This tells me that Roon server app seems to run happily but Roon remote app is struggling. Does that behavior change at least temporarily if you quit and restart your Roon remote app (GUI)?

I am now using max PCM rate, I will keep an eye on whether this helps. Unfortunately it doesn’t matter if I close and reopen the remote app

Muse sample rate conversion didn’t help. When I tried to play music again this morning, the first thing I got was a freeze/pause. A few songs later it happened again, I saw a brief message about qobuz the second time, but unfortunately I could not read the entire message. So the first thing I did is look at the settings of qobuz again, see also screenshot


In the qobuz app i have everything set on 24-bit/up to 192 khz.

This morning after the freezes i changed the cache size in de qobuz app on my iphone from 1,25 to 6,23, it does not let me set it higher. But after the change I noticed that while playing music, the music also even stops for no more than a millisecond, this has happened twice now.

I can try to delete imported music, but seems like theres enough available? Do i do something wrong with the qobuz settings maybe? I’m also going to put the minipc somewhere else in the network to see if that helps. Are there some other things i can try?

Edit; Immediately after posting I deleted the imported music, I also don’t know why I would use that when I have separate storage on the mini PC for local music for Roon. Now I have also been able to increase the cache size to 30 GB. I saw in the Qobuz app on my desktop PC, which has more settings, that they also recommend that, but I still get the feeling that the problem lies somewhere in Roon.

I have been having the same issue. It is really annoying. I read in another thread to go into “Settings” “Roon ARC” and put “Port” at “0”

I did that and now it is super fast. As in fast for the past hour. Time will tell if that solved the issue but I wanted to post the possible solution I found.

1 Like

As I had anticipated in my last post, unfortunately.

Qobuz app settings have no relevance for Roon.

Hi Mark, did it solved the issue for you?

Problem is still there… Tried some things; using wifi and some utp cables, speed is when testing around 400/400, good enough with some switches in between. I noticed when i restart the minipc everything is ok and really fast for a day/max 2 days, but after that in roon loading pages can take up to 2 minutes or more, if im lucky the page is loading directly, got some qobuz errors that its loading slowly, clear roon image on my iphone seems to solved that, but i did that already a few times. I think its a ram issue if i use task management the memory is kinda high after a day or 2, but what can i do about that, something else i can try?

It did not. The hope was there but it still randomly stops. I have not found anything that helps.

Hi @Tomboli,

How has RoonServer been performing since the most recent update for you? We’ve continued to investigate this case and wanted to pass along a diagnostic test at your convenience.

First, restart RoonServer and then sign out of Qobuz in Settings → Services. Then, play a few local tracks and see if you can reproduce any performance issues. In any case, it should be helpful to our developers as we pinpoint what’s wrong.

Thank you!

Hi @connor, thank you for your message. Unfortunately, I’m still experiencing interruptions. Regarding the question about playing a few local files and logging out of qobuz, after restarting my mini PC I sometimes experience no interruptions for a day or sometimes 2 days, would you still like me to play only a few local files or continue playing local files until I experience inconvenience? thank you in advance

Hi @Tomboli,

We’re still investigating here, although I should have a more fruitful update soon.

On the bright side, we’ve released performance improvements in the last nineteen days since you posted that target some associated symptoms to what you’d reported here. How have things been performing in your setup? Are the dropouts recurring on the Bluesound? What about if you play to the speakers of your Windows 10 machine?

Hi @connor , Roon has been working better lately(was still listening with qobuz and local files together), I think out of the 5-10 days there were only a maximum of 3 interruptions and they were also very short and I didn’t even have to restart my mini PC, in any case these are much fewer interruptions than before. the last dropout was today, but only today it took a little longer for everything to start playing again. Coincidentally, Today I started testing local files only(and I followed the steps mentioned by you earlier before playing local files). Testing with only PC speakers for a longer period of time will be a bit more difficult. How can I find out if the dropouts come from the bluesound?

Hi @Tomboli,

Glad to hear it’s been more reliable. If you’re encountering the known issue with Roon/Bluesound, it would only affect grouped Zones in Roon that contain only Blu-OS capable devices. If it’s a single Bluesound device, then you’re likely encountering WiFi interference or bandwidth allocation issues.

You can test by playing back lower-quality files and gradually increasing the sample rate and bit depth. Do you start to encounter slowness and dropouts with heavier files?

Lastly, there are a slew of performance improvements shipping with the next Roon release. You may see continued improvement after we release the next build. Please keep us posted in a new topic thread in the meantime if this one auto-closes. Thank you!

Roon stops all the time for me as well. I have no music services currently setup. I have all my files playing from a Synology NAS fully updated. When I play songs in my Q, it just stops. My Q still has 2 songs in it and has Roon Radio running.

Hi @Brian_Fay,

Thanks for reaching back out. We’re investigating diagnostics for the affected device. Are you able to provide the name of a track that has failed in the queue recently? We can use this to pinpoint the failure and expedite our investigation. Thank you!

We’ll be back shortly with a more detailed response once we have a timestamp.