Roon stuck analysing tracks

Core Machine (Operating system/System info/Roon build number)

Intel Core i5-3317U
Windows 10 Pro, Version 1803, Build 17134.885
6GB memory, SSD
Roon 1.6 64bit, build 416
Music is stored on a QNAP Turbo NAS TS-412

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TP-Link TD-W8980 router, NAS and laptop connected by Gigabit Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Various Sonos devices, Intel Core i3 2100T connected by USB to a STR-DA5800ES Sony Receiver

Description Of Issue

Roon is in the process of analysing my tracks for its initial setup (I am still in the trial period) but has got stuck with 13446 items to go. I have checked through the support and community pages and have noticed this has happened to several people over several years and with no real solution. I have tried searching for corrupt (i.e. tiny) files as per the suggestion in the support pages but have not found anything.

I know I am only an IT Quality Assurance Analyst by trade, but surely if this is to do with corrupt files there must be a way to make the process time out and move on to the next file, and perhaps report any files that have failed somewhere so the user can take a look and replace them? This seems a lot easier than several reboots, enabling diagnostics and waiting a week for someone in the development team to look at it, which seems to be the current way of dealing with the issue.

Unfortunately I am also getting the “white screen of death” after minimising Roon on all of my PCs, including remoting into the core laptop, which seems to be another often reported but never fixed issue. All machines use Intel graphics. The Obsessive Compulsive part of me finds this very frustrating.


Hi @Jason_Schubert,

Analysis Issue

Generally, when this issue comes up, we have to take a look at the diagnostics report so we can track down the specific file(s) that is causing this issue. We then use these files to try to resolve the underlying issue preventing analysis from progressing.

Would you kindly do the following:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

White Screen

This issue is caused by Intel graphics drivers having an issue interacting with OpenGL, which Roon users. Often times updating the drivers can resolve this. If you’re still seeing an issue, try using the 32bit version of Roon.

Thanks for the response.

Okay, I have had some strange behaviour. Firstly, I tried installing new Intel Graphics drivers on one of my PCs and the core laptop, unfortunately I am still getting the white screen issue with the latest driver on both and for the 32 and 64 bit versions.

Moving onto the analysis issue, I performed the following steps (times are GMT +10):

  • Restarted the laptop 22:54:40
  • Roon started 22:55:55
  • For some reason the laptop did not reconnect to the NAS, which I did manually at 23:00:50.
  • Roon did not restart the analysis automatically, so I restarted Roon at 23:09:00

After I did this, the analysis started again and appeared to be working normally, at least for the first 141 items, but then stalled again. So I:

  • Rebooted 23:35:08
  • Roon restarted 23:36:01

It has been about 8 minutes now and the analysis is working normally again. Not sure if I should stop it now whilst it is working. Is this information useful for you?


PCs. Can you list the make/model number of if home brewed, the motherboard. What is the monitor resolution that you run on these PCs.

Laptop. Same, what is the make/model of the laptop?

The PC is an Asus P8H77-M running an Intel Core i7-3770 CPU @ 3.40GHz and 2 monitors at 1920 x 1200.
The laptop is a Toshiba Satellite Z930. Its native resolution is too low to run Roon, but I am remoting into it from the above machine (so same resolution, only one monitor).
Both use Intel HD Graphics 4000 (now) with driver version dated 27/12/2018.

I did try using the app on my Surface Book and it works okay, but obviously completely different graphics and drivers (still Intel though, no separate graphics card).


Some info for anyone who is following the analysing track issue, after a massive disaster where I lost internet and network (you don’t realise how much things rely on the internet until you don’t have it) I am back up and running AND all my music has been analysed (this actually finished before the crash). Interestingly, Roon does exactly what I suggested in my initial post n that it lists all the songs and what issue they had, in my case several DTS files and 5 corrupt files, which is exactly how times the process got stuck.

In my case, restarting the laptop seemed to make the process skip to the next track (just closing and reopening Roon did not).

The good news is I have been shuffling my whole collection and the volume levelling has been doing brilliantly!

Hope this might be useful for someone out there :slight_smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.