Roon stuck in scan mode, won't play streams (Tidal, Live Radio, Radio Paradise) or local music

Roon Core Machine

MacBook Pro 14" (M1 Max), macOS 12.1, 64 GB RAM
Core is installed on this MBP

Networking Gear & Setup Details

Wifi connection

Connected Audio Devices

At this location (work), I have two enabled audio devices:

  • System
  • Audioengine 2+ direct-connect via USB

Number of Tracks in Library

approx 7,500

Description of Issue

Roon played fine all day yesterday (following an update to v1.8 build 913 yesterday morning), across the Radio Paradise stream, a Tidal recommended playlist, and Roon Radio.

Later yesterday afternoon, it suddenly stopped playback. The controls still showed it was in play mode (pause icon, not play triangle), but the progress bar just had a short blue pulse sliding back & forth across, as if Roon was seeking the next track.

Restarting Roon did not help; choosing a local track did not help; then it was time to head home. Did not use Roon at home last night.

This morning, same issue: Roon won’t play music, just shows the sliding blue pulse in the progress bar. I started Roon fresh this morning, and restarted it twice. Same result trying to play tracks from Tidal; streaming live radio; RadioParadise; and also local tracks–none play. Also tried using the System device (all other attempts were with the Audioengine device)–no love.

When you say restart do you mean the app or the whole machine reboot?

By “restart” I’m stopping & starting Roon, not the entire computer.

Reboot the computer

You saw where I said this was MacOS, not Win98, right? :wink:

An OS is an OS.

Hey @Gregory_Wold,

Just checking in to confirm that the restart @ged_hickman1 recommended cleared up your troubles? In checking your system diagnostics it looks like you’re up and running again and have been able to play music. :+1:t2: :loud_sound:

Jamie,

Thanks for responding–it’s good to see Roon folks taking an interest.

A full computer reboot did in fact wake Roon up, and I’ve been able to play music again. It did not, however, clear up the troubles. I am still having intermittent stoppages with this latest build. Luckily, so far I’ve been able to get past them without an app forcing a system reboot again.

Hey @Gregory_Wold,

Thank you for letting us know that a restart helped. Are these stoppages still primarily happening at work? Are you able to try a wired Core connection to see if that helps? I’ll be watching for your reply.

I did not make time to test on my home network, and don’t have the ability to use a wired connection in the office, so can’t help with either of those questions.

Is there some Roon log you might be interested in seeing from when I was having the issue, and if so (and if it’s still available, this late), how would I find it to send it to you?

@jamie I had the issue happen again. This time, I was at home, running Roon on a new machine–I transferred my core from my laptop to an M1 Mac mini. While playing from Tidal the playback stopped and I saw the sliding blue pulse in the progress bar. Trying to control Roon from other devices (the laptop, iPhone) did not help; playing to other audio devices did not work.

This time, however, after I restarted Roon (no, I did not yet reboot my computer–this is an app issue), while Tidal would still not play, I could play from my local library. I also logged out of Tidal, then back in, but still could not stream from there.

When I rebooted the computer, Roon returned and is once again playing Tidal streams.

@jamie any thoughts? This issue with all streams freezing Roon is getting annoying. I’m facing having to reboot my computer–not just Roon, but the entire computer–for the second time tonight. That’s less than 2 hours. And I am now running build 931, yet the issue is as bad or worse than before.

Hey @Gregory_Wold,

I’m sorry to hear that your issues have returned.

We’ve also seen Private Relay on Mac Monterey cause these kinds of problems in Roon.
Please check to see if Private Relay is enabled on your Mac using these steps.

On your Mac, choose Apple menu  > System Preferences, then click Apple ID. Select iCloud > Private Relay.

On your iPhone, iPad, or iPod touch, go to Settings > [your name] > iCloud > Private Relay.

Your iCloud settings might take a while to load. In order to disable it, simply untick the box and click “Turn Off Private Relay” when the prompt appears. Please let me know if this helps.

Just had Roon go into the spinning beachball. I had to reboot the system to get Roon running again.

I’ve turned off Private Relay (post-reboot), will give that a try. Hopefully Roon gets updated to allow me to turn it back on again, as I’m a fan of what PR purports to do.