Roon suddenly stops playing from Tidal but resumes upon server restart

Roon Core Machine

Windows 10, i7-4790K, 16GB RAM

Networking Gear & Setup Details

All Ethernet, except for cell phone and Chromecast Audio on wifi

Connected Audio Devices

Chromecast Audio and PC

Description of Issue

I was playing music from Tidal almost the whole day, then suddenly one track ends and the next doesn’t start. That was to Chromecast Audio controlled via Android app on a cell phone but that’s irrelevant, see below. I tried other tracks, albums, artists. Nothing played. It starts but no audio and no progress bar. Then even the play button stopped changing to pause button.

I opened Roon on a wired PC, tried playing something but the same - nothing would play from Tidal. I looked at the logs. When it was playing normally I saw the following:

07/03 23:07:04 Trace: [ChromecastAudio1] [Lossless, 16/44 TIDAL FLAC => 16/44] [100% buf] [PLAYING @ 0:00/3:47] xxx - yyy
07/03 23:07:04 Debug: [easyhttp] [6812] GET to returned after 198 ms, status code: 200
07/03 23:07:04 Debug: FTMSI-B got length for ti/5154396C; 8.4 MBytes
07/03 23:07:04 Debug: FTMSI-B ti/5154396C download status: FileLengthRetrieved accessTimeout:False openFiles:1 prev:(DownloadNotStarted,False,1)
07/03 23:07:04 Debug: FTMSI-B-OE set min bandwidth for ti/5154396C to 1005 kbps
07/03 23:07:04 Info: FTMSI-B-OE ti/5154396C rid:1 response took 199ms
07/03 23:07:04 Debug: FTMSI-B ti/5154396C download status: FirstBlockRetrieved accessTimeout:False openFiles:1 prev:(FileLengthRetrieved,False,1)
07/03 23:07:04 Info: [ChromecastAudio1] [zoneplayer] Open result (Queueing): Result[Status=Success]
07/03 23:07:05 Debug: FTMSI-B ti/5154396C download status: FirstBlockRetrieved accessTimeout:True openFiles:1 prev:(FirstBlockRetrieved,False,1)

When it stopped playing I saw the following:

07/03 23:12:18 Debug: [easyhttp] [6838] GET to canceled after 5017 ms
07/03 23:12:18 Debug: FTMSI-B ti/0EBEC887 download status: DownloadNotStarted accessTimeout:True openFiles:1 prev:(DownloadNotStarted,False,1)
07/03 23:12:18 Info: FTMSI-B ti/0EBEC887: allocated bw changed from 51200 to 0 kbps
07/03 23:12:18 Info: FTMSI-B ti/F5563DEE: allocated bw changed from 0 to 51200 kbps
07/03 23:12:18 Debug: FTMSI-B-OE ti/F5563DEE rid:17 interrupt requested; reason: should remove
07/03 23:12:18 Debug: FTMSI-B-OE ti/0EBEC887 rid:1 request ended -- first block: 0 blocks read: 0 download speed: -256kbps response time: -1ms
07/03 23:12:18 Info: FTMSI-B 1 FileCache ti/43B4B624 dwStatus:FirstBlockRetrieved files:0 accessTimeOut:True priorities: ('zoneplayer:7':1) --> bw limit:0kbps

I didn’t know what to do. I stopped and started the Roon server and everything is back to normal. I didn’t do anything else.

But what happened is not normal I believe. I hope you can take this report into account when coding the next version.

Doesn’t tidal restrict playback to one device per account - maybe someone else has got a stream playing on your account? Or maybe it’s you on another machine/device???

Funny questions. I was alone and tried to play one stream from one device at a time. Even if it wasn’t the case why would restarting the server help…

Hi @G_P ,

Can you please upload the full log set to the following link and let us know once uploaded? Thanks!

Hi @G_P,

I realize it’s been some time since you reported this issue, but I wanted to check in to see if Tidal playback has remained stable for the last few weeks. Looking through logs, it’s likely the problem you experienced was related to a known issue which we’ve since worked with our QA team to resolve.

A glance at the most recent diagnostics from your account indicates that Tidal is syncing appropriately in RoonServer, but please reach out if you’ve experienced any difficulties and the tech support team will be standing by to assist.

1 Like

Hi @connor,

Sorry, I rarely used Roon in the past and haven’t visited the forum. From time to time I opened Roon on the PC to check for updates and I think there was an update shortly after I reported the issue. I think there were more updates after that. In any case, the issue never came back. Hopefully you fixed it. Thank you for keeping track of the issues.

1 Like

Great to hear @G_P!

Please reach out in a new topic if you encounter any issues moving forward.

1 Like