Roon takes forever to add an album

Roon takes forever to add an album. NO change at all after so many minutes… @noris

1 Like

I am having exactly the same issue. I have tagged support in my post. It has been going on for about 16 hours now

1 Like

Wired reboot without IPv6, DNS change and much more were solutions documented here in the community. Without the most accurate technical data it is hard to help, so a support sheet was developed. This way it is easier to isolate the problem.

I never had this problem before, nothing has changed in my landscape. The only change was the upgrade of ROON to the latest version. I use an N+.

I would start a new Support thread and fill in all of the parameters they ask for.
Otherwise I think you will be asked for more details and in my experience the support process can drag on.
Give as much detail about your set up as you possibly can

I am in the same position as you . I have the Nucleus and never had this issue before.

1 Like

Check the “background audio analysis speed” and “On-demand audio analysis speed” in settings/library and try a different setting.

1 Like

I rebooted the N+… Now the time the system is taking is under acceptable limits for me… :slight_smile:


Hi Try this , it worked for me.

You need to rid yourself of the “Metadata improver paused”-message.
There are several reasons for this, the common one for me is that this particular core started up unlicensed. (meaning, another Core was authorized and granted your license)
Try this:
Go to Settings
Disconnect your Core
Log out (top left on the screen)
Restart your Nucleus/ROCK from the GUI
Restart your Controller
Log in to your Roon account anew, after selecting your Core.
If your license is granted to any other cores you will be asked to deauthorize the old Core. Do this…

Did this do the trick?

These instructions were given to me on my thread


Hello @Tushar_das ,

Thanks for letting us know that a reboot of the Nucleus helped in this case, has the system been stable since the reboot? Let us know, thanks!