Roon takes longer to start playback of tracks

Hello, I’d like to jump in on this…I am having the exact same issues here. I use Roon with Tidal Hi-Fi and MQA and my own CD quality music stored on a QNAP TVS-673 (fairly powerful NAS), has Roon Core loaded on dedicated M.2 SSD…tons of surplus capacity, I barely have anything on the NAS. Roon Endpoint is Bluesound Node 2i. Internet connection is 200Mbps. All my internal household networking is gigabit wired with Cat 6.

Roon Core Version : 1.6 (build 401) stable QPKG-Version : 2018-06-14 Process ID : 20755.

I tried Roon a while back but did not purchase. Trying it again now on a 3 month trial. I’ve loaded up all my music and Tidal selections. 937 albums with 12,975 songs. Here are symptoms:

  1. Songs slow to load 3-5 seconds…and sometimes music never starts for the selected song and it just skips to the next song.
  2. Most times it cuts off the first 1/2 second of the song when you select a new song to play. The moving graphics suggest it’s playing but no sound comes out, and then when it does start playing it cuts off the beginning.
  3. Skipping forward or backwards mid-song is pot luck.
  4. Album art for releases in my collection slow to refresh, same as Jens above.
  5. Player controls in general sluggish and erratic.

Have tried:

  • clearing cache
  • cleaning up database (using the built in “clean database” function)
  • rebooting Roon core app on NAS.

Would appreciate any advice…feels like a software fix…or maybe settings, but I haven;t really tinkered with any settings, very much a stock set up.

Thank you.

Hello again,

I should point out that general browsing and navigation within Roon, such as viewing the artists, album or song lists is lighting fast. The Overview, Genres, Discover, Tidal ect, all these pages load very fast if not instantly.

The issues mainly surround actual playback of music files…either local or Tidal, MQA or CD or even MP3, doesn’t matter. Also, iun addition to the syptoms mentioned in my prior post…sometimes a song just fails to play. You have to click on it several times, or first clear the queue etc.etc.

Also, noticed that Internet Radio stations are not starting properly, or requiring excessive time to start. I tested all the links browers adn itunes and the stations come up instantly, so the links are good.

Can you try playing to a different endpoint than the Bluesound, maybe a laptop computer, a phone, just to provide a different data point than just the Bluesound.

Hi @Anthony_Lathbury,

Thanks for contacting us regarding this issue. I would definitely give @Rugby’s suggestion a try and see if other outputs are working as expected. If they are we can know to take a closer look at the Node 2i connection by itself rather than a general issue.

Can you also provide some more information regarding your network here? What is your router model/manufacturer? Are you making use of any switches/range extenders/powerline adapters? If so please list the model/manufacturer.

We have sometimes seen the need for specific settings applied to these devices for Roon to operate properly, so I would just like to request this info ahead of time in case you have equipment that falls under this category.


Rugby and Noris,

Thanks very much. Last night I did try using my Computer as the end point (the same Windows 10 computer from which I was running the client app on), and was still having the issues. This morning I tried on my iPad 2 Air, using that same iPad as the end point and that seemed to work pretty good.

The Bluesound Node had been wireless, but last night to try and test that aspect, I ran an ethernet cable to it. I believe it helped maybe a little, but was still seeing the issue in a noticeable way. It’s fairly close to the Netgear 5g router, so didn’t expect a night and day difference between wired and wireless.

My network chain is as follows:

  • 200Mbps service from Cablevision
  • Modem
  • Linksys LRT224 router
  • Actiontec Bonded MoCA 2.0 Network Adapters - Gigabit (connects to the wing of house where my Bluesound is, so there are two devices, one at each end of the connection, travels over coax)
  • NETGEAR R8000 (configured as a wireless access point)
  • Bluesound, if connected wirelessly…or if wired then…
  • HP ProCurve Switch 1400-8G 8-Port 10/100/1000 Gigabit Network Switch
  • Bluesound, wired

I will experiment further this evening. Any advice on settings would be appreciated. Thanks !


Hi @Anthony_Lathbury,

Thank you for providing that information. I have not seen many MoCA reports but to verify if this is not part of the issue I would suggest connecting both your Core and Bluesound endpoint directly to the Router. If things are stable that way, we can take a look down the chain.

Your Netgear R8000 access point is similar to the R7000 which is on our list of devices that need specific settings applied, so I would try to see if you have the option of disabling the “Enable Smart Connect” setting. Please let me know how the test goes and if you are able to connect the Core + endpoint directly to the router.


1 Like


Thanks again. Sorry, I wasn’t thinking clearly when I e-mailed the network details earlier. See attached updated pdf diagram. QNAP/Roon Core are connected to the router via gigabit switch.

Maybe, as a test, I connect the Bluesound Node 2i to the same Netgear gigabit switch as the QNAP/Roon Core ?..I believe that would be as fast as you can get.

Another cross check would be testing the shields as end-points, since they are already on that same switch.

ALso, will check on the R8000 Smart Connect setting.

1 Like

Both of those sound like a good test to do.

1 Like

Norris and Daniel,

Problem solved, many thanks ! Seems to have been the Smart Connect setting Netgear R8000 router that you pointed out, once I disable that setting everything started to work fine. It’s slightly snappier hard wired, but that’s not convenient and with this fix it’s plenty responsive for my needs. So good news is I can leave the Node 2i right where it’s at.

Thank you !!!



Hi @Anthony_Lathbury,

Great to hear that the changing that Smart Connect setting on the R8000 resolved this issue! Thanks again for contacting support and wish you an enjoyable Roon experience :headphones:!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.