ROON TECH SUPPORT Please Help

Roon Core Machine

Late 2012 Mac mini 2.5GHz 8GB Ram 500GB SSD Catalina

Networking Gear & Setup Details

ARRIS TM1602 MODEM
UBIQUITY Amplify HD Router NO mesh end points used
Mac mini Connected via ETHERNET

Connected Audio Devices

NODE 2I Connected via ETHERNET
ANTHEM AVM 70 VIA Chrome cast
Blue Sound Pulse Mini Connected Wifi RAAT No issues with this device

Number of Tracks in Library

RIGHT NOW NONE

Description of Issue

I have been reaching out to Roon support for over a month explaining my situation. No matter what I play i get audio drops in every song through BS Node 2i RAAT or Anthem AVM 70 via Chrome Csst. I disconnected my external hard drive and used TIDAL only and still same results. I switched to a dedicated ROON CORE, the mac mini, I was previously using a 2014 iMac,
still same results.

I think I was pretty clear that all network connections are hard wired. This has been very frustrating. this is my second post on here for the same issue and no responses. Am i doing something wrong the way I have explained my problem.
I received one email response from Jamie, on March 31 and responded back same day but have not heard back again. see belowPlease Help

Hi Michael,

Thank you for reaching out to us with your question. We can definitely help! I apologize for the delay in responding. I had hoped to get back to you sooner and appreciate your patience.

I am very sorry to hear that you were having issues with your playback on the Node. Since there’s been a delay in getting back to you I wanted to inquire whether you were able to get everything up and running again?

If not can you please try to connect wired ethernet to the Node and see if that helps? If you still require assistance please respond to this email and I’ll be back in touch as soon as I can. I’ll be watching for your message.

All the best,

Jamie


Setup details

Core: macOS

Audio devices: Bluesound node2i and pulse mini

Networking gear: Nose 2i hardwired to Amplify HD and pulse on WiFi. Not using any mesh end points

Company information

Name:

Type:

If you put tge mini on a wired connection and take it off wireless does it still work?

I have not tried that, the mini is mounted on a wall very far from the riouter. the node 2i either wired or wireless same results
Anthem AVM 70 as well wired same drops

Hello sorry to hear this. You may want to try some things to understand where the problem lies:

  1. If possible to use your Core as it is but have a different endpoint (“zone”). You say MacOS - If you have a Mac laptop this will be trivial to do, go to settings and enable the speakers as a zone. If you have a Mac mini as core I don’t know if you can do so

  2. If that is not possible can you install Roon core on your laptop or PC, deauthorize your current core, authorize the new one and use the same laptop/PC as an endpoint (set the laptop speakers as a “zone”)

In both cases if the problem is with the network you will probably continue having issues. If not, you will know your problem may be with your current endpoint

Roon Core Machine 1

Imac 3.5 intel I5, mac os 11.6.5 Big Sur. 24 gig RAM

Networking Gear & Setup Details

Modem is Aris TM1602
Amplifi HD router Hard wired to blue sound node 2i as RAAT

Connected Audio Devices

Node 2i is connected to an Anthem AVM 70 via COAX from node 2i
Blue sound Pulse mini connected via wifi

Number of Tracks in Library

5151

Description of Issue

I have been having audio drops and at static while using Roon only. This happens very frequently. if I group the BlueSound Pulse mini and the node 2i the audio drop and static is only produced on the node 2i system. if i switch to the BueOS app, and not use roon everything works fine. I haven’t made any network or gear changes, It has worked fine in the past with this system and I’m not sure why this started happening. Any help very much appreciated.

Hey @Michael_Reilly

My sincere apologies for the delay and for dropping the ball on your earlier report. I’m sorry about that. I’d like to get this resolved so you can get back to enjoying music.

Logs were pulled for your Core on the 31st and I just pulled another set to take a second look. There’s an overwhelming amount of network errors in your logs that are stopping playback. It appears that your network is having difficulty maintaining a consistent connection with Roon.

You said that your Mac Mini is now using a wired connection as is the Node 2i. Can you describe those connections a bit? Are there any switches in the line? What type of ethernet cable are you using Cat5/Cat5e/Cat6/7/? Have you tried different cables by chance?

Let’s start by having you check to ensure that IPv6 is turned off on your router. You’ll need to access the router software or app to do that. You may need to do a quick Google search to figure out how that is done. Next ensure that Roon exceptions have been added to your firewall on your Mac Core.

After checking those two steps, please restart your Core and Router, power down, unplug them, wait a few minutes, plug back in, power up.

First try to playback music on the Mini itself using the headphone output. Does it play without dropping? If so move on to the Node 2i. Does it work? Does it work if you try wi-fi?

Also, please take a look at our Help Center article on Networking Best practices to see if there are any recommendations there that apply to your setup.

Please let us know if this helps. I’ll be watching for your reply. My apologies again for the delayed response.

Hi,
Thank you for reaching out. I went back to the iMac as the Core, which has built in speakers, I selected system output and all played nice no drops for over an hour.
I’m just not sure why it would happen on both the Anthem and the Node2. Two totally different systems and different ways of play back. RAAT vs Chromecast.

Thank you,
I will try your suggestions and report back.

Hi Michael, can you go one step further and try to hook up the BN as an end point with the iMac as core ? As you say it is strange that two different protocols have problems at the same time. Could it be the Mac mini that is causing the issues

The Mac mini was just added as a dedicated core. I was using an iMac family computer for a couple of years with no issues. I was able to get a good Mac mini i5 2,5 ghz 8mb 500G SSD. for pretty cheap and figured I would use this as a dedicated core.
The problem started on the iMac and continued on the mini

Thanks Jamie,
IPV6 is indeed off on my router, fire wall was off on the mini after new install of Catalina. The mini is clean I removed all external hard drive from the mini and only have Tidal as a music source.
I thought about replacing the AMPLIFY HD router with Eero, but I’m seeing others on here with a node 2i with the same problem.
The Anthem AVM 70 is playing with Roon as I type with no issues. Anthem is waiting on certification, so don’t want to start replacing the node 2i.
Chrome cast works fine but it’s not RAAT so I can’t group any other speakers and frankly when the node 2i is working with Roon it sounds much better. I am currently not using the BS pulse mini right now as I have confirmed that it works fine as a single player or grouped with the node 2i. When grouped the drop out only happens with the node 2i.
Thank you for your efforts, not sure of next steps.
Mike

Sorry, yes Mac mini headphone jack works fine no audio drops

Thanks @Michael_Reilly,

Based on what I saw in your logs I feel like your network is causing your problem. Node 2i problems are less frequent in my experience. Generally speaking, Bluesound devices are very reliable with Roon. However, that doesn’t eliminate the possibility that it’s the Node. Are you still having issues when playing to just the Node by itself?

Also, can you tell me the rating of your ethernet cables? You should see that printed on the cable itself.

I’ll be watching for your reply, thanks again for your patience.

Hi Jamie,
The Mac mini is a CAT6 the node CAT5E, could you check my logs at 2:50 am Saturday April 23. Through 3:20am. At about 2:55am I disconnected everything I had connected to the Amplify router. I connected the arris router, Mac mini and the node 2i to a netgear GS 308v3 unmanaged switch. This seemed to work really well. Please let me know if you see any problems after 2:55am.
If not then it may seem to be the router. If it is the router do you think a EERO woulld be a decent choice. I have tried many stand a alone routers in the past, linksys and netgear but the WiFi has never been good enough for my home.
Please let me know your findings
Yes, it is still was happening with the node until I made these changes, either WiFi or wired. I’m just puzzled why the pulse mini has NEVER dropped audio.

Thanks Jamie

Hi Jamie,
Over the last day I had some time to try and isolate my issue.

  1. Reset AMPLIFI HD router to factory settings created new wifi network.
  2. Mac mini using Roon server headless (love this)
  3. Removed AMPLIFI HD router from system
  4. Connected Mac mini, node 2i to netgear gigabit GS308v3 with CAT6 cable used Roon core on Mac mini to play files (Tidal only)
    All theses produce the same results, audio drops very frequently.
  5. Used BlueSound app no issues…with AMPLIFI HD router connected everything works as expected…
    Roon has worked flawlessly before this all started over a month ago. I’m lost in what else can be done. I know you see internet loss, im just not sure where its dropping.
    When I do get audio drops, I DO NOT see any signal drop on my Anthem AVM 70. If I loose a signal the Source bit rate would flicker on & off (ie PCM or whatever is being Played).
    Thanks for you time
    Mike

Hi Jamie,
Last update.
I reset the node 2i entered it back into the BluOS app. Everything seemed fine. I then proceeded to enter in the pulse mini, as soon as I finished adding in the pulse mini, static and audio drops started on the node 2i. I have a new router coming, I don’t think that is my problem.
I had the netgear switch connected to the modem, the Mac mini, node 2i and my Anthem. This was before the factory reset and was still having audio drops.

Hi @Michael_Reilly ,

It doesn’t look like your Mac Mini has communicated with our diagnostics server in the past 2 days, can you open the Roon app and use it on the Mac Mini when you have a chance?

Looking over the iMac logs, I did find one instance of the issue occurring, and it looks like the Node 2i just disappears from the network and re-connects:

04/21 02:40:07 Trace: [Node 2i] [Enhanced 83.3x, 24/48 MQA TIDAL FLAC => 24/48 MQA] [100% buf] [PLAYING @ 2:49/3:53] You Belong to Me - Carly Simon
04/21 02:40:12 Trace: [Node 2i] [Enhanced 83.4x, 24/48 MQA TIDAL FLAC => 24/48 MQA] [100% buf] [PLAYING @ 2:54/3:53] You Belong to Me - Carly Simon
04/21 02:40:13 Debug: [airplay/discovery] Sent mDNS discovery list response
04/21 02:40:13 Debug: [airplay/discovery] Sent mDNS discovery list response
04/21 02:40:13 Debug: [airplay/discovery] Sent mDNS discovery list response
04/21 02:40:13 Debug: [airplay/discovery] Sent mDNS discovery list response
04/21 02:40:13 Debug: [airplay/discovery] Sent mDNS discovery list response
04/21 02:40:13 Debug: [airplay/discovery] Sent mDNS discovery list response
04/21 02:40:13 Debug: [airplay/discovery] Sent mDNS discovery list response
04/21 02:40:18 Trace: [Node 2i] [Enhanced 83.5x, 24/48 MQA TIDAL FLAC => 24/48 MQA] [100% buf] [PLAYING @ 2:59/3:53] You Belong to Me - Carly Simon
04/21 02:40:18 Info: [stats] 6108mb Virtual, 936mb Physical, 302mb Managed
04/21 02:40:23 Trace: [Node 2i] [Enhanced 83.7x, 24/48 MQA TIDAL FLAC => 24/48 MQA] [100% buf] [PLAYING @ 3:04/3:53] You Belong to Me - Carly Simon
04/21 02:40:28 Debug: [raat/tcpaudiosource] disconnecting
04/21 02:40:28 Debug: [raat/tcpaudiosource] connecting to 192.168.166.218:36165
04/21 02:40:28 Warn: [raat/tcpaudiosource] send failed: Cannot access a disposed object.
Object name: 'System.Net.Sockets.Socket'.
04/21 02:40:28 Warn: [raat/tcpaudiosource] disconnecting + retrying
04/21 02:40:28 Debug: [raat/tcpaudiosource] disconnecting
04/21 02:40:28 Error: [raat/tcpaudiosource] connect failed: Object reference not set to an instance of an object
04/21 02:40:28 Warn: [raat/tcpaudiosource] disconnecting + retrying
04/21 02:40:28 Debug: [raat/tcpaudiosource] connecting to 192.168.166.218:36165
04/21 02:40:28 Debug: [raat/tcpaudiosource] connected

On the iMac, there were also networking issues present, but these errors could have been while you were moving networking gear around.

It does look like there was some Airplay activity in the logs right before the issue occurred, so I wonder if Airplay is playing a part in this, especially since you mentioned:

If you keep the Pulse Mini out of the equation, does the Node 2i remain stable? I wonder if the Pulse Mini Airplay discovery is playing a part in the issue.

I’m going to change modem and see what happens. I’ll uninstall Roon from iMac, remove pulse mini and factory reset node2i, then report back when it’s up and running
On the Mac mini it will run headless after we fix this. Should I just keep Roon server on the Mac mini and the remote on iPad, clean as possible?

Any chance we are seeing an IP address conflict on the network? Just a thought… good luck OP.

It’s running on the mini now haven’t changed anything yet