Roon Tidal - badly broken

Roon Core Machine

ROON on I3 - 16GB RAM - SSD .

Networking Gear & Setup Details

Unifiy POE
Wired
HifiBerry Beocreate
Airplay 1 - with Smarthome (that mostly just worked)

Connected Audio Devices

Hifiberry BEcoreate
Hifiberry AMP

Loxone - with Airplay 1

Number of Tracks in Library

About 4K

Description of Issue

Why I’m writing this - as i canceled my Roon - i loved it but:

Roon is just broken on dealing with Tidal. Tidal itself works perfect. Roon standalone works as it seems.
Logitech Music Server with Tidal App works ways better than Roon Tidal Integeration.

After fiddeling around about half a year I’m tired of arguments like - your infrastructure is bad - your network is bad - actually nothing is bad here, just a piece of software does make massive troubles.

Let me be honest - get your code in shape → that’s the main problem what I see.

Will probably give it a try later as I love to poke around with music infos - but actually playing music is a mess with roon.

Must be a geographical issue. I’ve had Roon and Tidal for 3 years and Qobuz for 2 1/2 years with no issues with either. I’m in southeast USA.

EDIT: My AT&T U-Verse internet is only 50/12. Everything is connected by ethernet except Roon control devices.

Hi

don’t think so at all - cause Tidal app alone works fine.
Roon itself works.
Netflix / Sky (streaming in 4k - HoD) - just works
So probably Roon connects to tidal via a link in the rocky mountains back to europe, or probably there’s no cache at all for Roon in Europe / Germany / Austria ? That si probably bad - but shouldn’t harm that much that it stops playing stuttering around etc.

Greetings

Mike

Hi Mike,

I didn’t see a Support thread for you on the forums. I know you have decided to leave, but, if you want help I’m sure that the @support would be happy to investigate.

2 Likes

That’s what I mean by a geographical issue. Roon works. Tidal works. Roon and Tidal together work, but not for you. Something to do with your location I think, if you have ruled out all other possibilities.

Out of the 250k Roon users (or more) I guess a good half use Tidal. If your contentions were sound the support thread would be flooded with complaints.

It simply isn’t , if its not a geographical thing as suggested by @Jim_F then maybe look to your own system. Roon is well known for having large demands on your system resources.

If you have cancelled so be it but at least make your post accurate , FWIW I have used Tidal for years in darkest Africa without a blip . The KISS principal for systems works :smiling_imp: :smiling_imp:

Nuff said

5 Likes

I had the same symptoms that you are describing, Tidal stuttering, not play in Roon, “this track is loading slowly” message etc. All while Tidal on its own worked just fine. At the time I was using the ISP provided Router/Access point (10meg down/0.5meg up speeds). Core was wired. I upgraded to a Mesh network, turned off all extra features on the ISP router so it was JUST providing an internet connection and lo and behold tidal worked with Roon. We are now on Fiber internet (240 meg up and down) and it has not had any issues. I am in the Midwest USA, Rural location out in the country.

So I suspect that it is could be one of your devices not being able to handle the throughput?
Can’t say for sure, obviously, but might be worth looking into.

I measure my throughput this morning at 14 Mbs down 9 up , not quite the 20/10 as purchased

I see no stuttering , even 24/192 shouldn’t stretch any normal 10mbs download ,I would look elsewhere

Are you using WiFi for instance , interference will cause this

Keep in mind that Tidal/Qobuz send FLAC files (or even lossy compressed files, depending on the settings) to the endpoint, which may be your phone or streamer. With Roon, however, the FLAC is decoded by the Core and then sent onward as uncompressed PCM data to the endpoint, which is larger. Hence, if you are using WiFi for Core or endpoint, it may happen that it is fast enough for the encoded/compressed data, but not fast enough for the PCM

@bearFNF I believe this is relevant from what I can see via remote diagnostics logging.

@Mike_Tomaselli are you using an ISP-provided modem/router combo as I suspect? I have had this exact same issue with mine. Changing from this all-in-one solution to using my own Motorolla modem and ASUS router resolved this exact same issue for me. Others have had success by putting the modem/router combo into “bridge mode” and using their own router too but I didn’t.

Do me a favor and look at these possibilities. I will send you a private message as well.

Thanks,
Wes

Hi … Not flaming at all - reading a lot through the communities and trying to find solutions based on already available community feedback, and mostly the answer is - it’s your ISP etc.

Hey - when i can without any problem stream Sky with HoD or GoT or Disney+ or Netflix in HD and 4K - it should just work with a simple “FLAC / AAC”

Tidal alone works perfect - roon alone - is stuttering (even with radio stations that work perfect within a logitech music server installation on a raspi 4 with 4GB RAM - with tidal integration (no problem at all)

The Intel NUC i use for the core is equiped with a i3 - 16GB RAM / Fast NVMe - 1GB Wireless - direct on the switch.

I just read often - it’s problem on your network - that’s the easiest way.
I wiresharked - and found no problem at all - as i work for a compny in the internal IT as adminstrator.
Everything works - but roon stutters …

Please advice me what I do terrible wrong so that:

  • a software that should import information from the net
  • probably convert ONE stream at a time form one format to another to a “roon supported hardware”
  • showing some information on the “ipad” - within an App that is mostly a webcontainer

isn’t able to just give me the experience i expect - information like a magazin to a song…
without - loading slowly - this all on cable net - with 150Mbit down / 50mbit up …

No Fancy on a VPN oder something … just a network - some vlans needed - a roon core and the needed “ipad” on the same vlan - and the hifiberry player too on the same vlan… (that works completely flawless with Logitech music server btw …

So where to start to find out what’s happening really?
Roon isn’t telling me something - where’s the log i could analyse?

I just do NOT wanna bash on roon - i really will restart my subscription - but it should work without fiddeling around every 2 days…

And why did i start this - because i stopped my subscription - and roon “automated” asked me why …

Best regards

Michael

You would think, but that’s just not the case. If everyone but you can stream from Tidal to Roon, it’s your network. The fact that other apps work is not an indication that all is OK.

@Wes I have a bridged internet → to a pfsense firewall. just flawless on every service i consume.
(NFL Gamepass / Sky / Netflix / Amazon / TuneIN within LMS / Disney + / Tidal)

I couldn’t see a possibility to find out is the core on steroids and probably the 4 year Intel I3 NUC is too old - to full packed - with just 16GB RAM / SSD with the ROCK installed?

Greetings

Michael

@Mike_Tomaselli do you mind me sharing your logging that shows the songs and internal IP addresses? I can show you what I saw when I enabled diagnostics.

Wes

@Wes no problem can share how to PM?

Click on the red logo next to his name

2 Likes

Hi

The players are all 1GB connected.
Just the App → ipad is on wired - unify…

Ah OK, I wasn’t clear on that. Just came to mind because I had such an issue streaming with Roon to my phone as the endpoint (because BT headphones), but it worked with the Qobuz app, clearly for that reason.