Roon>Tidal connection broke

Core Machine (Operating system/System info/Roon build number)
ROCK v1 Build 227
Roon 1.7 (Build 610)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Atoll 300 Stereo via USB.

Description Of Issue
I received notification that Tidal was not connecting.
Then, I had a power outage that may have impacted my Ethernet port. Now am using Ethernet dongle directly into USB port.

I tried to reconnect to Tidal via Settings>Services and received

You’ve successfully connected your TIDAL account.

When I am returned to Roon Settings>Services I see the message

Not configured

for Tidal.I am able to successfully use Tidal via their web site.

In effort to remedy the situation I have Reinstalled the OS. Restarted the Server Software and restarted the NUC multiple times.

I have a successful connection to my router and have tried multiple DNS server settings (,, etc). Roon plays without hesitation or hitch.

I think I have tried everything I have learned and read about.

Hello @ronald_estell,

I would start troubleshooting this by temporarily changing your Roon Core to a PC or Mac in your household to and checking to see if you’re able to login to Tidal.

  • Open Roon on the PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the PC


Ok, did it. Tidal will connect using the pc as Core.

How to proceed on NUC?

Found my subnet mask was corrupt. Problem solved!

1 Like

Hi @ronald_estell,

Thanks for letting us know you were able to locate and resolve the issue, happy listening! :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.