Roon + TIDAL not working, performed some troubleshooting already

  • Details on your Core machine (OS, Hardware specs)

Intel i5-4670, 8GB ram (4gb + 4gb), 2TB Hybrid HDD
Windows 10 Pro
Roon Core Version 1.7 (64bit)
Roon Remote Version 1.7 (iPad 10.2, 2019)

  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)

Home Internet Service Provider: 1Gbps Optic Fibre
Home network: Linksys Velop Mesh Routing (WHW0303-AH)
Roon PC is connected via 5GHz.
Roon PC to Node is within 5 metres with line of sight.
Node to main Node is connected via ethernet backhauling.
Wireless Roon PC download speed is 360Mbps++, Upload speed is 400Mbps+

  • Audio devices in use

T+A DAC 8 DSD

Presently, I only have one Roon endpoint.

Update:
So I noticed a pattern/trend about Roon+Tidal. I try my best to describe it.

This is under the assumption that everything goes well with Roon Radio enabled:

  1. Selects a track on Tidal to stream and play.
  2. It takes some time (between 1 min and 3 mins+) to buffer the selected track.
  3. It starts playing normally
  4. When the track has successfully played from start to end without interruption (e.g. skip next track, or, selects another track to play immediately), the next track will play seamlessly.

But what if I want to play another track?

  1. Selects a track on Tidal to stream and play.
  2. It takes some time (between 1 min and 3 mins+) to buffer the selected track.
  3. It starts playing normally.
  4. While the track is playing (time elapsed does not matter), I decide to select another track to play immediately.
  5. Start from step #2.

I also noted occurrences as such:

  • Track finished buffering, showed start and end time/duration of the track, it is supposed to start playing but the vertical line indicator of time elapsed is stuck at the beginning of the track, and it is not playing at all.
  • Track plays for about 10 seconds or so, suddenly and automatically changes to another shuffled or Roon Radio track, and it buffers the new track again.

I always thought Tidal was giving me the problem. But when I am outside of Roon+Tidal environment and instead dive into Tidal only environment (e.g. mobile phone Tidal App, or through chrome browser of my work laptop or gaming pc), I can listen to music seamlessly and change track on-demand!

1 Like

Hi @James_Song,

Thanks for the detailed report here. It’s hard to say exactly what might be happening here just yet as there’s a few places that this behavior may be stemming from. This might happen if Roon is having trouble connecting with the endpoint, if there is a problem with performance on the Core, if there are networking issues, etc. There are some tests you can do that will help us narrow down the root cause so we can get this resolved for you.

First, I hope you could confirm the following:

  • If you play local content and not TIDAL content, this works without any issue or delay, correct?
  • Does this same issue occur if you play to System Output of the Core machine?

Live Radio plays. TIDAL or Quobuz do Not play. TIDAL without Roon plays seemless

If you play local content and not TIDAL content, this works without any issue or delay, correct?
That is absolutely correct. Local library music has no issues.

Does this same issue occur if you play to System Output of the Core machine?
Yes, the issue is replicable if i play to system output of core machine instead.

A post was split to a new topic: TIDAL playback and missing zones

Update #2:

Yesterday, I put my Roon+Tidal list of liked tracks (mix of local and tidal tracks) on shuffle, and then went away to attend to work.

About 50 minutes later I returned to my Roon Remote, I noticed that a track was buffering. I didn’t want to listen to that track so I tapped on “next track”. The next track started to buffer for about 30s and I thought, “it isn’t working”. So I then went to look at the queue list and realised that the track I skipped earlier was on buffer for 51 minutes!

There were many question marks on my head.

Hi @James_Song,

Thanks for giving that a try. We’ve confirmed that local content works okay and that it’s not endpoint dependent, so this narrows this down to issues with the Core processing the data or not receiving data quick enough from the servers (networking issues).

For our next test, let’s try going to Settings > Services, selecting TIDAL, and changing the streaming quality to Normal. Is there any change after doing this?

Another thing that might help with potential networking issues is using Google DNS or Cloudflare DNS — Can you give that a try and let us know if it helps?

Hmm, changing streaming quality did not help.

So moving on to Google DNS configuration, I’ll report my findings after a day or two.

1 Like

Reporting back…

Google DNS did help a teeny weeny bit on Roon Core PC.

I also noticed a pattern - restarting Roon Core helps to stabilise the streaming for about two hours before symptoms appears.

That said, it does not mean that the streaming experience is seamless. Rather, the time to buffer each track is about 10 seconds on average. However, the worst buffering time (or rather i am willing to wait) is about 10 mins or so.

FYI, the Roon Core PC runs almost 24/7.

Thanks for the update, @James_Song.

Do you have a device you could try using as your Roon Core that has an SSD? We always recommend that you use an SSD whenever possible, so it’s possible that this could be playing into things. It would also help determine if this is networking related or specific to that Core machine.

Hmmm, I’ll try to see what I can do on my end, no promises on the SSD.

On the other hand, the Roon Core was working fine with Hybrid HDD previously, am just wondering if it wasn’t a case of storage drive?

Hi @James_Song,

It’s hard to say just yet whether or not the SSD might be playing into things — Testing with another Core machine would definitely help us narrow things down a bit. If things work on the other machine then we know it is likely something specific to the other Core that is occurring. Alternatively, if neither machine works, it points to something broader, like the network having troubles.

Another test here would be to temporarily connect your current Core machine to a mobile device using USB tethering or hotspot. While that’s not an ideal network long-term, it would be helpful to know if the behavior changes at all when doing so.

I do not have another machine to try it out… unfortunately. I’ll go ahead with hotspot networking.

Will report back my findings in a day or two.

Hi @James_Song,

I just wanted to check in and see if you were able to do this test. Let us know if you have any questions!

Reporting back - the experience is similar but worse. Maybe takes additional 5 seconds or more to buffer the track,

However, something interesting happened - after switching back to local home wifi, things are better than before.

Hi @James_Song,

Thanks for the update here. That’s definitely an interesting observation. If you get into this state again, maybe try just disconnecting and reconnecting the network — Do things improve after that? While not a permanent solution that would definitely be an interesting data point that should get us on the right track for understanding the root cause of the issue.

Things improved quite dramatically, and it does not occur as frequently as it was in the past. I will continue to actively monitor the situation.

Previously, I have tried to flush ip address and dns via command prompt, but to no avail.
Forgetting the wireless connection and reconnecting with password - did not work.
Restarting my Linksys MESH, also did not work.

For those who are following this thread: what works now (for me at least) is to connect the core to an entirely separate network, then restart computer, and then listen to music for 1/2 day, and then connect to my home wifi. It worked for some reason that I cannot explain.

Hi Dylan,

The same presenting issue is happening again after new Roon core update.

Hi @James_Song,

There were two updates recently — Build 536 and the next day (yesterday) Build 537. Build 537 includes some additional TIDAL changes, so just to confirm, is this still happening on Build 537?