Roon / Tidal streaming has broken completely for me [Resolved: Router issue]

Core Machine (Operating system/System info/Roon build number)

Imac Pro / Mac OS Mojave / Roon 1.7 Build 537

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

I have 1 gigabit fiber up and down from AT&T. Gigabit comes into the ATT supplied modem, a Pace 5682 AC. The Pace modem is connected via “DMZ+ mode” to my Netgear Orbi router over ethernet (this is the closest thing the Pace has to a bridge mode). My Orbi is then connected to the iMac Pro over ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

My preferred setup is KEF LSX speakers as Roon endpoint. The LSX speakers are also connected via ethernet to the Orbi. Since experiencing problems I have also tried using the iMac system output to eliminate variables, and I have the same problem.

I also have various other Roon endpoints in the house, but have been trying to troubleshoot on the iMac as its the simplest setup.

Description Of Issue

Tidal streaming has basically stopped working from Roon. Tracks take a very long time to start, if at all, and then will play the first five seconds or so and then stop. Playing local files works fine. Playing Tidal directly in a web browser on the iMac works fine.

This all started happening when I upgraded from a Linksys router to the Netgear router, so it seems very likely it is some confluence of the new router and how Roon communicates with Tidal…because clearly Tidal can stream fine to my iMac using their web interface.

I’ve uploaded the relevant Roon logs here where you can see the Warn: Track Stopped Due to Slow Media errors that kill a track ~5 seconds after load:

Please halp? This is driving me nuts and the Orbi so far is great beyond this weird problem. =)

Hi @Rob_Sanheim,

Since this started happening around the time that you changed to the Orbi, let’s give the following a try:

  • Uncheck the Disable IGMP Proxying option in Orbi’s settings
  • Try using Google DNS or Cloudflare DNS
  • Clear the TIDAL cache in Roon (see steps below)

Clearing the TIDAL cache:

  • Stop Roon on the Core machine
  • Find and open your Roon database
  • Navigate to /Library/Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Restart Roon on the Core

Let us know if this helps!


I’ve tried all those items (had already tried the DNS changes and IGMP setting in the past few days in fact). Tried clearing the cache this morning.

Still having the same problem - Tidal won’t play in Roon, local music plays fine.

Thanks for the update, @Rob_Sanheim.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reboot the Core and then reproduce the issue once more and note the time at which the error occurs as well as the track that you’re trying to play? Then respond here with that time and track name, and I’ll make sure we review the diagnostics related to that timestamp.


So I figured out what this was. Not a Roon or Orbi problem at all.

It all came down to AT&T’s Pace 5682 modem that I was required to use. This is one of the modems that ATT leases to customers on their fiber plans…and you required to use it for initial authentication on your connection.

The Pace has a horrible reputation if you search around ATT related forums, but it worked mostly okay w/ my previous router. When I introduced the new Orbi router, things got a lot worse. The Roon dropouts started, some tv streaming services not working at all, etc. So I decided to remove it from the mix entirely using a “manual bypass” method, and everything started working 100%. Roon is fine, no more dropouts!

If any other ATT customers come here w/ the same problem, take a look at the posts below for how to do the manual bypass. There are also more complicated ways to bypass it, or you can try to request a newer modem form ATT. Good luck!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Thanks for following up with this information, @Rob_Sanheim! Glad to hear that things are working for you now. Happy listening :headphones: