Roon+Tidal with slow internet connection

I’m new to Roon and in my free trial period. I’d appreciate if anyone can help me here.

I live in rural Montana where my only internet option is a slow DSL cnnection. When I play Tidal via Roon, I can usually play 20-30 seconds of a song before it cuts out and then stops. Roon shows an error message that says: “Tidal Media is loading slowly. This may indicate a network or connectivity problem.”

Are there any settings in Roon that might help with this problem, e.g. increased buffering that I should be aware of?

I previously streamed Tidal through my Oppo BDP-103 player without any problems have also been able to stream Tidal using Squeezelite and DietPi, so I know it’s possible to stream via Tidal. Roon is the only software I tried that seems to struggle with my limited bandwidth.

Thanks in advance for any help!

Is this a sudden problem today or is it always like this.

This is only my 2nd day with Roon, but it’s been this way since I first started playing Roon last night.


There has been an issue with the roon infrastructure. Try rebooting everything and see if it gets better.

Did a reboot of my Roon core, and I’ve now made it through 2 entire tracks without any problems. Thanks for the suggestion ged, I continue listening but hopefully this did the trick.


1 Like

My tip if you have a problem have a look around the forum first. And always ask for help, we’ve all been there :wink:

I have 5 days left on my roon trial. With my slow internet speeds, I am unable to stream either Tidal or Qobuz via roon. However, they work fine if I play them on a computer outside of roon. This tells me there is doing something to the audio data.

Can someone tell me if there is a setting somewhere that can either (a) limit the streaming resolution to mp3 quality (maybe this would let me stream music), or (b) change a setting that could be taking up extra bandwidth?

Thankfully, with Qobuz I can at least download and play high res music files. But then roon becomes mainly just an expensive file organizer.

Thanks for any help.


Not sure I have an answer for you but I do have a couple of questions and suggestions.

What is the download speed of your DSL supposed to be? Who is your provider? What router do you use?

What type of Tidal & Qobuz subscriptions do you have? It sounds to me like you may have the higher quality tiers which would seem reasonable if you can stream them on your computer. If you do currently have their higher tier ( more bandwidth required ) subscriptions you could drop back to a lower tier and reduce your bandwidth needs but then you would get lower quality audio.

While I don’t work for Roon or claim that I’m an expert at how it works it appears to me that it does tax one’s networking infrastructure more than other services. One suggestion that has helped other users with issues streaming from Tidal & Qobuz has been to switch DNS servers. Typically the router one uses is provided with the ip address of one or more DNS servers belonging to their Internet provider and in some cases using them with Roon causes streaming issues.

Two of the most common alternative DNS providers are CloudFlare ( ) and Google ( ). Typically one edits the Internet setup on their router and replaces the ip addresses of their provider’s DNS servers with alternative addresses like I have done on my Netgear Orbi router:

Please note that since my router lets me specify three DNS servers I also use Quad9 ( ) in addition to CloudFlare and Google. They are used in order and based on what I’ve read CloadFlare and Quad9 are supposed to be the faster than Google so I entered their addresses before Google’s.


|### Zack Holden|7:15 AM (2 minutes ago)||

to Tim


Thanks for your response Tim.

The only internet available to me is through CenturyLink. I have a router purchased through them (ActionTech, I think). The download speeds I get are typically around 1.3 Mbs. It’s very slow.

I have both the high-res Qobuz and Tidal subscriptions. My next step will be to try changing the subscription to the low resolution option and see if Roon will allow me to stream lower resolution files. I tried changing the subscription for Tidal, but the change wouldn’t take effect until next month, too late for me to test during my free trial.

I will try changing my DNS provider tonight to see if that helps.

I am assuming from your response that there is no setting in Roon that will allow me to select lower quality mp3 stream rates. If anyone knows different, please let me know.


You can only stream what the provider sends. No switches.

Hi @Zachary_Holden,

Thanks for contacting us regarding this issue. 1.3 Mbps is indeed a very low speed to be trying to stream hi-res content with, the DNS change suggested is a good one to try and I can suggest a few other changes, but I can’t say for sure if it will help:

  • Try setting a larger buffer by right-clicking the Zone -> Device Setup -> Show Advanced -> Use Maximum Buffer Size

  • Try to disable MQA Core Decoder

  • Sort non-FLAC TIDAL files that you have added to your library. To find these types of files you can navigate to Track Browser (Left-hand menu -> Library section -> Tracks) and then create a focus selection on TIDAL AAC content.

Also a few other aspects to look over:

If all of my above suggestions do not help, then it would appear that the connection itself is too slow to handle the load and I would start taking a look into USB Hard Drive Media storage.


Hi Noris,
thanks for your help.

I will try your suggestions tonight.

My core is an i5 CPU with 8 GB of RAM and should be fine for running Roon
(I have friends with the identical machine who have no problems).

I am connected via ethernet cable directly to my router.

Honestly, if I could stream even mp3 quality music, I would keep Roon. That
would at least allow me to hear new music. If I like something, I’ll
download the physical media with Qobuz and then play it locally.

Is there any way for me to test out mp3 streaming? In Qobuz, I can change
the resolution settings on their web player, but these don’t propagate to
Roon, My only option it seems is to change my Qobuz plan to the low
resolution. However, this will take a few weeks before I know whether this
works, since changes to my Qobuz plan will not occur until the next billing
month. Too late for me to test during the end of my Roon trial period.

Any suggestions are welcome and thanks again for the help.

Hello @Zachary_Holden,

There is unfortunately no way to change the quality of the stream. While I agree it would be a good idea, this would be more of a feature request than current Roon behavior.

Please let me know if my suggestions help but as I mentioned before, the bottleneck here appears to be the internet connection itself and other than my above suggestions, not much else can be done at this time.


Unfortunately, I am still unable to stream music from Qobuz or Tidal via Roon. Even after changing my subscription to MP3 Quality on Qobuz, I’ll get 15-30 seconds of music, followed by the “Qobuz media is loading slowly. This may indicate a network connection problem” message. I have also changed my DNS to google public, this didn’t seem to change anything.

I can still stream Qobuz, Pandora, or Spotify from any other device in my house without any problems, which suggests this is an issue with Roon.

Before I cancel my subscription, I will submit a feature request. However, I am not sure exactly what I should request. Perhaps a switch to turn off any extra data processing (e.g. the little sound wave and progress bar below the track)? Maybe better buffering? I’m sure this problem could be solved with code, but I realize I’m a rare case, and probably not worth a lot of extra work.

Thanks for the efforts to help. Any other suggestions are welcome.

Hi @Zachary_Holden,

Sorry to hear that it is still not working as expected even with the Qobuz subscription change :frowning: . I would definitely recommend submitting a feature request along the lines of “having an ability to set the maximum quality of tracks from streaming services” or if you feel that best meets this type of issue here.

If you try to play one of Qobuz’s or TIDAL’s lower resolution streams that are AAC or MP3 format (by going to your library -> tracks -> focus -> TIDAL + MP3 + AAC, then that has no issue, correct? The bottom bar does not really take up network bandwidth, it is more the buffering side of things that are slow here and fundamentally the internet connection not being up to par for high-res streaming is the main issue.

It is possible that direct streaming from Qobuz/Pandora/Spotify do not take up as much bandwidth or the apps have an “adaptive bandwidth” mode where it automatically lowers the resolution until it buffers without issue, Roon currently does not have this feature. Pandora and Spotify do not stream high-res so it wouldn’t have this issue and Qobuz is likely implementing the adaptive streaming model I mentioned.

We would be happy to revisit this issue in the future if you upgrade your internet and I can discuss with the accounts team about providing you a new trial after upgrading but other than the suggestions I mentioned earlier in this thread, I’m not sure what else can be done for the slow internet connection, sorry.


A post was split to a new topic: TIDAL not working through Roon - No internet