Roon Unable to Connect/See PerfectWave DAC or MAC mini

Core Machine (Operating system/System info/Roon build number)

Intel NUC8i7BEH using Room Optimized Core Kit ROCK
Roon OS: 1.0 (Build 227) stable
Roon Server SW: Version 1.7 (build 571) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NUC attached to NETGEAR 8-port Gigabit Switch (GS308-300PAS) switch on Wifi Router Asus AC1900 DualBand on Sonic Gigabit Fiber. – Middle Floor Location next to window in floor center

Top Floor: Linksys AC1200 Wifi Extender #RE6500
Lower Floor: Netgear ac1200 Extender EX6150-100N

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  • Mac Mini as music server, WiFi
  • PS Audio PerfectWave DAC MKII firmware v3.04 with Bridge II (firmware update n/a) ethernet cabled to Linksys Extender
  • 2 Sonos Connect, WiFi
  • 1 Sonos S3, WiFi
  • BlueSound Node 2, WiFi

Roon Remote Devices so far:
iPad Pro
Samsung Note8 Android

Subscriptons to:
J River
Tidal HIDef
MConnect

Description Of Issue

TEXT GOES HERE
Roon is unable to see the PS Audio and Mac Mini music server.
Everything else connects without issues.
Researched forums, googled and tried to tweek w/o any luck.

Which bits of the network are they attached to?

Hi Ged…Not sure what you meant by (which bits…). My PS Audio Bridge ii is still not able to connect to Roon. I’ve attached the bridge directly to router And to the switch with Ethernet cable with no luck.
However, my PS Audio Perfectwave still works well with Jriver, MconnectHD,Tidal and Sonos apps.
Please be advise what else I should do.
Thanks
James

I wondered which equipment is connected directly to the switch and what is connected to an extender.

Hello @JamesW, if I understand you correctly, the PS Audio is connected via Ethernet to a range extender. Can you try connecting it to the router? We recommend against extenders and managed switches in our networking best practices, so simplifying your setup should be our first step.