Roon ver 1.8 says "Lost control of audio device"

Roon Core Machine

Windows 10 Pro, 64-bit, Processor Intel(R) Core™ i5-4690T CPU @ 2.50GHz, 2501 Mhz, 4 Core(s), 4 Logical Processor(s), 16GB RAM, Dell Optiplex 9020 SFF

Roon bridge is a RPi 4 running RoPiEEE

Roon Version is 1.8 (and problem started after this update). Previous version worked fine for many months.

Networking Gear & Setup Details

Arris, Fios Quantum Gateway router, wired connection for Core

Roon Bridge has wired connection with FiOS Network Extender.

FiOs Network Extender connects to primary router (Quantum Gateway) directly through room-to-room coax to eliminate WiFi from entire signal path.

Connected Audio Devices

Roon bridge RPi4 is connected via USB to a Schiitt Modi Multibit DAC via USB

Number of Tracks in Library

12,024 tracks

Description of Issue

After a few moments of playback, get a “Roon lost control of audio device” message and music stops playing until I hit “Play” again. Have rebooted everything in the chain multiple times (except DAC), including router/extender. It was happening in a few seconds, but I have reset DSP to “default” settings and now it takes a few minutes - maybe half a song before it exhibits this behavior.

Thanks

It could be many things, but the top of the list is WiFi. In general, Roon does not fare well with Wifi anywhere in the chain.

If you can, as a test, take the extender out of the chain.

No Wifi. The extender connects to primary router via coax. The bridge connects to the extender via Cat5. core connects to primary router via Cat5. So entire network signal path is wired.

Hi @Rahul_Nair,

Before we proceed with troubleshooting, it would be helpful to try to eliminate a few variables in your setup to try to pinpoint the offending device.

  • Have you encountered this issue without the Raspberry Pi in the mix, connecting the Schiit via USB to the Core?

  • From there, what if you play from the System Output of the Core while wired to the extender? Any issues with playback?

  • Lastly, as suggested, you can test without the extender (even if wired).

In summary, try to remove variables one-by-one from your chain, and then build back, to identify the point where the audio is failing to pass properly.

We’ll be watching for your response.

1 Like

Hi Connor,
Apologize for not responding earlier. I did try and eliminate variables one by one, and was eventually able to identify the issue.

Everything had worked swimmingly fine before all this, so it was actually quite surprising when the issue began. I am eventually theorizing that the Pi4 is finicky about which USB port I connect the DAC to. As I went through the 4 ports, I found that I got erros on both black USB 2.0 ports. It also failed with the first teal 3.0 USB port but took a while. It is now a robust connection and not failing at all with the second teal USB port.

So we can consider this issue resolved and close this thread.

Thanks a bunch.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.