Roon via Mutec DDC to Lampizator DAC

I am in the process of burning in a Lamptizator Baltic 3 DAC and trying to figure out the best way to use it. With my previous systems I have used a DDC to re-clock the USB input from my Roon NUC endpoint which runs AudioLinux. This allowed me to use the AES input of my previous Schiit Yggdrasil, its best input.

First of all I am very impressed with the sound I am getting using USB straight in to my Baltic. It may be it’s best input. I know that in forums where Lampizator DACs are discussed I never see others using a DDC. Having said that I want to circle back and at least try my Mutec USB and Denefrips Hermes DDC’s. It is easily possible that the Baltic USB will sound better and I can happily sell off some equipment.

This morning I set up my Mutec to use AES into the B3. Once I got it configured it sounded very good but whenever I turned the volume up or the music had a crescendo I got a lot of static. I would say that it was clipping but it really sounded like an issue in the digital domain. I have always used Roon set to “Fixed Volume” so that is where I started. To me it always sounded best. Cutting to the chase, what I discovered was that I had to set Roon to “Device Volume” and drop the digital volume control to 75 of 100. I seems as if the digital AES output of the DDC was overloading the B3 AES input.

Any ideas?


Does the same happen if you use Toslink or coax SPDIF instead of AES/EBU?

Toslink seems to work well. SPDIF has the same problem as AES.


Mutec is usually very ‘tight’ on protocol spec. Might this be a bug in the Baltic 3? First time I hear about a digital interface like this generating clipping…

Thanks for the input. I am calling it clipping but it sounds more like the digital version of “clipping”. I did not know that was a thing!

It is likely wrong to call it clipping. Your description “overloading the B3 AES input” is probably what happens.
Roon has a “Headroom Management” in the DSP section with a good explanation of digital clipping

Post a screenshot of your Roon signal path.

Make sure volume leveling and DSP Engine are disabled, and you are not grouping it with other endpoints.

Thanks @OGS and Peter.

That was an interesting article. I do not have DSP enabled and so do not have headroom management enabled. I could enable DSP long enough to use the clipping indicator to see if it is happening. At that point I could try dropping the digital gain and then evaluate the sound quality. So far USB sounds excellent.

Oddly if I turn on “device volume” and drop the volume it will stop the distortion and is still lossless

Peter. I do not have any grouping enabled. Baltic is it’s own group as is Mutec when it is in the system

Here is my path using USB. The only difference using AES is that Mutec replaces Lampizator in the path.

I may try my Denefrips Hermes DDC today to see if it is a better fit for the Baltic using AES.


Power off the Baltic. Set the Baltic to Lo Gain. Power it on. See if it makes any difference.

Thanks again Peter. I tried that during my original troubleshooting although I did not power the DAC off first.

The results were the same. From the description in the manual it did sound as if that change would be to the analog tube circuit, not in the digital domain. The distortion I hear sounds more like static than what I have experienced by overdriving an amp. Also if I turn on the digital volume control in Roon and lower it then I can eliminate the distortion. The SQ does not sound as good to me as using Baltic’s USB input though.


The signal path shows you’re not doing DSP or volume leveling. If possible, try other SPDIF inputs.

If this problem is not restricted to one particular track, you should contact the manufacturer.