Roon waiting for server issues

Main Roon Server 2.0 build 1357 running on MacStudio M2 Ultra / 192G RAM OS Ventura 13.6.1. This is in my office on one side of the house.
Main router (fast Virgin cable) set up as modem and I use an ORBI12 mesh netwrok system for wireless with three points around the house. But my MacStudio (Roon server) is connected by ethernet into the ORBI12.
My main listening setup is in my lounge also connected by ethernet from ORBI12 direct to SOtM SMS-200 Ultra then to Chord Qutest, amp etc.

In my office, where my Roon server is, for less critical listening I use Roon 2.0 build 1357 on the MacStudio to connect by WiFi to a Chromecast Audio network server connected to my Naim amp - speakers on my desk (Rogers LS3/5as).

Most listening is done using TIDAL for streaming but I also have a network disc connected (by ethernet) with 43,285 tracks on it. When listening in my office, Roon remote is on the same Mac as Roon Server. In my lounge I use either my iPhone or a MacBook Pro as my Roon remote controller.

For some time now (months) I have been losing connection between Roon remotes and Roon Server. This happens both in my lounge using either phone ot laptop as the remote, but also in my office on the same Mac as my Roon Server and Roon Remote. This can be for a few seconds when a small window pops up with the message ‘Waiting for your Roon Server’. When this happens, Roon also loses the connection to the Chromecast temporarily, though not always and it usually comes back. More annoyingly I can select a track to be played (TIDAL or on disc) and nothing happens at all. The progress bar at the bottom of the screen (showing timings) just has a small moving bar (instead of a circle) flashing backward and forward along the bar. Nothing happens from anything from 30 seconds to several minutes before Roon continues playing from wherever it was. This can also happens when playing a playlist between tracks - it just stops playing but comes back minutres later. If I reboot my MacStudio (Roon Server) then it disappears for a period of time, sometimes a day or so if I’m lucky. But the problem reoccurs and eventually degrades until it happens frequently, necessitating another reboot. It does seem to be getting worse and it’s frustrating, hence my post.

If I play from TIDAL direct or from my NAS drive direct, cutting out Roon, then this problem does not exhibit itself - everything runs smoothly, so streaming/networking does not seem to be an issue.

Any ideas welcome please.

Hi @Mike_Cryer,
Thank you for your patience while we worked through the queue. If you can provide a date and local time when you’ve experienced this issue we will activate diagnostics on your account to investigate this further.

It happens quite often. I included a screenshot which will have a date/time on it. Otherwise I will note specifically when it next happens.


Can’t see a screenshot with a date and time :slight_smile:

Hi Daniel,

The problem I mentioned in my post has been happening regularly. Sod’s law, since I posted it has not occurred again until today. BUT yesterday (13 Jan) Roon Remote running on my Main MacStudio (where I keep my Roon core/Server) crashed while I was playing music. And the music kept on playing. Subsequently, I didn’t reboot my MacStuidio and just used my iPhone and MacBook Pro to play music/playlists etc using these Roon remotes and the problem has stayed away. I’ve been able to play anything I like through Roon without the interruption up until last night.

I suspect that this is down to how Roon now works with Roon Server starting up automatically on reboot and running in the background. So today (Sunday 14th) I did a test - I rebooted and restarted Roon Server early afternoon and didn’t start the Roon Remote on my MacStudio. I streamed using just my iPhone and everything worked OK through the day listening in my office. I then started Roon Remote on my MacStudio in my office which worked fine for a while. I then moved to my kitchen and left Roon Remote running on my MacStudio, but used the Roon Remote on my iPhone again to stream/listen in the kitchen. At around 16.35 local time today my iPhone Roon Remote froze. I had been playing Foxwarren’s album ‘Foxwarren’, I finished that and Roon suggested an album by Andy Shauf (who’s in Foxwarren) and it was while playing this that Roon Remote on the iPhone froze. I rebooted the iPhone Roon Remote (approx 16:55) and it came back in playing Foxwarren again so had jumped back from the Andy Shauf album.

I then quit Roon Remote on my MacStudo, leaving just the Roon Server running and used my iPhone to control what I was listening to. So far this has been stable.

I will continue to test and run things without running the Roon remote on my MacStudio, but I suspect that the problem is having both Roons - Server and Remote on my MacStudio running at the same time - there is some sort of conflict there. If there’s something there you can look at I’d be grateful.

Hi @Mike_Cryer,
Try plugging your core in via ethernet.

My core is on my main desktop/MacStudio which IS connected to my router by ethernet cable. However, I did have WiFi enabled on that computer. Perhaps that was causing Roon to be confused so I have turned of WiFi and will see if the problem persists. Thanks for your help and I’ll get back in a few days to let you know what happens