Roon Web Display works in Windows but not on a iPad

Hi guys, I have a problem getting Web Display to work on a iPad.

Roon Core is running on a synology NAS.
When I type my server adress on my Windows10 computer and enable the Display in the roon settings, Firefox is showing the played music.
If i do the same on my iPad, I just can see “roon”, independent from using Safari or Firefox.
The “display-button” is missing in the Volume Menu, so can´t enable the display. I tried this on a iPad using the latest OS Version and on a old one using OS 9.5.3.

Already tried to reboot all roon clients and the roon core server.
Anyone out there with a good Idea to solve this?

Hi @Matthias_Dichtl,

Can you share a screenshot of the Displays settings in Roon? Does the iPad’s web browser show up there?

Are you controlling Roon from the iPad as well or are you using a different remote?

Hi Dylan,

Meanwhile i detected that a iphone8 in the same Wifi is working well, but the iPads still only show “roon”.
I´m controlling from the new iPad, the ols ipad (OS 9.5.3) just show be used as a display.

Hi @Matthias_Dichtl,

Since you’re controlling Roon from the same iPad, the Web Display will become unavailable because the browser is in the background and not actively running. The best option is to use the now playing screen or leave the browser running and control Roon from a different remote.

Understood, but I if I do control via Win10 PC the problem stay almost the same.
The new iPad is working with Safari, but not with Firefox what i usually use. But o.k. using Safari is a acceptable workaround.
But the main issue was and is that I want to use my old iPad2 as display only (Roon Remote and Firefox can´t be installed on OS 9.5.3).

Hi @Matthias_Dichtl — Can Chrome be installed on that device?

Unfotunatelly not, i tried to install several browser opportunities… with no success :frowning:

Hi @Matthias_Dichtl,

Just to verify, if you try using a Web Display from the Windows machine, does that work for you?

Yes, also an old android tablet with Chrome works fine.