Roon will no longer sign in to Tidal after latest update

Core Machine (Operating system/System info/Roon build number)

IOS 13.3.1/Nucleus192.168.1.203/Build 511

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ASUS rt-n66u via Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

BlueSound vault 2i

Description Of Issue

Immediately after update this morning Roon will not sign into Tidal. Error message says Missing Method see Settings. When I go to settings all it does is ask for User and Pass which when entered prompts the Missing Method error message again.

I had the same thing. New protocol I guess, requires login from a browser window. Very weird and Roon probably should have mentioned this with their software update notes. Better yet, pop a message in Roon.


A post was split to a new topic: TIDAL - Too Many Failures/Track not currently available

Same here… I logged back into Tidal, closed Roon and opened it again then it was fine. It also updated Nucleus too so all good here :slight_smile:

1 Like

Yes, had to log in to Tidal multiple times, reboot Roon, reboot MacMini and finally (took about 10-12 attempts) Tidal & Roon integrated again. So far, seems to be playing fine.
MacMini/OS Mojave 10.14.6/ wired ethernet connections (modem > switch > Mac > PS Audio DS Jr DAC)

8 posts were split to a new topic: Can’t login into TIDAL after Build 528

Logging in from a browser seems to have fixed it. Thanks James_I I most likely would not have tried that as I almost never use Roon at the computer.

1 Like

It worked via browser on iOS/smartphone on second try.

I have the same problem… logging into Tidal via browser did not fix it…


K, finally the connection happened after a reboot. It wasn’t a straightforward login - the browser is launched and an oauth process happens. All good now. Thanks!

A post was split to a new topic: Could not login to TIDAL after build 528 update

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.