Roon will no longer start up on my Mac

iMac 5k, 27" 2019 running MacOS Big Sur v11.2.2 (20D80)

Roon will not open, I am only getting a blank Roon screen with the Roon logo in the middle. I had been running the newest release (I’m afraid I can’t tell you what version number this is as Roon won’t go to the “About Roon” page. This version had been running for a few days.

I am not aware of any configuration changes that I have made.

I have tried to uninstall Roon and re-install the latest version but this has the same problem.

This machine is my roon server so the other devices cannot open either.

I am trying to run this all locally on my Mac at the moment.

Can anyone help?

Nick

Have you rebooted the pc

If so uninstall Roon reboot and reinstall

Worth a try

Hi Mike,

yes I have rebooted (multiple times) including a full unplug. I cannot complete a re-install, Roon gets stuck in the same way. I gives me a window with the Roon logo in the middle but it never moves on from there.

Nick

Unfortunately I am all Windows so not much help

Have you restarted network gear as well sometimes Roon hangs “talking to home based cloud”

Hi Nick,

Pull the power cable out of the back of the Mac then hold down the power button for 10-15 seconds. Plug the Mac back in and boot.
You should find that your Mac boots faster and it may solve your problem.
Hope this helps.

Alex.

Hey Nick,

maybe this helps - I had a similar issue.

Just be careful not to delete anything, please do rename stuff so you can restore everything as it was before - just in case…

Thank Oliver. I went and found all references to Roon and deleted/renamed as appropriate. I then re-installed Roon and all now seems to be good.

thanks,

Nick

I’m getting this problem sometimes when I start Roon on my MacBook Pro
image

Any clues?

Quick google search returned this.

The issue is part of the operating system. Which server is reporting the error? Is it your server or the SQL server?

Start by checking the system which is reporting the error, look for a stressed system. Check the normal counters for cpu, memory and disk.

This error can happen if the action was not completed in time. I have seen it on a cluster where the disk sub system did not complete the IO requests before the next batch was submitted.

Have you altered any files in the roon app? What is the ui_atlas file is my question. Is it corrupt?

Have you gotten roon to work before? Did you change anything since the last known successful launch if there was one?

UI atlas… user interface. Atlas. Map. @2x.spec. These files are all over iOS apps usually for graphics stuff. Icons and visual things.

So something graphics related is taking too long or stressing something and it’s crashing. Idk.
I’m just a plumber. :man_mechanic:

Not wishing to harp on but have you an absolute reboot of everything core, network, coffee machine

It usually works

1 Like

Hey Stephen,

I suggest you open a separate support request (go to Support and then click on New Topic)

Bildschirmfoto 2021-03-03 um 11.49.33

Bildschirmfoto 2021-03-03 um 11.49.47

as your issue seems to be a completely different one as the one of Nick. :wink:

This way it will be better seen by the Roon support.

Thanks, everyone. It only happens around one in four launches so isn’t critical. I’ll take it more seriously if it continues after I’ve completed a complete clean Big Sur reinstall. None of my Macs have been that great after Big Sur came along.

Tbh, I think Roon’s tech guys have enough problems at present without my minor one.

If you’re going to do a clean reinstall… why not just go back to 10.15. Give Apple a few months… they’ve already gone from 11 to 11.2.2 in this short period… by the fall they’ll be at macOS 12!

This is another good reason to stay away unless you have an M1 Mac.

There is no going back to Catalina for M1 macs

Valid point. Overlooked you were on a M1. Good luck. :slightly_smiling_face:

Did you try editing any of the theme files?

Daniel

No editing of theme files

Hi All,

I am still having real problems. Roon worked for a few days and has now stopped loading. When I try to open it all I get is a blank Roon window with the logo pulsating in the middle. It never moves on. I cannot access any menus when it is doing this.

I have deleted all references to Roon, run a full mac clean-up using CCleaner, reinstalled Roon, rebooted including from a full power cycle all to no avail.

My network has been rebooted several times too.

Any suggestions?

thanks in advance,

Nick

OK, I think I have now fixed this based on a suggestion from Oliver above. I renamed the Roon directory under Library (finder…Go to folder …~Library) and then re-installed Roon from scratch. So far this appears to have helped.

Nick

1 Like

Glad it helped! :smiley:

1 Like