Roon will not start again

I have the same problem. It worked great for hours while I was testing and just shut it down by accident and then it would not restart. Still in my 14 day trial but this is not good. Ran ProcMon and it is spinning in some retry loop reading tcpip\parameters registry keys and dnscache\parameters registry keys. Checked in Regedit and most don’t exist.

Hi @Ed_Wegryn,

I have moved your report to a new thread so we can address your issues on an individual basis.

I would also like to give you the steps to freshly install Roon up front since I believe it will be necessary anyway. Since you’re new to Roon, you might not need to bother with backing up and restoring databases.

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Will you please complete the template below? Once done, I will dig into your issue and see what I can do to help.

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM).

Networking Gear & Setup Details

Your networking gear (model of routers/switches/etc), connection types (Wifi/Ethernet), and any firewalls, antivirus, or VPN software.

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”.

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

I can do that, but the original post I replied to stated that he had done that multiple times and it worked until he shut down the next time. I saw at least two other posts that seemed similar. Do you have any sense that it will not just keep happening?

I also saw that another post had an issue with two monitors. I have two as well and had moved Roon from the main monitor to the second monitor while experimenting with it. It was playing something on a Bridge device elsewhere when I closed it. I assumed the Roon Window was just a UI component and the Core was likely some service that continued to run. Obviously that is not the case so when the music stopped, I tried to restart the Core and that was when it failed. I am a programmer so watched it startup in ProcMon and saw that it always just ends up in the loop constantly reading those registry settings (tcpip and dnscache).

Hi @Ed_Wegryn,

One possible way to work around this is to use Roon Server as opposed to the all-in-one client. Let me list the steps below and let you decide. Renaming the folders is a part of the process anyway!


Roon Server is a headless core solution. You can still use the Roon application on your computer to control Roon but the Roon Server application will handle core operations. Once completed, it will no longer be necessary for you to leave the Roon application open!


  1. Take a backup of your databases.

  2. Navigate to Roon>Settings>General and log out of your core then exit Roon.

  3. Download Roon Server and install it.
    Downloads - Roon Labs

  4. Once installed, you will see a taskbar Roon icon (both Windows and Mac). Click the icon and select launch at startup.

  5. Reboot to ensure Roon Server starts successfully.

  6. Open Roon and select the new instance of a core we just created!

Afterward, you can re-import your databases. This solution will also require your remotes to be connected to the new core and you’ll be prompted to do so when you open them.

Ok, that sounds like a better configuration anyway. So add the Server which acts as the always on Core and then the same Roon installation (once working) sees the new Core and only acts as a front end?

Still, my concern is doing this and having it come back. Found your logs folder and it is not dead, it is just trying to lookup songs from your web service and getting 404 and 401 errors after 1/2 to 4 seconds each. Seems that is on your end - unless somehow credentials are wrong - which seems could be fixed without reinstalling? I can upload the log file if that helps.

Also, your instructions for backing up the DB assume I can be in Roon - but since the problem is it never starts …

Hi @Ed_Wegryn,

If that is the case 100% of the time, the only course of action we can take is to point the new Roon Server core to the most recent backup once installed.

Let me know what the end result is. I have been monitoring similar issues with MacOS and so far, Roon Server has been a solid workaround with the normal UI being used as a remote.


But how do I make a backup since Roon does not come up ever?

Hi @Ed_Wegryn,

If you hadn’t set a scheduled backup or manually made one, the database would be gone. If you’ve only been on since the start of the trial, there wouldn’t be much in the way of data loss though. Your library is still intact and when you log into Tidal or Qobuz it would sync again.


Ok, so good news and bad news. I uninstalled Roon then installed the Roon Server. Then re-installed Roon and it locked up with white screen same as before. I uninstalled and told it to delete all settings and then re-installed and it worked. I played with it for an hour or so and re-setup my devices. It read through my 27k songs. I closed Roon a couple of times and re-opened and it worked. Tonight I just restarted my PC and tried Roon and it comes up white screen again. I got my phone and tried to play music on the PC and it works. So the Server is apparently started and fine. But the Roon UI does the same thing as before.
This seems like an easy case to figure out. It does it every time, I can send you log files, I can create a memory dump, I can even attach with WinDbg and check what the devs want. You are very responsive in the forum but I am not going to fork over $150 if it can’t stay running. And this does not seem unique to just my machine based on the other posts. And just re-installing is not a solution. There is a bug here handling something and I am happy to help the team debug.

Via ProcMon, it appears to be doing something different this time. Now it is just constantly doing the same things every few seconds

Hi @Ed_Wegryn,

To clarify, you did indeed follow the instructions I provided to reinstall?

The problem we’ve seen happening is when Roon is running on a second monitor, is that the case for you? Does it occur when you’re using Roon on the primary?


Yes, I followed your instructions minus the backing up of the DB since I didn’t have one.

Yes I have two monitors (think I mentioned that the first time). Yes it is frozen on the second monitor at the moment. It doesn’t save where it was so I guess I have to uninstall again to clear the stored window position (unless you know where in the registry you store that and I can delete it).

However, I am pretty sure when I opened and closed it several times, I had it on the second monitor as well. The trouble did not start this time until I rebooted the system after closing the UI but before restarting it.

This still seems like a really simple bug to track down. Is the dev team working on this and it is not just you in support trying to get people back up and running?


8 posts were merged into an existing topic: Roon for Windows keeps locking up on multiple monitors and saved_window_pos needs to be reset [Investigating]

Hi @Ed_Wegryn,

If you didn’t find that path and file based on my prior instructions to community users, wow but bravo either way.

We do indeed have an open ticket for this and are working to resolve the problem. I will bring this issue to a meeting tomorrow and see what I can do to either get an update or attempt to expedite as best as possible.

Thank you for your patience and help in troubleshooting this.


Very well. Thank you for your help.

Please note, I’m only marking this as resolved since we’ve identified the issue as a known one. Please feel free to message me on this same topic if you’d like.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

This just happened to me again so apparently it is not fixed yet? As a programmer myself, seems this would be an easy one. And in trying to find this post so I could “fix” my system - I found a half dozen others that seem to be the same thing. And somebody from support asking them about graphics drivers and re-installing. Maybe share this more broadly to same lots of people pain and trouble?

Let’s please move any further related discussion related to this issue to the main thread: